Installing Printer

I am trying to install a Canon Pixma MP160 on my computer. I have been following the directions off of the Canon website(Asia or Australia). This is the first bit of instruction:

Installing the libxml package
Depending on the selected installation type, the package required to install the printer driver may not be installed.

You must install “libxml-1.8.17-xxx.i586.rpm” from the installation disk before installing the printer driver.

Correcting cupsd.conf
Depending on the selected language, correct DefaultLanguage.
Open /etc/cups/cupsd.conf with an editor and add the following line at the end:
Example: In the English environment:
DefaultLanguage en_GB

Connecting the printer
Before installing the printer driver, connect the computer and the printer with a USB cable and turn on the printer.

Preparing the printer driver rpm
Before using the printer driver, you must install the “common package” and the “model-specific package.”
cnijfilter-common-2.70-x.i386.rpm -------- Common package
cnijfilter-mp160-2.70-x.i386.rpm -------- Model-specific package

Download the above .rpm files from the Canon Web site in advance.
(Where “2.70-x” in the above .rpm files is the version number.)

I found(on and installed libxml-1.8.17-480.47.i586.rpm

Then when I tried to run the common package it came up with a depedency error:

gtk+ is needed by cnijfilter-common-2.70-1.i386.rpm

Can anyone tell me what steps I need to take now? Thanks!!!

Canon is poorly supported, but I see here users have used the MP180 driver with good results
HCL/Printers - openSUSE

See if it is in the List via Yast and configure yours with that and see

Hi 2quick;

I read the problem that you want help with: as:

Then when I tried to run the common package it came up with a dependency error:

gtk+ is needed

I would suggest 2quick that you install gtk and gtk2

by opening YaST: do you know how to do that?

you will need your substitute user (su) root password ready;

and then go to software management;

and enter gtk in the available list;

if your system finds it, it should be in the main OSS repository;

if it does not show it as available, you need to backtrack to the main YaST menu;

select software repositories; and see that four are added: oldcpu recommends only four: two should be main OSS and non-OSS

let us know how you get along with this advice;

you should be on an excellent track with what you have done so far; you should be able to get your mp160 working; canon is “coming to the party” and supplying drivers for linux for newer printers; we need to praise them for that;

Did you install from a liveCD?

Thanks I will use that for a fall back if I cannot get the MP160 working.


I installed from a DVD

I have a few additional supositories, the 4 main ones and additionally NVIDIA’s, Packman, on for wine, and libdvdcss. Should I remove any of these additional ones?

After searching gtk, it came up with alot, I downloaded:

gtk, gtk-compat-devel, and gtklp.

The problem earlier was I was adding the + at the end; i.e. gtk+ like it was refering to.

I already had installed the GTk2 items.

BAAM! Installed both rpm’s fine!! Now I just need to make sure everything else works.

I do have another question, how do you edit the cupsd.conf file?

Thanks so much for the help!

Just got done, test page printed fine. Went into word and it also printed out fine! My day is starting off great!

it might be a details, and completly off topic, but one say it’s not good to have both packman and vlc repo set up together.
I would suggest that you ged rid off vlc repo once you’ve install libdvdcss.
It’s a compatibility issue.


well done! You are on a roll!

glad the Canon packages installed well;

to edit the printer settings, many folks now recommend editing CUPS by a graphical means:

open your browser: Firefox? and in the top line, type


this is only on your own computer, so there are no security issues we are all told;

many folks recommend copying and pasting commands, as it should ensure good copy! So you can copy the above

from the CUPS menu you can select: manage printers on the top line and edit

Out of interest: you say you went into “word”: which programme is that?

**Recommended Packages:
just realised I meant to comment there:

oldcpu recommends just four:

OSS, Non-OSS, Update and Packman

In this thread that is current on the multimedia page,

Check your multimedia problem in ten steps - openSUSE Forums

oldcpu comments in the post #3 about his four (only) recommended repository sources;

you may find the thread helpful to work through about using zypper by copy and paste of commands; and a howto on packages


Thanks, that work great! I did not know that you could use CUPS in the web browser.

I was referring to kwrite. Is that completely the wrong answer?

Good info on the link to the multimedia thread, thanks! I will modify my repositories accordingly.


Thanks I will give it a shot!

Just a side note, this site is awesome with everyone’s knowledge and support helping me get linux up and running. I have definitely been converted :wink:

we are pleased you are enjoying linux and Suse; kwrite ain’t a wrong answer; it is a very good word processor; everyone uses different things; abiword; openoffice

glad the CUPS was helpful too;

enjoy Suse

all best wishes

Unfortunately I have to bring up another question. It seems that the printer is no longer liking the setup. I deleted and re-added the printer and tried a various types of the drivers that it found. I can print out a test page, and then jump over to openoffice and print out a word document. Then I will try to print out a page from a .pdf file. Problem starts. It will not print the page, but will go into the que and sit there. Also it will now not print the openoffice document and neither will trying to print the test page from within Yast. I am a little stuck here.