Installing openSUSE11.1 on External USB Harddisk

Hi All,

I need some help on installing the above distro on my ext. hdd. I have a Sony Vaio laptop with Windows XP SP3 but don’t want to mess the partitions up on that.

I have already read through Installing SuSE on External USB Drive - openSUSE but couldn’t understand head or tail.

I’ve installed linux on my pc years ago. But never have I done an external hdd install. So please a step by step guide is very much appreciated.

Thanks & Regards

d – _ – ]b - [Ecronic]

Never done it either but obvious first thing to check is that your laptop’s BIOS is capable of booting from a USB drive…

It is bootable because I have an option in the BIOS and when I tried booting through the external usb gave me an error saying no OS found or something.


I am pretty sure the message was not “no OS or something” so be more precise on that, the answer “then you might have a BIOS problem or something” would be the only suitable one, because it’s most likely as a “No OS found” message comes from the BIOS (i.e. when there is no boot sector found on the medium you wanted to boot from).

Also you did not try to describe at all, what you really did, so if you expect decent help, give some decent information on that (and a link to the tutorial is certainly not sufficient, especially when the tutorial shows several alternatives).

The next (potential) problem after fixing that will be getting the needed USB modules into the initrd, but the tutorial is pretty clear on how to do that.

Hi Akoellh,

Thanks for your reply. Well as you had mentioned I checked my boot screen and here’s my report :).

I booted my laptop yesterday from the external hdd after copying the files off the via unetbootin. I believe this basically makes a live usb drive if I’m not mistaken.

The laptop screen goes blank and just shows a flashing cursor and nothing else. Could you advise if this is happening because I’m doing something wrong or is it that this particular EHD is not bootable at all. My EHD is FreeAgent Go: Sleek & Stylish Portable & External Storage Hard Drives | Seagate with 500GB capacity. Just for you info my hdd is currently partitioned as 250gb fat32 and the other half is just raw as I was planning on installing the Linux on the raw partition after formatting during the installation procedure.

Just to make sure if the iso package was not corrupted I then burnt the contents to a cd-r and booted via the cdrom and voila the system booted into the linux. So I guess the package is ok.

If there’s anything else you think I should be trying then please do let me know.

Thanks for your support.


Sounds like a corrupted/unusable boot sector.

Use dd instead of that unetbootin stuff, the last time i checked it, it was a bunch of crap.

I have no idea what I am talking about, but I have seen something similar myself.

My guess is that your EHD is bootable but that it doesn’t have GRUB set up properly. It may be that the MBR is missing or GRUB can’t find the info it needs to boot the SUSE kernel. When you make a bootable CD you don’t have to worry about grub at all. With HDs you do.

Have you/how did you install GRUB on your EHD?

Can you boot up with the CD into SUSE and attach the EHD? Then in a root terminal you can type ‘grub’ to open a grub shell. Now type ‘null (’ and then the tab key and grub will report all the devices it can detect as command line completion alternatives. Post what it says here.

The other important thing is to make sure the EHD has legit SUSE partitions on it. There should be 3. The first partition should be root, “/”, and have a directory “/boot/grub”. Please check this and post the contents of ‘menu.lst’ in this folder.

Once this is confirmed, the next step will be to make sure the grub config file, “/boot/grub/menu.lst” has the correct addressing in it for the EHD and then to install grub in the MBR of the EHD. This is very simple but we need to establish the correct addresses for the EHD’s grub or it will fizzle.

I’m no expert; these are the steps I’d take to make progress.

Hi traderbam,

Thanks for you replying my post. I installed openSUSE10.3 on my external hdd through my laptop since I didn’t have the new version downloaded yet.

Anyways coming to the point as you have described above I faced the same problem. I think the grub was written on to my laptop’s MBR and when the system restarted I was getting the “Grub error 1.3”. So basically what I did was removed the linux cd and the external hdd and then using my Windows XP cd booted up in recovery mode and did a “fixmbr”. So now I have the Windows XP back on my laptop working fine and the external hdd still has the linux installation on it.

Is there a way I can write the grub on the external hdd now without having to run the installation again? If not then during installation how do I specify where to install the grub?

One more question: What is the difference between Grub/ Lilo?

:slight_smile: Thanks for you help.



I have been dealing with GRUB for a couple of weeks now. It is sort of clever and sort of stupid. If you can boot up into SUSE (using your CD perhaps) with the EHD drive attached, you should be able to install grub correctly on the EHD.

From within SUSE, open a root terminal and type ‘grub’.
Now you are running grub and the prompt will be grub>.
You need to establish the drive name that grub uses to recognize the EHD. You can do this by typing:
grub> null ( <tab>
This is just a trick to make grub list all the drives it sees. You then need to make an educated guess as to which is the EHD.
Then you set grub to point to the first partition of the EHD using:
grub> root (hdx,0)
where x is the correct drive number. It may not be hd for a EHD - I’m not sure.

Now you just tell grub to install itself and the menu.lst configuration on the EHD:
grub> setup (hdx)

That is it. But there is a catch! The default menu.lst file (which should be located at EHD/boot/grub/menu.lst) is set up by SUSE with absolute drive addresses. This caused me hours of fun as I tried to figure out why I couldn’t boot! The motherboard bios, it seems, changes the drive numbers when you change the bootup sequence. This stops Grub finding the correct bootable kernel on the correct drive.

So you may need to edit the menu.lst file on your EHD. For example, it probably needs to reference hd0 if you are going to set the EHD as the first boot drive using your bios. I discovered a trick to help with this which I will explain when you have posted your menu.lst. It is simply to add an instruction to menu.lst to make grub find the kernel drive number and pipe it into the root command. This makes the grub drive no. independent.

I’d like to know the drive designation grub uses for you EHD and the content of EHD/boot/grub/menu.lst.

FYI, my system has two internal HDs, the first is exclusively VISTA and the second is exclusively SUSE. The grub booter is on the SUSE HD. I’ve got it so that if I tell the bios to boot first from the Vista HD then Vista boots immediately. If I tell the bios to boot from the SUSE HD first then I get a GRUB menu that allows me to select either Vista or SUSE. It is really important not to have GRUB on your Windows HD, I have learned, because Windows has a totalitarian attitude and will wipe grub away on its HD at the slightest excuse: such as a reinstall or repair. Also, Vista service pack 1 (I think) crashes when grub exists in the MBR! I know, I experienced it.

I’m out at the moment. But when I chkd my downloads my suse11.1 has finished downloading. So I’m planning on installing it 1ce I get back. If everything goes well, then ill post the new menu.lst along with the grub desgnation :)m

Thanks again.

I don’t know, sorry.

hi traderbam,

I checked my downloaded file but it returned a checksum error. So I installed the 10.1 again and now am stuck with the same problems I told you about.

So, I proceeded the way you asked me to…

the grub> null ( <tab> command presented;

hd0, hd1

When I did a null (hd0, 0) it returned saying that “partition not recognised 0x30” &
null (hd1, 0) returned “partition is fat ***” I dont remember what the *** is since I have this one laptop to type to you and work on the linux. Will be taking my laptop to the office and then try everything once again and post the exact details from my office pc…

Btw, I did this whole procedure from the rescue mode after booting from the cd…