Installing OpenSUSE problem

I have installed OpenSUSE on my laptop beside Windows 8.When I boot up I get a black screen with the following message.
Welcome to GRUB
Attempting to decrypt master key
Enter passphrase for hd0,gpt4 ( lots of numbers here )

Looks to me like hd0 is the hard drive and gpt4 is something to do with the partition.I havent a clue what the master key refers to.
There is a flashing cursor,so obviously it is waiting for input from me but I dont know what to input.FYI I did not encrypt the disk in any way.Please help because I really want to try Linux but at the moment I cant even get back into Windows or my laptop PC.Thanks in advance.

Yes, “hd0” is your first disk, and “gpt4” refers to partition 4 on that disk. It seems that the partition is encrypted, and you are being asked for the encryption key.

I’m not sure how the disk would be encrypted without your knowing. Perhaps the computer was unattended during part of the install, and somebody is playing tricks on you. That’s about the best I can come up with.

If all else fails, you can reinstall. The installer will also ask for the encryption key, but you can skip that (maybe it is “cancel”). And then pay careful attention during the partitioning section of the install (that’s where any encryption would be configured).

Are you using UEFI or legacy BIOS for boot? GPT partitioning suggests you are using UEFI in this case you should be able to select Windows in firmware boot manager or BIOS setup.

I dont mind re installing but please explain how to do that,because as I have said when I boot up all I get is a black screen with that message.

Sorry,I dont fully undersand your answer.My laptop is a Lenovo and to boot from disk ( to install Open susi ) I just went into settings and selected boot from disk.It would be great if I could get back into windows because then I could format that partition and start over again.

If I restart the computer and press the ESC key and the Windows key I get the following message:
minimal BASH-like line editing is supported.For the first word,TAB lists possable command completions.Anywhere else TAB lists possable device or file completions.
Underneath that message the word grub printed a few times in a single column.

Hope this extra information is of some help in solving this problem.

Hi:

On every computer, there is some way how to enter the BIOS (a piece of ‘software’ on the motherboard itself that allows you to control things like what you’re booting from, USB, hdd, etc). To enter it, usually there is a key combination to press right when you press the power button. To find out what yours is, try searching the model of your laptop together with ‘enter bios’. Often it’s something like: “hold F2 while you power on the machine” or “press escape while you power on the machine.”

Once you have done that, you will be taken to the BIOS, where you can tell the machine to boot from, say a USB stick, or disk, to reinstall (and reformat) OpenSUSE on the partition.

Edit: Perhaps, to be more clear, I should add a list of steps:

  1. You should have OpenSUSE on a Bootable USB stick or on a DVD (for info on how to make one, you find this info at halfway down this page: https://software.opensuse.org/distributions/leap). I will pretend you have it on a USB stick for these steps.
  2. Put USB stick into computer
  3. Use keycommand while powering on to get into the BIOS where you will have to explore a bit and find out how to “boot from USB”
  4. Then you should be able to reinstall OpenSUSE from there, reformatting the partition as you need to.

Cheers,
SisPenguin

On a Lenovo computer, you should be able to get to the boot menu. Hit F12 as soon as you see the logo (probably says “ThinkPad” on the logo). Maybe keep hitting F12 until there is a beep.

I think it is F1 if you want to get into the full BIOS setup and not just the BIOS boot menu.

Hi SisPenguin,
I managed to get into the BIOS/Boot options but before doing anything else I thought I better run the options past you.The options are:
Boot Priority UEFI First
USB Enabled
PXE Boot to LAN Disabled

EFI opensusi-secureboot ( WD and lots of numbers )
Windows Boot Manager ( WD and lots of numbers )

On the EXIT screen I get:
Load Default Settings
OS Optimised DEfault < Win 8 64bit >

Over to you

Hi nricket.
Thanks for that info.As you can see I got into the boot Info,using Fn and F2 but it will be handy to be able to get into the Full BIOS as I might need to change other settings later.
The thing that brasses me off the most about all this,is that I have been wanting to try Linux for a while now and when I saw a magazine in the newsagent called “Getting started with Linux” I bought it and followed the instructions in the mag along with the included disk of Open SUSI.The magazine is put out by www.linux magazine .com and the installing information for Open SUSI was incomplete.There is one part during install where it asks me what file system to use and the magazine does not mention this at all.I went with the default which was a three letter file starting with W.For all I know this could be part of the problem.

You consistently misspell openSUSE.

Windows Boot Manager ( WD and lots of numbers )

This is your Windows.

Okay, so I’m not really a Lenovo user so I don’t know as much about their BIOS, but here are some basics that I think will help:

Boot Priority UEFI First -> What this means is that the first thing the computer tries to boot from is the UEFI partition, it’s a modern partition that has boot instructions for your computer. We’re assuming that something might have gone wrong with the OpenSUSE install and so this is looking for GRUB but having trouble from there. As long as the Boot Priority is set to UEFI First, it will always look at the UEFI first, if you want it to look elsewhere (like at a DVD or at a different place) this would be the thing to change.

USB Enabled -> This means that you are allowed to boot from a USB stick, that’s a good sign for switching to Linux on USB stick, not so handy if your distro is on a DVD.

PXE Boot to LAN Disabled -> this mean that this setting “PXE Boot to LAN” is not allowed right now. I’ve never used a PXE Boot to LAN so I honestly have no idea what it does, leave it alone would be my advice.

EFI opensuse-secureboot (WD + numbers) -> this is essentially telling you the location of the attempted install of OpenSUSE.
NOTE: If this actually says susi and it’s not a typo, then you’re not dealing with the operating system everyone in the forum thinks you are and this is probably a bad thing. If you’re trying to switch to opensusi, we don’t know what that is and that’s why we’re all starting to freak out about it because we’re wondering if we’re even supposed to be giving you advice because typos are a one or two time thing, and now it’s a many time thing.

Windows Boot Manager (+numbers) -> As arvidjaar mentioned, this is your Windows boot location.

So, what do you do:

  1. Answer the question (to yourself is fine): Am I trying to switch to OpenSUSE or this thing that is opensusi? If the latter, maybe search for that, because our advice will be all wrong.
  2. If you want to work off the DVD that came with the magazine, Go into the Boot Priority Menu (usually press enter and it will bring up more options) and tell it to look at something like “Boot from DVD/CD ROM”.
    2.5) If that’s not an option, i.e. you can’t find a place in the BIOS to boot from DVD/CD ROM, then you might need to enable Legacy Boot, there should be an option somewhere in the BIOS. An Alternative is to make a bootable USB via the instructions at openSUSE Leap - Get openSUSE (going to be honest, I mostly only use bootable USBs, so I don’t know so much about Legacy Boot).
  3. Once that’s done, you’ll be able to boot from the DVD, theoretically, and start to redo the installation.

If you want a step by step on how to go from top down, I can send you a blog post I made to help.

Cheers,
SisPenguin