Installing openSUSE on penryn MBP

I’ve tried installing openSUSE 11 x64 on my Macbook Pro three times, and every try failed. I tried first KDE 4.0, then 3.5 and finally GNOME. I know I have a x64 processor, but just to make sure, I then downloaded the x86 version. That didn’t work either. So I went to KUbuntu, and that failed.

Every time the install failed in openSUSE, it told me that several packages failed to install, and then a subsequent boot just to make sure told me to insert a bootable media into the drive. KUbuntu didn’t say that anything failed while it was installing, but when I tried to boot, it gave the same error.

What am I doing wrong? I thought it might have been the DVD being corrupt, but I downloaded three different images through ethernet, not airport, and every time I burned them, I let it verify. Am I missing something here?

My goal is to get openSUSE 11 x64 bit using KDE 4.0 running. If I have to, I’ll go to ubuntu x86 GNOME, but that’s the opposite of what I want. However, I really want to get some form of Linux running on my machine.

I apologize for that huge novel of a post, I ramble… And I thank you just for reading it.

EDIT: Never mind, the post isn’t that huge. The huge font size when typing a post is deceiving.

Follow the instruction mentioned in the link below :
Installation on MacBook/MacBook Pro Intel Core 2 Duo (x86) - openSUSE

It worked for me…
Only thing I did not do is create a lilo.conf file.
If you select Lilo as boot loader it should automatically create a lilo.conf file.
Good luck.