Installing OpenSUSE on mdadm > Encrypted > LVM fails to boot

My first attempt at installing OpenSUSE on mdadm with encryption and LVM has failed over the last 3 days. Here is some of my attempts.

My first attempt i use Linux Mint KDE to set up the partitions like this.

Make a boot 1 GB sda8 ext4
Make the Partitions to hold RAID0 (mdadm) on /sda9 /sdb7

mdadm --create --verbose /dev/md1 --level=stripe --raid-devices=2 /dev/sda9 /dev/sdb7

Next i encrypt the RAID0

sudo cryptsetup -v --cipher serpent-xts-plain --key-size 512 --hash sha512 --iter-time 5000 --use-random luksFormat /dev/md1

Then open it

cryptsetup luksOpen /dev/md1 lvm_encrypted

Make the pv, vg, lv

pvcreate /dev/mapper/lvm_encrypted

vgcreate OpenSUSE /dev/mapper/lvm_encrypted

lvcreate -L 42GB -n lvroot OpenSUSE
lvcreate -L 8GB -n lvhome OpenSUSE
lvcreate -L 8GB -n lvopt OpenSUSE
lvcreate -L 8GB -n lvsrv OpenSUSE
lvcreate -L 8GB -n lvtmp OpenSUSE
lvcreate -L 8GB -n lvusrlocal OpenSUSE
lvcreate -L 8GB -n lvvar OpenSUSE
lvcreate -l 100%FREE -n lvswap OpenSUSE

Now i close LVM and and lvm_encrypted and restart and put in the OpenSUSE Leap 42.1 Installer iin the drive and power up the installation.

It succesfully find and is able to unlock my RAID0 and then ask for password. Which also a success.

I then install OpenSUSE Leap to sda8 (boot ext4) and the newly created LVM.

Install goes fine and no errors pops up.

On the next reboot while trying to boot OpenSUSE Leap 42.1 it hangs right after it has found /dev/md1 and never ask for password. I attempted to use the rescue cd and succeded in assembling raid, unlock LUKS, mount all LVM’s together and make a new initrd.

But fails after succesfully finding /dev/md1 but still never ask for password.

After playing alot with OpenSUSE LEAP RescueCD part i ended up deciding to make it all again but this time using OpenSUSE LEAP Installer to configure the HDD’s.

So this time i boot up the OpenSUSE LEAP 42.1 installer (very simple this time since its all done with GUI) and create /dev/md1 out of /dev/sda9 /dev/sdb7.
Follow up by encrypting the partition putting LVM Volume Group “OpenSUSE” on it and creating the Logical Volumes.

42GB lvroot
8GB lvhome
8GB lvopt
8GB lvsrv
8GB lvtmp
8GB lvusrlocal
8GB lvvar

Installing OpenSUSE LEAP with /dev/sda8 ext4 as boot and the rest should be logical how i install.

On this first boot it ask’s for my password but hangs right after at Found device lvswap.

I have tried again using the RescueCD part of the installer assemble raid, open LUKS container and mounting all Logical Volumes just as it was a system and then making a new initrd. Still fails at boot telling me it found lvswap (as the only thing) and staying at thats screen until i hit the computers Physical Shutdown Button.

I allso tried figuring out how to add modules and hooks to initrd but failed at finding the info on the net

On both attempts I have also tried only making a /dev/sda8 ext4 and lvroot, lvhome, lvswap but after trying different things over the last 3 days i feel its on time to write it on OpenSUSE forum and figure out if i need to make a bug report or its just me who doing something wrong? (or maybe doing something impossible?)

I thanks all who spend time on looking at my problem and going as for as to the bottom of my post reading my thanks and pleed for help.

Best Regards all,

I forgot to mention that after each install (before the first boot of OpenSUSE)

I logged into Linux Mint KDE and ran

sudo grub-mkconfig && sudo update-grub

which allways finds OpenSUSE on /dev/OpenSUSE/lvroot and not /dev/sda8 (boot ext4)

I do not know if this is related to my troubles or not but ty again for reading.

Best Regards,

Maybe assuming you used BTRFS file system I don’t think that is supported in Mint thus can not use Mint to boot to a BTRFS partition So use openSUSE as the boot control not Mint or use ext4 in openSUSE

as i wrote in my post i used mdadm, luks and LVM i even showed how i created them.
The LVM Logical volues where all formattet with ext4 and swap as needed.

Then I don’t know you have a complex system with lots of places to go wrong. There must be some incompatibility between Mint and openSUSE for such a complex set up. What happens if you leave openSUSE as the boot manager ie don’t reinstall grub from Mint?

Just for the fun of it i decided to follow your idea and install OpenSUSE LEAP again and let it install GRUB2 itself.

Partitions as follow

/dev/sda8 as boot (formattet ext4)

/dev/sda9 and /dev/sdb7 as mdadm RAID0 /dev/md1

luks on /dev/md1

Then LVM on LUKS as follows

lvcreate -L 42GB -n lvroot OpenSUSE (formattet ext4)
lvcreate -L 8GB -n lvhome OpenSUSE (formattet ext4)
lvcreate -L 8GB -n lvopt OpenSUSE (formattet ext4)
lvcreate -L 8GB -n lvsrv OpenSUSE (formattet ext4)
lvcreate -L 8GB -n lvtmp OpenSUSE (formattet ext4)
lvcreate -L 8GB -n lvusrlocal OpenSUSE (formattet ext4)
lvcreate -L 8GB -n lvvar OpenSUSE (formattet ext4)
lvcreate -l 100%FREE -n lvswap OpenSUSE (formattet swap)

This time it never ask for password tells me OpenSUSE/lvroot doesnt exist (and so on with the rest) and drops me at dracut this time.

But OpenSUSE (GRUB2) finds Mint KDE thought and mint boots fine.

Kinda weird no matter what i do it just wont boot. But i somehow managed to get 3 different errors depending on my way of installing the OS.

Anyone out who has any clue?
I hopefully cant be the only one with this problem?
Im starting to consider it might be worth a bug report after all.
Even though ive never actually posted one.

btw. ty for answering me it was worth the try at least.

Best regards,

Maybe report on bugzilla.

Are you using Plymouth? Try with and without it. I vaguely remember several bug reports regarding password prompt. I believe using Plymouth was a workaround. One problem with Plymouth is, password prompt does not contain any device indication, so you better use the same for all devices.

I tried first installing Plymouth and it dropped me off at dracut again.

Then i tried to remove polymouth and it allso let to dracut.

Seems like i really gotta pull mysel together and write that bug report.