Installing openSUSE on Dell Studio 1535

I am new to openSUSE but NOT new to Linux

I just bought a Dell Studio 1535 Laptop with the following configuration

Processor - Intel Core 2 Duo (64 bit)
Chip Type - Mobile Intel 965 Express Chipset Family
VGA - Intel Graphics Media Accelerator X3100 (358 available memory)
BIOS Version - A04

Here is my problem:
I installed ubuntu 8.04 on my present laptop (Dell Studio) and i was never able to run it with its full graphics and good resolution. The possible reason (which i learnt from ubuntuforum) was lack of proper support for my graphics card and 965 chip. The end result was I was never able to run ubuntu with a resolution more than 800x600 while i m capable to running 1280x800.

I thought to switch to Fedora Core 9 - but the results were worst than ubuntu - I couldnot even get the 800x600 resolution as the installation resulted always in White Screen of death. Till now I havent got any solution for this problem from the forums.

I tried installing openSUSE and the result was the same - Familiar WHITE SCREEN OF DEATH :frowning:

I am really want a Linux OS on my laptop as I dont like Vista. Please tell a solution if there exists one for this problem in openSUSE ??

Thanks a lot for reading and any further responses

Gawd! NEVER NEVER NEVER buy Intel graphics! There’s a guy on this forum that steals any “Intel Inside” stickers he can find and sticks them on public toilets!!!

Sir, A mistake has been committed - ie I bought a Laptop with Intel Graphics Driver … isnt there a remedy for it?

People who are using Intel Graphics Card on Thinkpad (Eg: T61) have no problems with it while they use Ubuntu or FC 9 (I have no clue about openSUSE) - The problem still remains for Dell Studio laptops specifically (I wonder what anti-linux spell Dell has casted on this variety).

Dell also sells laptops with ubuntu on it so there should be some similarity between drivers for these laptops and the Studio variety (That what I guess - May be I am too naive - or less informed than the hacker community).

I think the Linux community has a lot of intelligent people/programmers/hackers who can find a way around where me intelligence fails.

I just want to install linux - now with my Poor Laptop - i dont care which distro it is - If you guys have any suggestions for any other distro - pls suggest …


You could try SLED 10 SP2? which is based around 10.1 It’s a free trial
for updates for 90 days. It does keep going after that, you just won’t
get updates unless you decide to register for updates which requires

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 11:58, 1 user, load average: 0.20, 0.21, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Dear Sir,
first I’d like to apologize for the inappropriate outburst in my previous post. Secondly, there actually are a couple of suggestions you may try to salvage the situation:

  1. exiting your desktop environment (by issuing init 3 in a console) and running sax2 -r; or
  2. exiting to console-mode and running xorg -configure; or
  3. trying to install Mandriva 9; judging from this post: Mandriva Forum >> No sound for Dell studio 1535 /Mandriva 2009 you’ll apparently get your video card working, but possibly losing sound in the process…:P; or
  4. returning your computer to the shop if it’s been just recently bought and trying to swap it for a more compatible model. Alas, buying liGNUx-compatible hardware has become a science of its own…
    Good luck and please accept my apologies again.

IMHO this chipset should work with minimal problem on openSUSE.

As JosipBroz suggested boot to run level 3 and then try running “sax2 -r” (with root permissions). After configuring, you can test if the configuring was successful by typing (as a regular user, NOT as root): startx

You could also try configuring with sax2 with root permissions by using: sax2 -r -m 0=vesa
you could try with root permissions: sax2 -r -m 0=intel

Also if the above suggestions from JosipBroz don’t work, you could also try reading this advice for the lenovo/thinkpad for the same graphic card, to see if they might work for your Dell:
Intel Graphics Media Accelerator X3100 - ThinkWiki

Kind Sirs,
Thanks a lot for your help … and no one needed to apologize. My new laptop (which i cannot return now) has made me sad. I have spent atleast 4.5 weeks figuring out to install a decent linux distro

I hate to say this - but nothing works for me on openSUSE as well (i liked the initial screen tho - first time user :slight_smile: ) - i changed the driver to Vesa in the xorg.conf file. Still the same problem - WSoD … i am too afraid to download a bulky 4.2 GB SL 10.2 only to see the WSoD … Dell Studio 1535 with 965 chipset and X3100 GMA is cursed for linux nothing works on it :(.

Atleast in ubuntu i was able to run Gnome in 800x600 resolution. I think I should stop searching for the solution now and settle for big icons.

oldcpu - the link u gave me has already been visited by me - but with relation to ubuntu. The WSoD problem is only with Dell Studio - eventho it has the same problems and configuration. I guess the Thinkpad community has plenty support and Poor Dell Studio is still the neglected entity…

thanks a lot for the help. Lets hope that i will be able to run linux in good resolutiuon by the end of this year

How far did you get in the install ? If the install worked, but then at the very end the graphics did not work, then you should be able to use the xorg.conf file from the install (called xorg.conf.install) and rename it to “xorg.conf” and then get some graphics. These files are located under /etc/X11.

see this is what happened in the order of occurance.

-green screen appears with cds and Welcome (in diff languages)
-I pressed Welcome and it asked me to install openSUSE - Pressed enter
-Then it checked my computer configuration - i could see all the fancy code with a lot of ‘done’ ‘done’ … then what happens it after a lot of dones - the white screen appears.

  • I press ctrl Alt F1 and come into command line mode
    asks for login: but i dont have one as I just started installing SUSE. So i just wrote ROOT and then it said have fun!

I tried to edit /etc/X11/xorg.conf

  • I have known from my previous experience with ubuntu - that this is the file that has to be played with if u want to remove the WSoD.
  • I was very happy to see that openSUSE recognized everything perfectly
  • And basically this is the main problem - In the “Device” section of xorg.conf - it uses the Driver as “intel” (which is very correct given my grahics card is X3100) but - this is a problem with Dell Studio (happened with ubuntu as well) - If I use this driver my screen goes WHITE - so from my ubuntu experience changing it to VESA - atleast gives me the 800x600 display - so I changed the driver to VESA and resoluton to 800x600 in the Screen/Display
  • Then I typed startx - and it gave me an error saying - FATAL ERROR:0

I am new to openSUSE - i could correlate Sax2 is similar to annaconda in FC 9. But anyting else is beyond my comprehension. Can oldcpu give me n00b lesson :). I know its too much of spoon feeding but please it will be help.


It looks to me that your install may not have completed.

Did you read our installation stickie and follow the many bits of guidance given there:
NEWBIES - Suse-11.0 Pre-installation – PLEASE READ - openSUSE Forums

Please also note, thanks to Kevin Dupuy, you can also see a full installation walkthrough on the openSUSE wiki for the DVD:
Installation/11.0 DVD Install - openSUSE

… or for the Live CD:
Installation/11.0 Live CD - openSUSE

This is an excellent reference to point to, if you have an installation failure (after the GUI starts) and you wish to point to the failure location.

On what page of those installation walk thru’s did you reach?

You could also try an install with graphics lower than your highest graphics setting … ie when the first installation screen appears: Installation/11.0 Live CD - openSUSE
press F3 and select a lower video mode. Maybe start with 800x600 and then you can tune that later after your install is complete.

Also note from here:
Intel Linux Graphics: Hardware Matrix
… while your specific Dell is not listed, there are many examples of this Mobile Intel 965 graphic chipset working on other Laptops, and I would be very surprised if this can not be made to work on a Dell.

Doing a hand edit to one’s /etc/X11/xorg.conf file can be necessary on occasion, but as a newbie, IMHO its always best to try the openSUSE tool “sax2” first (and there are many combinations of sax2 one can try), and if that does not work, try other tools, and only if you have exhausted such options, is it then useful to go to /etc/X11/xorg.conf

And dont’ forget what I mentioned about the /etc/X11/xorg.conf.install file. Thats another possibility, but it reads to me that you never even reached that stage in your install.

Does that give you enough information to create an approach to fix this?

Thanks oldcpu :slight_smile:

That was quiet exhaustive - I think I had the Live CD installation procedure open in front of me but none of them appeared as a white screen appeared before anything could happen.

I would redo everything that you say.

I have been to a lot of forums on linux help - But I think you give very exhaustive solutions :slight_smile: thanks a lot - May or May not help for my case but atleast its a lot of effort from your side.


Did you get this Installation in Live Desktop display? It comes right after the Welcome in many languages. If you did, then press F3 and select the 800x600 resolution for your install. Then select installation.

If that does not work, then try rebooting again, and install again, but this time press F3 and instead choose an ascii/text install.

If you do not get the Installation in Live Desktop display, then there is a key sequence you can press do do a text install. And then when the text install is complete, you can run sax2 to configure your graphics.

And to run sax2 - i need to refer to all the things which u commanded me to do in the last page - Right?


Yes, to run sax2 you need to log on as a regular user in “run level 3” (where run level 3 is a text/ascii mode (it looks like a big MS-DOS screen)). Once logged in, you need to obtain root permissions. You do this by typing “su” (no quotes - enter root password when prompted) to switch users to root.

Then you try to configure with one the following, and hopefully one will work:
sax2 -r
sax2 -r -m 0=vesa
sax2 -r -m 0=intel
stop after you get one to work (note that is "zero equals … " ) … ie once you try one of the above, and your PC doesn’t obviously freeze or doesn’t give you many errors, then you need to test the configuration. You do that by typing “exit” to get rid of root permissions. This is important. You need to test your GUI (X window) with regular permissions and not root permissions. You can test to see if you are root or a regular user by typing “whoami”. Once you are a regular user you can type “startx” to test your GUI.

and also don’t forget about the possibility of copying the /etc/X11/xorg.conf.install over the /etc/X11/xorg.conf file, which may give you the same resolution that you installed at.

There are also other suggestions in this thread you can try once you have a successful install.

Hey guy. sorry for my bad english. Normaly install opensuse 11, but on loading(vga=0x314) black monitor and nothing. On safe–boot normaly. Help undestand problem. I think problem into intel mobile video?
thank for reading

Howdy My fellow linux users!

So after a lot of struggle with openSUSE my POS Dell Studio 1535 with X3100 Intel GMA didnt let me install it at all. Finally I opted for the Mandriva option as suggested previously in this thread by Josipbroz. Thanks a lot Josipbroz…

Atleast I can get my resolution up to 1024x768 in Mandriva 2009 on Vesa driver. Again using intel driver gave me the WSoD. Which convinces me that its a problem with the LCD vendor in this particular variety of Dell Studio. I think 1024x768 can be produced on any linux distro on vesa driver under KDE4.1 desktop.

I think i can keep myself satisfied with this resolution until someone comes up with a good solution for my problem. I am just being positive about this as I trust the linux community for the intelligentsia …

KDE 4.1 is fine except for its frequent crash … but it is definitely better than Vista

Thnks again guys

Sorry to read of your problem. I now own a Dell Studio 15 laptop (Dell Studio 1537) which has an ATI Radeon HD 3450 (instead of your X3100 Intel GMA). I currently have it running openSUSE-11.1 beta5 at 1024x768 resolution (using the openGL driver). I deliberately selected that resolution during the install. I have not yet tried to increase the resolution, nor have I tried the ATI driver. I’m current focused on trying to get the audio (headset) functioning properly.

I chose 11.1 beta5 (with the 2.6.27 kernel) because:
a. I wanted to test 11.1 beta with a new machine, and
b. The wireless in my Studio 1537 needs the 2.6.27 kernel, and
c. I had read the Radeon 3450 works better with the 2.6.27 kernel

Best wishes on your Mandriva. If you pickup any tidbits in terms of Mandriva configurations and stuff that you think might be useful to openSUSE, by all means post it here. :slight_smile:

I suspect openSUSE-11.1 (due on 18-Dec) may address many of your problems, although there may need to be some iterations of the Intel graphic driver.

Have you had any luck with your headsets functioning properly in Mandriva?

You may wish to track this openSUSE bug report, as I am lucky and I very very fortunately have the attention of an alsa dev in that bug report , and he is trying to fix the headphone bug:

Note the mandriva bug report here:

I still have not tried the proprietary ATI driver, but I did switch from 1024x768 to 1440x900 on the radeonhd driver.

To do this, I rebooted the PC, and then when the grub boot menu appeared, I simply typed “3” such that a 3 appeared in the options line of the grub menu. That booted me to an ascii/text prompt (in run level 3). I then logged in as oldcpu (with my password)

Now I had previously confirmed I was using the opensource openGL driver by typing: grep -i driver /etc/X11/xorg.conf

So I then typed “su” to switch to root (entering root password). With root permissions I backed up my functioning /etc/X11/xorg.conf file with:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.oldcpu.backup

Then I ran sax2 to configure my X window. So having previously observed my PC was using the “radeonhd” driver, I ran sax2 by typing:
sax2 -m 0=radeonhd

I confirmed the graphics it gave me, and when it was complete I was back at a text prompt. I typed “exit” to get rid of root permissions, and then typed “startx” to launch and test X window.

When I was ready to exit I opened a konsole and typed su -c ‘shutdown -r now’ to confirm my new graphics setup would survive a reboot.

Oldcpu - I think u r the best moderator among all the linux distro forums. I am very impresed. Trust my I have visited all the forums and almost all the linux forms to get a solution for my Dell 1535. Hats off

Now i discovered what my problem was:
It was discovered on ubuntu launchpad bugreport the reason for my problem. It was my LCD Monitor manufactured by AUO - Manufacturer: AUO Model: 8174 Serial#: 0. This brand doesnt seem to work with the present variety of intel driver. Can you guys fix that?

The same kind of bug has also been reported at the bugzilla.
See this link

For the bug report corresponding to ubuntu please look at this link

They also have all the relevant files.

Regarding the problems with headfones and media keys:
Kde4.1 has its issues - it crashes a lot (u can expect that - I am fine with it). The media keys (the one at the top which u can press to control volume etc.) wont work - its the KDE problem as its still under development. Headfone issues presist.

To summarize - i wanted to work on Linux as I hate Vista - I made an a out of myself by thinking that Dell Studio can run any linux distro (wow! I trusted Dell that much). In the end I am stuck with a pretty primitive Laptop which has 1025x768 display - i can not use headphones - KDE crashes often - I love visual effects but with vesa driver i can’t use that - I can go on and on – I have faith in the linux community :D**