Installing opensuse 11 on Dell Open Laptop

Hi, has anyone tried to install openSUSE 11.0 on the Dell Open laptop Inspiron 1525. I looked at the specs, and wondered if I could wipe the Ubuntu 8.04 off the hard disk and install openSUSE 11.0 instead.

I’m very happy with openSUSE 11.0 on a Athlon XP 2100 and would enjoy using openSUSE 11.0 on a laptop.

Thanks in advance.

Take a look here for 10.3:
GNU/Linux on a Dell Inspiron 1525 -
reference your sound, I’m pretty confident we could get it running on the Inspiron 1525.

Which wireless do you have? The Broadcom or Intel 3945?

A fedora user got the suspend to work, so I assume its also possible under openSUSE.
Dell Inspiron 1525 - Linux Laptop Wiki

Thanks oldcpu for the reply.

Here’s the spec’s off of Dell’s website:

Intel® Pentium® Dual Core T2370 (1.73GHz/533Mhz FSB/1MB cache)
Ubuntu Linux version 7.10 with DVD Playback
Glossy, widescreen 15.4 inch display (1280x800)
CD / DVD Writer (DVD+/-RW Drive)
1GB1 Shared Dual Channel DDR2 at 667MHz
Size: 120GB2 SATA Hard Drive (5400RPM)
Intel Graphics Media Accelerator X3100
High Definition Audio 2.0
Intel® 3945 802.11a/g Mini-card

It’s highly possible I would bump up the RAM to 2GB and the HD to 250GB. Should I look at 802.11 a/g/N also?

I’m also considering a dual boot setup with openSUSE 11.0 and Windows 2K Pro SP4.

Thanks in advance.

I take it then you have not purchased this laptop yet.

If it were me, I would backup as much of the Ubuntu install, BEFORE wiping it off the hard drive. Especially all of the configuration files. They could come in useful when configuring openSUSE.

Everything should work. I have an XPS 1710. And I bought it before Dell introduced Linux on their computers.

At the start on Kubuntu 7.10 (i think, the one before the more recent one), I had everything working, even the card reader and bluetooth.

After that with the more recent version of Kubuntu (with KDE 4) which I tried before openSuse 11, it was a bit too buggy on my XPS 1710. The wifi did not work at all, I’m not an expert but configuring wifi was way too much hassle.

Now with openSuse 11.0 (64bit and KDE4), it works spot on, the wifi card needed the wireless-compat drivers and WPA instead WEP used, and it works a charm. Some things that don’t work is Suspend to Disk (suspend to ram works nice) and the volume/multimedia keys on the front (which have worked in kubuntu 7.10), so there must be a program somewhere…

So the bottom line, there is noooo reason why everything shouldn’t work (even with a bit of work, and I am still a noob myself).

Oh and if you want the recent Compiz on openSuse 11.0, it works nice, but a little buggy (with KDE 4).

Put it like this, I am now in a position where I am more than willing to ditch windows as my main OS and install openSuse 11 on the first biggest partition, and then run windows in virtualbox. And possibly leave some space to play with macosx. Or as a backup partition. I’ve never seen such a stable OS as openSuse at the time being.

Well done developer guys.

I have installed openSuse 11 on my Dell Vostro 1500 ( nVidia graphics & Broadcom 4311 Wireless). Smooth installation and Wireless is up. Able to play MP3s, WMV, avi etc.

Now have WinXP / Ubuntu 8.04 / Suse 11 on my Dell Vostro.

Thanks to Linux World for making the Installation task so simple that novice like me can do it comfortably.


Reference the sound, there are some quirks.

I am trying to help a user here:
Sound slowly fades out when connecting phones or speakers - openSUSE Forums
and thus far have not been successful.

Thread moved to Install/Boot/Login

Specs are fairly similar to my Inspiron 1420 which originally came with Ubuntu 7.04. I decided to be reckless (I like learning experiences…) and just wiped the drive after becoming irritated by Ubuntu. This worked for me, though I wouldn’t necessarily recommend it, unless you really hate Dell’s default partitioning scheme.

I would definitely recommend openSUSE 11.0, it has much better support for this laptop than 10.3 did, and I thought that was pretty good.

You should be able to get everything more or less running, though of course with some tweaks and adjustments.

Thanks for that. Based on your post, I added an entry of 11.0 under the Dell Vospro row in this HCL guide for openSUSE (most of the row refers to a users 10.3 experience).
HCL/Laptops/Dell - openSUSE

How does your sound and also suspend to RAM function? Have you had any luck with the modem?

Got a laptop like the one described (the only difference being 2G of RAM - so go with this upgrade).
Tried to install 10.3, but network card was not recognized, so I had to bare Kubuntu for a couple of months :frowning:
Got 11.0 installed. Worked like a charm: detected all my hardware, with absolute no quirks in what regards video, sound, wifi, etc.
One problem though… I tried to configure Kpowersave to suspend to disk on lid close, and guess what? While opening the lid, no keyboard! Luckily mouse worked so I could switch session back and forth until I got a keyboard - actually this is why I am on the forum right now…
Anyways, good luck w/ your new Dell!

I have a vostro 1500 as well and I am new to Linux in general. I’ve installed opensuse 11.1 on it and the wireless does not work at all. Can anyone please assist? I have visited the other links in this post but it seems outdated.


Welcome to our forum.

Wireless can vary, even on the same Laptop, so IMHO your best bet to get help is to post (start a NEW thread please) on our wireless subforum area:
Wireless - openSUSE Forums

BUT before you post on that subforum area, please read our 3 stickies on wireless, so you know what information to provide, and maybe can even try a bit of troubleshooting yourself first before posting/starting the new thread. The stickies are on the top of that forum. I’ve also copied their links here:

Good luck.