Installing openSUSE 11.3 on Gigabyte T1000 netbook (eee pc mt101)

Hi all,

I don’t consider myself an openSUSE expert or even a how to expert. I wanted to post my experience here in the hopes it might help someone else.

My first problem was getting the OS to boot from a usb stick. Having tried the methods described here SDB:Live USB stick - openSUSE my machine would hang at the post. I also tried unetbootin UNetbootin - Homepage and Downloadswhich didn’t either.

I finally ran across this site which did work. Why he doesn’t optimize his site for search engines is beyond me because it is hard to find. To use this you will need a Windows machine and at least a 1GB usb stick.

Once I got it booted I definitely like what I saw and clicked on the Live Install icon on the desktop. Oops. It would get to the screen that shows the installation progess and crash. After attempting this several times and carefully reading the error messages that popped up I decided that it was having a hard time partitioning the hard drive…or at least making it rw.

That was my Aha! moment. I booted the usb stick and pre-partitioned my hard drive. I set up the partitions as follows:

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1             288M   30M  244M  11% /boot
/dev/sda2              30G  3.6G   25G  13% /
/dev/sda3            3954       30402   212438016    f  W95 Ext'd (LBA)
/dev/sda5            3955        4196     1942528   82  Linux swap / Solaris
/dev/sda6              30G  433M   28G   2% /home

I was a little disappointed that I couldn’t (or didn’t see how) to set up LVM here. I have a 250GB hard drive so I left myself plenty of room to set it up later and move partitions over.

I then started the installation again choosing my pre-formatted partitions and the install went as expected.

Now the real fun begins discovering what I truly have. In a nutshell I wasn’t disappointed. Yes I had to do a few things for configuration but they weren’t unexpected.

The touchpad will not work by default. This is fixed by adding the following highlighted text to /boot/grub/menu.lst and rebooting:

title openSUSE 11.3
    root (hd0,0)
    kernel /vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-WDC_WD2500BEVT-00A23T0_WD-WX11A10H8790-part2 resume=/dev/disk/by-id/ata-WDC_WD2500BEVT-00A23T0_WD-WX11A10H8790-part5 splash=silent quiet showopts vga=0x317 i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40
    initrd /initrd-2.6.34-12-default

Screen rotation works out of the box with the provided icon in the tool bar. The touchpad axis rotation won’t though. This is easily fixed by installing x11-input-evtouch-0.8.8-3.2.i586 with the package manager, downloading and installing eGalaxTouch-3.04.4912-32b-k26.tar.gz from and adding

blacklist usbtouchscreen

to /etc/modprobe.d/50-blacklist.conf. Then reboot and run eGalax to calibrate. Rotate your screen and voila! the mouse pointer goes where it is supposed to.
Reference for the above: openSUSE 11.3 and eGalax TouchScreen

I like cellwriter for handwritten text input and the onscreen keyboard is nice as well. This can be installed with zypper as well. You can make a few tweaks to it like unlocking your screen saver and adding it to your login by following the instructions as and

You should now have a true tablet pc with screen rotation, hand writing and onscreen keyboard for logins.

Those were the hard parts. Sound works great out of the box as does video, mp3 streaming in Firefox, and cheese for the webcam. I have a 6 cell battery and the battery life is exceptional. Suspend and hibernate also work as expected.

There are two “issues” that I haven’t yet figured out:
What I haven’t figured out yet is why the keyboard wants to all of a sudden start repeating keys. Generally xset -r will fix this but it also turns off repeating. And no my keyboard isn’t broken. It works fine in errr the other operating system. And before you decide to try another distro thinking it won’t be broken I can tell you it still is…and compared to openSUSE 11.3 you will be disappointed with what you get IMHO. Just speaking from experience…

The other is having to sign in to my keyring everytime that I login. This is a minor pain…

So if anyone knows how to fix this keyboard and keyring issues please let us know. Other than that Great Job! to all of the folks at openSUSE.

You can define a partition as LVM in the partition scheme section of the install. But note the way you have things pre-partitioned it not the way I’d set things up to use LVM.

Hi there!

Got a T1000P myself.
Although I am using it with Ubuntu I can confirm the issue with the keyboard repeat.
I am using “kbdrate -d 750 -r 30.0” in my /etc/rc.local to increase the keyboard delay. Now those repeats are rather uncommon, but they still occur. I think it may be due to some exotic hardware built in :wink:

My biggest personal problem is the touchscreen not working properly (it is recognized as touchpad). I will try the steps in your description and report back.

Also the key for toggling wireless LAN is giving me some headache. The device gets disabled by BIOS, but the system does not react. So if I toggle WiFI of, the system still thinks it is running, and I need to manually shut down the interface (via ifdown on Ubuntu). And when re-enabling the device I need to manually issue ifup to configure networking again.
The good thing is that the BIOS generates scancode for each keypress: 66 for WLAN off and 67 for WLAN on. I have tried binding 66 to KEY_RFKILL (keycode 247) and it seems to succesfully disable the device, but for turning it back on I am currently clueless.
Any hints/searchwords to look for?


That is MOST interesting !! Makes me want to purchase a Gigabyte T1000 (eee pc mt101) just to play around. :slight_smile:

For a ‘nominal’ PC, it is most definitely unusual to be forced to add to the menu.lst

i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40

and I understand that was needed to get the touchpad “to work”. By “to work” I assume you do not mean to ‘boot’ but rather are refering to the input/output ‘touch’ sensitive nature of the touch pad ?

I note to get ‘axis rotation’ to work you needed to install x11-input-evtouch, and custom install (compile/build ? ) eGalaxTouch, and blacklist “usbtouchscreen”. But what is ‘axis rotation’ ? ie how does that differ from ‘screen rotation’ ?

For laptops there is a package called ‘synaptics’ (I think) which is supposed to stop keys repeating … I don’t know if that is applicable to touchpad netbooks. I also note that with an old KVM switch of mine, on occasion I would get keys suddenly start repeating, and that could be stopped by switching via the KVM key sequence or control panel to a different PC (via the KVM), and/or in by pressing <CTRL><ALT><F1> (takes one to a text mode and do NOT login) followed immediately by <CTRL><ALT><F7> (to get back to the GUI). Of course a KVM experience is NOT relevant here, and likely neither is the experience from the <CTRL> <ALT><Fx> technique - for if the keypad is a touch keybad on the screen then that is rather a useless sequence when one is faced with a text mode after the first key sequence. :slight_smile:

Having to sign in to a keyring everytime that you login is something I’ve seen on both LXDE and Gnome with a normal desktop and normal laptop. Its not unique to a Touchpad and its likely some bizarre configuration issue that the developers thought essential (for security) and the average users dislike. I use the same password there as I do for my regular user account just ‘out of spite’. :smiley:

Sorry, I don’t know how to fix the keyboard and keyring issues. … I think I ran across an image of the T1000 here in this “Netvertible” (Netbook/Tablet) round up: Best netbook tablet PC: list of best netvertibles](
… with basic specs from same site:

# Intel® AtomTM Processor N470 1.83GHz
# 10.1″ Touch TFT-LCD WSVGA, 1366×768 with LED backlit, capacitive with multi touch
# Mobile Intel®945GSE Express Chipset+ ICH7M
# Embedded HSDPA Support
# 2.5″ 9.5mm SATA HDD 5400rpm, 250 GB
# Multi-Touch Mousepad
# Battery Li-ion 6 cells, ~7650mAh Battery

Did you end up setting up a dual boot between MS-Windows and GNU/Linux ? How does the Mobile Intel®945GSE Express work when playing back High Definition (HD) videos in openSUSE Linux ? Do 720p playback ok ? 1080p ?

Am I correct that you chose the USB stick installation method because you did not have an external USB DVD drive ? or did you try an external USB DVD drive and it did not work ?