Installing OpenSUSE 11.2 on a SunFire X4140

I’m trying to install OpenSUSE 11.2 on a SunFire X4140 without success. It has 2 x 146GB SAS disks.

The installation seems to go just fine until it comes to booting from local disk, where I get:

“Boot failed : press a key to retry”

I’ve tried installing with the GRUB and LILO boot loaders, and in different locations - on disk, in the MBR etc. I also tried SLES10 + SLES11 which gives me similar errors.

I’m not sure if it is significant, but in the YaST Installation Settings I see:

"it was not possible to determine the exact order of disks for device map. The order of disks can be changed in ‘Boot Loader Installation Details’ "

I did change the order of the disks but that had no effect. I don’t see the error in SLES10.

What am I doing wrong? Would very much appreciate any guidance.

When doing the install, how did you partition it?
GRUB/LILO can’t be installed if it doesn’t know the order of the disks.
Are you doing a raid?
Also, don’t use MBR. First sector of the hard drive should be fine.

Thanks for the response.

I did a custom partitioning:

I created a swap partition on /dev/sda1 (8GB)
And root partition on /dev/sda2 (128.72GB)

I didn’t do anything with RAID and I left /dev/sdb untouched - created no partitions with the intention of using it later.

If I switch the order of the disks around, I still hit trouble e.g. /dev/sda,/dev/sdb or /dev/sdb,/dev/sda

Solution: The server had PCI scanning disabled in the BIOS, so the RAID controller didn’t appear and couldn’t be configured.

I looked for PCIPnP and then ‘Scanning OPROM on PCI-E slotN’ - and just enabled all the slots.

The LSI controller prompt appeared on a reboot and I was able to configure a RAID and the installation went smoothly.