installing openGL 32bit in a 64bit system

Yes I want to do what the title says, you see I got some games installed via wine (dont worry I dont need them to be set up, both installed just fine under the installer in both playonlinux and wine)
I just dont know how to do it, I have searched for openGL in the repos but no luck, I have no idea how to install the libs I need.
This was an issue when I had ubuntu too, but I thought this was an issue that just Ubuntu had and not something opensuse had too.

To see if this is possible anyway, we need more info:

openSUSE version
Desktop used
Video card + is proprietary driver installed?

To see if this is possible anyway, we need more info:

openSUSE version
Desktop used
Video card + is proprietary driver installed?

Is Mesa-32bit installed?

BTW: if these games are that important to you, why not run 32bit openSUSE?

Usually you install the package Mesa-32bit for that.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GTX 650 Ti
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.3 | HD 3000
eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

I was giving the 64bit a chance, if it didn’t work then revert to 32bit if I felt it needed

openSUSE is version is 12.2 64bit
KDE 4.8
My video card is an ati HD4200, I do not have the proprietary drivers installed as they caused me issues with ubuntu as my card is no longer supported by the current drivers.
If its something I can just install and bypass thats fine, I can adjust.

Try start the game from command line which may give you some hints at what 32bit libs you might be missing.
I play various games with Wine and there is usually not any need to add extra 32bit packages as most are installed along with Wine.
But I am a bit uncertain about your graphics driver, when I install the NVIDIA driver for my card I get an option whether to install the 32bit version or not also. Maybe try to have a look for the 32bit version of the Radeon/ATI(?) driver you use?

Actually the suggestion of installing mesa 32bit did the trick, no drivers needed apparently :smiley: