Installing on mSata Drive

Has anyone tried installing on an mSata drive? I tried installing OpenSuse and received the message that the partitioning on my MyDigitalSSD drive was not readable.

I’d like to know if it’s just my generic MyDigitalSSD drive that doesn’t work, or all mSata drives.


Is it partitioned ?
Try a tool like Parted Magic and set up your partitions

Yes, it is partitioned.

The message I get is:

The partitioning on disk /dev/sda is not readable by parted tool

What kind of partition type do you have??
I mean FAT32, EXT3,EXT4,NTFS etc.

And also can I see your partitions

# fdisk -l

A 60 gig NTFS windows 7 install and a 32 gig FAT32 partition and 28 gigs of unpartitioned space.

OpenSuse can see the partitions, it just can’t edit or add partitions.

I tried Ubuntu and it couldn’t even see the partitions and claimed I had 128 gigs of unpartioned space. So I’m guessing it has to do with my mSata drive.

How can I run fdisk if I can’t install linux?

Look openSUSE has EXT4 partition type. It will better to read and translate my guide about partition Οδηγός Δημιουργίας Partition]( . You can of course use parted magic for that. Just download it burn it in cd and boot from it.

These types of partitions who you create is only to install windows on it. Try with parted magic. Also there is a guide who James has written about SSD. it is perfect I suggest you to read it.

You can not install openSUSE to a NTFS partition. It may be able to shrink the partition if it is not full of data. I would go into Windows, if created by Windows and shrink the partition there after you make sure there is enough free space left to install openSUSE. I would suggest at least 30 GB of free space to start an openSUSE installation. SSD disks are very expensive and not very roomy and perhaps you need to load openSUSE onto a different hard disk.

Thank You,

You said it was :

generic MyDigitalSSD drive
But now you say it has Win 7 installed. So really, who knows what you really have.

Boot Parted Magic and get us:

fdisk -l

Ok, I don’t know how you guys aren’t understanding me but here goes.

I have a 128 GB MyDigitalSSD drive.

It has a 60 gig Win7 NTFS partition, and a 32 gig FAT32 partition.

I want to install linux and setup partitions on the remaining 28 gigs of unpartitioned space. So I’ll create an EXT partition and swap partition out of the unpartitioned space.

I will post the fdisk -l info later this afternoon. Thanks for your help

Perhaps even an image of the HD in Parted
Like this:

Here is the output of fdisk -l

root@PartedMagic:~# fdisk -l

WARNING: GPT (GUID Partition Table) detected on ‘/dev/sda’!
The util fdisk doesn’t support GPT. Use GNU Parted.

Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xdfe52723

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 123095039 61444096 7 HPFS/NTFS/exFAT
/dev/sda3 123095040 190201855 33553408 c W95 FAT32 (LBA)

So it’s not a standard disk

If you create anything in the unpartitioned space it has to be an extended because you need at least 2 more partitions inside that

So create an extended partition to use all the free space, then create a swap and at least one ext4 (2 if you want a separate /home, but I don’t advise it with the sizes)

Seriously guys, I cannot create a partition out of the unpartititioned space. I get the message that parted cannot read the partition info, and fdisk tells me to use parted.

I have installed linux several times before on a standard hard drive, but never on an mSata drive.

When I open GParted in Parted Magic, it shows that my entire drive is unpartitioned space, but as shown above fdisk can read the partititons. Also I can write to the FAT32 partition while in Parted Magic.

I really appreciate the help, but can I have something a little more useful than “create a partition out of the unpartitoned space?”

I understand I would need to make an extended partition out of the remaining space in order to have an EXT and swap partition, but I have yet to find a tool other than Windows 7 that will let me partition the drive.

PheNux, the GUID Partition Table does not currently work with openSUSE, Grub Legacy or the YaST Partitioner. GUID is not needed unless you are trying to access a very large hard drive such as a 3 Terabyte Model. Here is a link on the subject:

GUID Partition Table - Wikipedia, the free encyclopedia

It looks like you might have success with an OS that uses Grub2 like Ubuntu, but it has not been tested by anything I have. If you have an option to repartition the drive using standard MBR (Master Boot Record) , then it should work with openSUSE.

Thank You,

I get the message that parted cannot read the partition info, and fdisk tells me to use parted.
Can you show us

parted -l

then? please use CODE tags.

Can you give us some more details of this machine? If it uses EFI instead of the normal BIOS it may help to explain the use of GPT.
EFI can cause some unusual problems, but there are those here who have had some experience with it.
Also what tool was initially used for partitioning?