installing Nvidia drivers GeForce 210 openSUSE 11.4

I don’t use the script of jdmcdaniel3, so I can not help with that. jdmcdaniel3 will need to help you with that.

I typically install via the very simple manual method (also called ‘the hardway (that is not hard)’ ).

For my wife’s PC with the G210 nVidia I ensured that KMS was set to YES in yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted. There is NOTHING special there. One is advised to try that per the openSUSE-11.4 release notes which I assume you read already. Right ? The release notes is ALWAYS the 1st instruction I look at for any software.

I ensure that I have NO packages with ‘nvidia’ in the rpm file name. ie if :

rpm -qa '*vidia*'  

shows you have any such packages (ie with nvidia in the rpm file name) installed then the method I employ won’t work. So if you want to try the method I employ, then you need to remove those (there are some exceptions but I won’t confuse the issue by listing them here).

I ensure I have kernel-source (of identical version to kernel) and kernel syms installed. I ensure I have the base-development pattern selected (with appropriate packages from it installed).

I ensured I had the latest nVidia video driver from here: Unix Drivers Portal Page which for the G210 for 32-bit openSUSE is the 271.41.06 here and for 64-bit openSUSE is the 270.41.06 here. Its important you download the right driver for a 32-bit or the different driver for a 64-bit (which means your openSUSE version and NOT your hardware version), else you are in for a load of frustration. In your case the output you provided earlier suggests a 32-bit version so ensure you download a 32-bit version (and NOT 64-bit).

Also put the driver somewhere that it can be found easily in a terminal.

On some PCs I blacklisted the nouveau video driver by adding the line “blacklist nouveau” in the /etc/modprobe.d/50-blacklist.conf file. That can also be done with root permissions by typing:

echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf 

I then booted the PC, and when the grub boot appeared I typed ‘nomodeset 3’ such that those words appeared in the ‘options’ line of the grub menu after the current entry (with a space between them and the current entry) and the allowed the PC to continue to boot to a full screen text mode.

I logged in as a regular user, and then after logged in typed ‘su’ to get root permissions.

Then with root permissions, I navigated to the directory where the .run file (downloaded above) is located and I installed the driver with:

sh NVIDIA-Linux-x86_64-270.41.06.run -q 

for my 64-bit. Yours will be different, possibly:

sh NVIDIA-Linux-x86-270.41.06.run -q 

and then after that install is complete do NOT look for sax2 (as it no longer exists) but rather I instead ensured I had NO /etc/X11/xorg.conf file, and also ensured that I had NO CHANGES in any of the files in /etc/X11/xorg.conf.d/ (ie left everything as ‘stock’ installed). And then simply rebooted with root permissions with:

shutdown -r now 

Note if at anytime the boot fails, you can typically specify ‘x11failsafe’ as a boot code that will boot to the FBDEV graphic driver.

Note if you made changes to any of the files in /etc/X11/xorg.conf.d/ then you need to UNDO those changes. You also do NOT need a file called xorg.conf anymore for most graphic cards and for a nominal monitor, this is true for the G210. If you have such a file, dependant on what you have inside, it will MESS up your ability to use the nVidia G210 (ie one MUST know what they are doing to have such a file).

I hope that helps.

Good luck.

Hi oldpcu,

Thank you so much for your step-by-step. It worked better than any of the how-to’s I found. I did read release notes - among many things - trying to troubleshoot this problem. Undertaking to get this graphics card working, I struggled with it for 4 days before posting my first message to this thread.

I believe there was something wrong with my OS installation to begin with. Some of the steps you provided were the same as steps of other ways to install these drivers and I did not get the same results this time. There were packages and dependencies installed which I did not see previously, despite checking same boxes in Yast. A big difference was the web site for the unix drivers on the Nvidia site. I do not think the script was the same as the one I was using.

I did not use any custom xorg.conf or other files. Everything I tried up to now was written by script from Nvidia. sax2 and xorg.conf are not in use.

Now, I have things working but I am wondering how I save the settings from the Nvidia X-Server settings panel to a settings file. If xorg.conf isn’t used anymore, what’s my option? Without saving the settings, I can not enable the second display on this machine. Left to its own device, the OS won’t even give 1280x1024 resolution to the primary CRT-monitor.

I’m not a technical minded hardware and Linux user, having just started out using Linux. I am an internet applications developer and have decided to leave Windows behind when they end support for XP next year. You’ve been helpful and patient. I really appreciate it.

Hope you’re having a good weekend,.

You can always use an Xorg.conf file again if need be. The way the X configuration priority works in openSUSE, is if there is no /etc/X11/xorg.conf file, nor any edits to any file in /etc/X11/xorg.conf.d/various-files then X will automatically configure. This is the default. If there are edits to any files in /etc/X11/xorg.conf.d/various-files then X will use that information (together with its automatic configuration information) although the /etc/X11/xorg.conf.d/various-files will have priority over X’s auto config. If there is an xorg.conf file, then all 3 will be used (xorg,conf, /etc/X11/xorg.conf.d/various-files, and X automatic configuration, with xorg having priority over any configuration in /etc/X11/xorg.conf.d/various-files and over any configuration information in X).

To tune to a desired resolution and to get a second monitor working, you may be best off starting a new help thread and asking for help. I’ve only done the same (2nd monitor) with AMD hardware on a laptop dynamically for brief periods in support of various meetings at work.

I use the xrandr command, but I understand its implementation with AMD graphic drivers is superior to that of nVidia graphic drivers - possibly one of the few areas where AMD drivers are superior to nVidia. (I should qualify by saying a typically prefer nVidia over AMD).

There is some information that I have been randomly collecting in post #52, #62 (nvidia hardware), and #64 (amd hardware) which may help in this thread openSUSE Graphic Card Practical Theory Guide for Users - commentary support thread, but it looks rather complex to me, and if it were me I would read up on those, but do NOTHING, and ask for help in a new thread.

Congratulations on getting this far. Good luck in your future efforts.

I should note that the version of ‘nvidia-settings’ packaged by packman is safe to install and it should work with the proprietary nvidia driver that you have installed.

I had problems with the nVidia proprietary drivers with 11.3. In 11.4 the nouveau driver is reverse engineered, according to Bugzilla, and works perfectly on my machine, so I did not bother to install proprietary.

I would strongly suggest doing an MD5 check on your downloaded system ISO image before burning it, and then verifying the burned disk to the image. I heard you can repeat the MD5 on the burned disk as a final check, although I was warned it takes a long time. Also, the BIOS setup should be checked to see if there is some setting related to video–the default should work. Dust on the mobo, partially seated connectors, and lack of surge protection can also add unwanted errors.

Incidentally, I have a 900x1440 monitor, that is, a 19 inch wide-screen. The card and the monitor resolution were detected properly with automatic configuration. Nothing fancy on the initial install–all default settings.

OS: openSUSE 11.4 x86_64
Kernel: Linux 2.6.37.6-0.5-desktop
Desktop: KDE 4.6.00 rel 6
Machine: HP xw9400 AMD 64 Opteron
Chipset: nVidia nForce Pro 3600 and 3050 (proprietary Tyan Thunder)
Drive: OCZ Vertex 60 GB dedicated system–single boot
RAM: 4 GB ECC

Video: nVidia GT200 (GeForce 210) 512 MB
2D Driver: nouveau
3D Driver: swarst (no 3D acceleration) (7.10)

Audio: Onboard card 0: nVidia MCP55 Analog Stereo
Onboard card 1: nVidia Corproation Digital Stereo
Chip: Realtek ALC262
Alsa Driver: v. 1.0.23

Hi folks,
My problem somehow fits in this thread (I think), sorry if it doesn’t.
I’ve been running with the default kernel of 11.4, and the NVIDIA prop. driver from the nvidia repo.
Now I’ve happily updated to the 2.6.37.6 kernel, and boom, now my system falls back to nouveau driver without glx.
I mean, from the discussion above I conclude that the prop. driver CAN be compiled and used with the new kernel.
My question is - why the f*&k it is NOT available from the nvidia repository? Why should a working system suddenly start behaving differently after a kernel update, and by differently I mean - WORSE.
Sorry for the flame… I just hope one day I would be able to actually install suse for one of my technically less advanced relatives, and know there will be no stupid surprises if the updates are turned on…

dich, did you have any luck in solving this and restoring your proprietary nVidia driver?

Reference why are things this way ? Thats a question for the GNU/Linux kernel developers (as it bites ALL GNU/Linux distributions and NOT just openSUSE). Its not a question for us. We are unpaid volunteer/enthusiasts who just in our free time try to help users on this forum.

So please let us know if you need our help so you restore your proprietary driver. Its not difficult if one uses ‘the manual’ way. I don’t use the repository method so I can’t help there.

For technically less advanced relatives, I recommend they stick with the GNU/Linux free open source drivers that don’t have such a problem.

There is a repository for 11.4 nVidia. you could do one click or add the repository to the list in Yast. The card will be detected and when you check for updates, the option to install will be there. Sorry, I know nothing of GLX. Try it and see what happens. The nVidia applet should have various options and settings. Undoing and redoing settings as well as a logoff or reboot has solve many “problems” automatically for me on many occasians.

SDB:NVIDIA drivers - openSUSE

I do not do gaming and as a general rule I will go with the default, out of the box and work from there. The less programs and driver additions the better. Please understand all the distros are constantly undergoing revision and bug fixes. I started with 11.2 and must say 11.4 is the best. Kernel changes often affect both programs and drivers. It is something we just have to deal with. I backup my entire drive image before I make a change so a reinstall is avoided if something goes awry…

hi oldcpu!

I’ve done that before, and I guess it will work now, too. What I miss is coherence among repositories, and indeed I had no intention at all to complain about what you guys do here. Sorry if it sounded that way.
For reference, itphoenix - I don’t do ANY gaming at all. But somehow openGL has become an important part of simple desktop as well. KDE4 in particular. Your reference is good, but it only contains drivers for the previous kernel and not the updated one.
In my particular case I also started having problems with suspend-to-ram, namely restoring from suspended state stopped working.
The thing I actually am unhappy with - if someone ships an update with a new kernel, why won’t he/she also make sure all dependent repos are updated as well ? For one thing - I’m 100% sure the old Nvidia driver would have worked with the new kernel, too. But the dependencies somehow require the magic numbers to match, even though the graphics subsystem wasn’t touched with the update at all. And recompiling the driver after every update is boring :slight_smile:

I ran the proprietary driver from the 11.4 repository and had nothing but problems. I am running 2.6.37.6-0.5-desktop and the nouveau driver is fine with KDE. I have desktop effects ticked off altogether because they drain resources. Must you have the “rubbery” windows shaking around?

You WILL have s2ram (sleep) with the proprietaries when resuming. Bugzilla will not provide support for the proprietaries, only the nouveau.

If you are not gaming, why force the issue?

Hi all

I wonder if I can get a bit of advice on my situation as this thread appears to be very active

11.04
Gnome 3
Geforce FX Go5600
Nouveau 0.0.16_2
Mesa-noveau3d 7.10-1-2

Now, everything is working well for me other than when I bootup and login where I tend to get 1 of 3 results.

  1. Everything is fine and working perfectly.
  2. Everything is fine but I loose my desktop background
  3. The screen is unusable, with multi-coloured blocks all over the place and no icons even though Evolution for example works perfectly and is readable.

Generally I get a mix of 2 and 3 which I currently resolve by logging out/in a few times until the desktop works.

My first thoughts of the problem lies the the graphic driver although I am surprised that my problem is intermittent rather than persistent.

Removing the Mesa-noveau3d results in starting in failsafe mode.

A couple of questions if I may -

Do you think the problem would be resolved if I installed the correct Nvidia driver?

Oldpc’s post above make perfect sense to me - given my set up, will it be ok to follow this guide, obviously substituting my info and card where necessary?

Any input appreciated

Many thanks

Chris

Gnome3 ??? Given the lack of any other information, I would think that is most likely your intermittent problem.

Its possible you need to remove the parallel boot process, but Gnome3 is not all that stable yet from what I have read.

What happens if you boot with the boot code ‘nomodeset’ ? Does that boot to the ‘nv’ instead of ‘nouvea’ driver ?

I don’t know if will resolve the problem. If it is GNOME3 problem then it may not resolve the problem.

As you deduced, the 270.41.06 driver that I mentioned above is NOT for your hardware. While the new 270.41.06 driver according to NVIDIA DRIVERS 270.41.06 Certified supports Quadro FX series: FX 5600 that is not your hardware from what I read.

I did read this nVidia link about Legacy hardware, where they note What’s a legacy driver? that the 173.14.xx driver supports GeForce FX Go5600 (Device PCI ID 0x312).

The most recent older legacy driver is the 173.14.30 driver according to NVIDIA DRIVERS 173.14.30 Certified supports GeForce 5 FX series FX 5600XT, FX 5600 Ultra, FX 5600 and Quadro FX series FX 5600 (I don’t see GeForce FX Go5600 mentioned, but you could try this 173.14.30 driver).

A bit of advice is all I can provide. Oldcpu is more qualified as to the technicalities of the openSUSE system.

Be that as it may, the problems you are reporting are indicative of insufficient RAM and CPU utiliztion of the video card–it is as if you are running on-board video on an antiquated machine with minimal resources. This can point to two things: there is corruption in the system (bad hardware or a phantom error) or the driver, or the card is no good.

If you have not checked your hardware and your installation disk with media check, and have performed an MD5 check before burning, and there is just one error, then you will be spending eternity trying to fix something that may not be able to be fixed.

The reason I say this is there are only two people reporting so far that cannot get this combo to work. There is always the option to test your system with Vista or 7, or to reinstall 11.4 once you know the install disk is 100%.

Awesome, you helped me too. However, it brings up a question. These are fresh installs, using the DVD. How is it that we ended up with incorrect or non-matching kernels and source? It seems there is a problem with the Yast2, or repositories for this to have happened in the first place no? In any event, your efforts have helped me too.

In my case, it is an Intel mb, Nvidia GTX 285 vidio card, with lots of ram and power. This seems to simply be a case of the install pacakage is installing from a clean install dissimilar pieces. This sounds like a bug to me.

I was also having issues installing the NVIDIA drivers with a GT240, and when I saw this I recalled that I had already experienced version problems. I had to update the kernel since I has the latest version of the kernel-source and kernel-devel packages, and it did not match the kernel.

The drivers installed smoothly afterward. lol!

OMG always keep the entire system up to date!! Also, always go with the defaults first to see if the system is stable, then try messing around with drivers, software, settings and such.

I am still using the default, automatically installed, nouveau driver and it has not failed yet for several months so far.

My sound got knocked out by uninstalling and installing software (probably). After going nuts and reinstalling the ALSA driver, I wound up on the ALSA site and installed their driver package. Problem resolved. Sometimes reinstalling the driver works but if it is corrupted it has to go. There is only one driver for my Titanium card so that is why I think mine was corrupted.

My monitor used to dim after 10 minutes even though I set it for 1 hour in power management. I did not know it also had to be set elsewhere as well. See I already forgot where that was!! Desktop something-or-other.