installing NVidia driver for Geforce GTX 275 fails


I have just installed openSUSE 11.1 64 bit on my system. Subsequently registered to get an auto-update repo and auto-updated until no more updates were offered.

Then I first tried YaST to install NVidia drivers from the NVidia repo (added their repo), but sax2 wouldn’t recognize them.

So I downloaded their 190. (beta) drivers, installed the kernel source code and gcc 4.3. Then I switched to a console (Ctrl+Alt+F1), closed the x server, ran the driver install as described (gcc 4.3 is installed). Installer said that all is fine (I checked the log to be sure). So I ran sax2 -r -m 0=nvidia, but the driver still isn’t recognized.

What can I do now to make this work?

Solved. I simply had to call nvidia-xconfig as root.

karx11erx adjusted his/her AFDB on Thursday 20 Aug 2009 20:56 to write:

> Solved. I simply had to call nvidia-xconfig as root.

Thanks for posting the solution, now maybe others will see your post and
know the cure.

However I doubt it very much.


Caveat emptor
Nullus in verba
Nil illegitimi carborundum

I’m very glad you solved the problem, but I’m new to Linux (and opensuse). Could you please explain?

First off, it is suggested that you install and use openSUSE 11.3 as it is supported while openSUSE 11.1 is not, though that may have been a typo. Anyone that wants to install the nVIDIA proprietary video driver should read the following documents:

SDB:Configuring graphics cards - openSUSE

You can install the nVIDIA driver using the 1-Click Installation Here:

SDB:NVIDIA drivers - openSUSE

Also, pay close attention to the repository method that was mentioned above. I normally install the nVIDIA driver the hard way. I download the most recent driver from here:

Welcome to NVIDIA - World Leader in Visual Computing Technologies

There is a document on how to install this driver the hard way here:

SDB:NVIDIA the hard way - openSUSE

I happen to have a bash script file you can use to install the driver the hard way from here:

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3

Message #12 has the most recent version of lnvhw for your usage.

Loading the nVIDIA driver the hard way allows you to keep the most recent version loaded BUT, every time you update your kernel, you must reload this driver. If you do not mind not having the most recent driver, using the repository method to load the driver, might be a better choice for you. If you did not see that, reread the documents I have posted here for you to read.

Thank You,

Condulmari, in a nutshell this is what he did:

Tried to install nvidia-drivers via the repo which didn’t work.

Went to Drivers - Download NVIDIA Drivers and downloaded the driver for his card and OS.

Switched to a terminal via Ctrl+Alt+F1

Ran init 3

Switched to the directory where the driver was and ran “sudo ./NVIDIA…”

sudo nvidia-xconfig

You can modify the nvidia settings so that it is ran as a root user in kde using the following command or by an edit of the menu entry for the nVIDIA Settings program:

kdesu nvidia-settings

You can create a desktop icon, in KDE, if using the folder view by saving the following text as ~/Desktop/nVIDIA-Settings.desktop

[Desktop Entry]
Exec=kdesu nvidia-settings
GenericName[en_US]=nVIDIA Settings
GenericName=nVIDIA Settings
Name[en_US]=nVIDIA Settings
Name=nVIDIA Settings

Thank You,