Installing new programs?

Sorry if this isn’t the right place for the topic.
I’m new on Linux (Got 11.2, KDE) and have a very limited internet connection. I installed Suse from DVD but can’t download everything I want. I can do that somewhere else (using Windows) and take the packages home with USB stick. Here are my questions:

  1. How can I determine all of the dependencies of a program? (Checking via YAST>Software Management and noting down all it shows before downloading, will that work?)
    2)How can I install them? In the right order?
    3)Where are the packages I downloaded kept? I checked “Keep downloaded packeges” in Repository configuration. I want to back up them on my expansion disc so I won’t have to download all if I have to reinstall Suse for some reason.
  2. Not related but yesterday while I was downloading codecs I added Packman and switched packages to this repository as was said in multimedia forums. It worked for media playing but I lost OpenOffice. Can I install it from DVD via system repair? Of course without losing multimedia.
    It’s been too long and I’m sure asked before but I couldn’t find where, thanks in advance.

I’m new here and I hope someone has a better answer for you. If you don’t use a package manager you are in for a lot of work but it is doable. There are several tasks that have to be done for each dependancy. Download the tarball. Unpack the tarball. Install the software.

Yes, you would need to install any dependencies first. Use YaST and write down any lib files you need and install those first. They need to be installed before any executables but don’t need to be an any particular order.

You can manage and query the rpm database on you system using the rpm command line tool. The database will can tell you where the files are stored.

If you read up on the rpm system RPM Package Manager - Wikipedia, the free encyclopedia and “man rpm” there might be a way to setup a local repository on your system. There may be a simpler way but I think rpm wants an ftp or HTML link for downloading so perhaps one way to get the packages on your system would by to create your own ftp server archive.

Thanks, it’s really a big problem here and I need to find a way. I’ll try to do what you said and I’d be grateful for all help.
By the way any opinion for the lost OpenOffice?

Does OO come up when you type ooffice in the run box? If not then check YaST Software Manager and make sure the OO RPM Group is checked. If it does come up then right click on the Desktop icon in the system tray and choose Create New -> Link to Application -> Application and enter /usr/bin/ooffice.

I just checked an YaST allows you to use a CD or a disk file as an RPM repository. YaST -> Software -> Software Management -> Configuration -> Repositories -> Add

Thanks a lot

Realy there was a way to add a local directory as repo in software management. I added a path and can install everything from there but for a reason I don’t know, even if I select an rpm from there, it goes on downloading from packman so first I disabled all repos, left only the local directory, then it worked (sure I had provided all dependencies in the local directory.)
For the open office, I added dvd as repo and installed all office packages from there. Now all goes fine (except for what I mess up!!)
Thanks again.

I believe that Yast will prefer the repo that the original install came from. There is a number usually 99 for most repos Yast should use a lower numbered repo over a higher numbered one. Though I’m not sure that still works in 11.2

I think what you’ve said is correct, YAST preferred Packman, I had downloaded the packages from there.
How can we check which number is the preferred one- the lower or the higher? I configured the priorities according to what was said in the forums, OSS and NON-OSS has 120, Packman 90 and Updates 99.

The lower the number the higher the priority. Think sort order which comes first. But as I said I don’t know if priorities are working the same in 11.2. Since it seems that the original source is looked at first. In the software management screen you can select which repository to load packages from it is one of the tabs. That overrides all other things.

Installing software in any linux distro is easy once you know how, all OS’s have a different way to install software.
Installing software in windows is different then installing software in OSX, or linux or even BSD.
You can install software the “windows way” in opensuse, heck we have better with the one click installers.
You can obtain a lot of great software via webpin too

Sorry mods for the double post, I am not having a good night.
Anyhow we don’t install software the same way in linux as you may do in windows.
Firstly we have the YAST software installer, it will take care of most of your installation woes.
Using the software installer should be easy but if you want something to help you get started you can go here:

There is webpin too as I mentioned but it seems down right now, but here is the link and hopefully it will be up again soon.

One thing worth mentioning, is to not download random .rpm’s you find off the net, openSUSE has issues with packages not in its main repositories.
openSUSE has a few drawbacks in not having as much packages as other linuxes but if you need something we might be able to help out.

To the OP: You can even download entire repos on a windu machine, put them on a stick or disk, or one of those fancy toe nails, take them home and use them as repos. If you need instructions on that, please be specific about what you want.

I founded the way thanks to friends and searches. It’s much more easier than windows if you have a decent internet connection but I don’t have one, so I check dependencies via YAST, find some place to download and go to OSS, Update or Packman repos and get them down.
Just the problem I mentioned above: I added a local directory as repo, told YAST to install some programs from there but it preferred Packman. When I disabled all repos temporarily, it had to get them from directory. So I think it’s what gogalthorp has said: the priority. I didn’t have the chance to check it today but I will tomorrow: give the local directory the lowest number. I guess it will work.
What is the way to get the whole repo down at the same time? I have an expansion disc, perhaps it will be the best way to do it in a while than checking every program in YAST.


This should be easy for you… and I’ll try to be as more simple as it can be:

You installed the system by a CD/DVD most likely, in this case, YaST can install programs that are part of the distribution. If you don’t want to drag the media around all the time, mirror it and run a local depot. Thats a very good start.

Now like everyone else, you will find the programs in very different formats, some binary, other source codes. It’s always nice to have around the development packages… at least kernel-headers, related stuff, system development, etc.

Some applications, like Nero for Linux have it’s own installer, so you doesn’t matter a lot, you will find a link for them and download them the normal way, and install them as super-user. They are pretty user friendly. You also find the packages in rpm form… Honestly, my advice is that you get the source packages and build them on your system. If you have the develop packages installed, it’s pretty nice and RPM does everything for you. You can also get “raw” source codes, those you unpack and read the documentation, these are the less user friendly ones. So there’s actually nothing you can do for this.

You may want to try some other distros on the side, if openSUSE is not working out.
If you are on wireless you may want to try Ubuntu or one of its spin offs like ultimate edition.
Sometimes Ubuntu is better at wireless, but this depends on your hardware of course.
Try anything thats my perspective.

Thanks but suse works great for me (if I don’t mess things up and it’s the way to learn, I think)
My problem is: I added a local directory as repo (my expansion disc) and when I want YAST to install packages from there (I download them on an other computer with all dependencies and put them on my expansion), even if YAST sees the local repo, it goes on downloading from Packman. I changed the priority and gave local repo 75. But it doesn’t work. It installs them from expansion only if I disable all other repos temporarily.
If I’m not wrong, YAST searches for a key and it doesn’t find it on my expansion so doesn’t trust it.
Anyway, I can manage it by disabling other repos but I wanted to learn how to make YAST accept my repo.

I’m not sure that priorities work in 11.2. I beleive that priority is given to the repo that you last got a package from. If that repos is no available then maybe priority works. You can now force a repo in the management screen. In your case turning off repos is best since you get get to them anyway.

Thanks, I’ll go on like that.