Installing New Kernel / Hauppage HVR 3000

Yippee! After several years of struggling trying to get this card to work, I have just read the following on Hauppauge WinTV-HVR-3000 - LinuxTVWiki: “Kernels 2.6.28-rc1 and later have a working multiple frontend driver built in.”

I am running 11.1/KDE3.5.10, with the original kernel,, so I’m hoping that updating the kernel (to 2.6.30?) will fix the problem.

HOWEVER, I have never done this before, and I’m scared! I notice that there are 1-click install kernel packages in the openSUSE Build Service, but from reading I’ve done in the past, I don’t believe it can be that simple!

I’d be very, very grateful for any guidance about the best, most up-to-date, idiot-proof (i.e. me-proof!) way of doing this.

What you could do, in order to gain some experience, is download the live CD for openSUSE-11.2 milestone5 , and do NOT install it to your hard drive, but rather just play with it, and see how it works with your Hauppage HVR3000. I assume you know how to do the md5sum check on the liveCD’s iso file (before burning) and then burn at a slow speed on high quality media, do the media check, and then run the live CD.

It has a newer kernel version, and the 11.2 milestone5 may indicate to you whether it is worth the effort to play with 11.1’s kernel version.

Also, if the 11.2 milestone5 does not work, you could even consider writting a bug report on it.

Still, if you decide to custom compile a kernel, we have some experts on this forum who can help you (but I am not one of them). :slight_smile:

Great idea, Oldcpu. Thanks as always!

Also, thank you for all your support in the past on this issue. I’ve almost had this troublesome card working on occasions, but never quite made it. Let’s hope this does it.

More trouble, I’m afraid.

I downloaded the Live CD successfully, and did a MD5 check, which was all OK.

I then burnt the ISO using k3B. When I do a media check, it fails the MD5 checksum.

I think it may be due to k3B only allowing “auto” or “10x” write speed.

Can anyone recommend how to change this, or an alternative CD burner?

When you say “all OK”, does that mean you compared the md5sum from typing: ‘md5sum some-downloaded-file.iso’ against the md5sum in the md5 file on the web site, and they were the same?


But when I do a media check from the created CD, it says that the MD5 sums do not match, and it does not load properly.

What media are you burning to? RW? R+ ? R- ? I don’t recommend RW. Have you tried burning the CD from a different PC ? How old is your CD reader? Your CD writer?

Thanks for your support as usual, OldCPU. I really am most grateful.

I’ve done some more investigations. If I calculate the MD5sum on the downloaded ISO file (md5sum some-download-file.iso_) I get a figure which exactly matches th one on the web-site, BUT if I use Yast>Media Check>Check ISO, I get the message “MD5 sums does not match”. So, it looks like a corrupted download. I used aria2.

Anyway, I’l have another go at downloading.

Thanks again

No. The downloaded iso is OK, since you get the exact md5 sum. Since the burnt media are not OK, the iso does not get burnt correctly to disk. Try burning it with option TAO and a lower burning speed.

It is always difficult to tell a user’s Linux knowledge level.

Over the past 5 years of trying to provide Linux support, I can think of over 1/2 dozen occasions, where a user ran the md5sum against an ISO file, and considered that was the “check” (but did not compare the sum/number with the web posted md5sum).

The mistaken belief of these users was that if a sum was produced, that mean the ISO was ok. … Of course, nothing could be further from the truth, but they simply did not know.

Hence I now do not assume users (who I do not know) understand what it means to do an md5sum.

I may not have been clear, or I do not understand the reply.

If I run the md5sum on the downloaded ISO, it produces the same checksum as the one published on the web-site.

If I use yast>media check on the downloaded ISO file on my hard disk (i.e. before I burn it) I get an error message saying:

Result: Error – MD5 sum does not match
This medium should not be used.

I downloaded the Live CD again, but still got the same result.

Please forgive my lack of understanding, but this does not make sense to me.

Various things can cause this.

What media are you burning to? RW ? R+ ? R- ? Are you burning on the same PC as you are trying to run ?

Despite the md5sum, did you check to see if the CD would boot to GUI ?

I have been burning to a RW disk - the only CD I had available.

Yes, I am burning on the same PC as I’m trying to run, BUT for historical reasons the boot drive (master) is not the same as the DVD/CD burner (slave). I will swap them over during the next few days so that the master is also the burner. The burner is also a much newer drive than the present master, so it makes sense to swap them.

I tried booting from the CD. It boots to the GUI, but then locks up after a few actions.

So, my next move is to swap the drives, get a -R CD, and try again. I’ll post again in a few days with the results.

Thanks again for all the help.


I re-arranged the drives, and booted using the Failsafe settings, and all seemed to be well.

I then went to Kaffeine, scanned the DVB-T channels, and it found them all!

Just the final hurdle, now - when I select a channel, Kaffeine produces an error message saying something like “Cannot Open Media”.

I am getting very excited, and hope someone can make my day by solving this last problem.

I don’t have a TV device. My wife used to, and a couple of years ago we got it working under an older openSUSE version.

Could this be a permissions problem? Since this is a liveCD, what happens if you run kaffeine with root permissions and try this?

I tried that, but it didn’t work. Then i tried a bit more digging around, to discover that it seems to be a KDE4/Kaffeine/gstreamer problem, caused by Kaffeine default to the gstreamer backend. The live CD gives no option to change this.

So, it looks like the TV card is working. I’m just about to download the live Gnome version to see if I can get real TV!

If your pc has enough memory, you should be able to download and install in RAM (via zypper) all sorts of TV apps. The key thing is “IF” your PC has lots of RAM.

Thanks, OldCPU.

I have 2M of RAM, so I guess that should be OK. I’ll try this before Gnome (of which I have no experience).

Do you have any further suggestions about what and how to download? It seems I only need to add xine to Kaffeine.

I’m fairly satisfied that the new kernel will support my card, so the next stage is to update the kernel for my existing installation. I have absolutely no intention of upgrading to 11.2, since I don’t like KDE4, and many of the problems I’ve had with my 11.1 installation have been due to KDE4-based applications (Kicker, Kupdate, etc.).

I confess I could never get kaffeine to work well on my wife’s PC. Of course I never was allowed much time to play with it, as she is WinXP fan. Still, you could consider other apps. … There are some listed on Packman:
PackMan :: search for tv

Well, others will have to help you re: the 2.6.28 kernel. Note you may break many drivers (sound, graphics, web cam) and have to custom compile them after going for 2.6.28.

I am a BIG KDE3 fan (still using KDE-3.5.10 on all PCs in our place) but having typed that, I’m pretty convinced now I will move to KDE-4.3.x in 11.2. A small number of days a go, on my sandbox PC, I installed KDE-4.3 from the openSUSE-11.1 “community” KDE-4.3 liveCD “KDE Four Live” CD]( and I now view KDE-4.3 and KDE-3.5.10 on equal footing. At least equal for the apps i use . In fact, KDE-4.3 may even have a slight edge now over KDE-3.5.10 (in my view). Hence I think it may be premature to write off 11.2 because of KDE4.

I suspect there will issues OTHER than the KDE4 desktop that may have people perturbed at openSUSE 11.2. KDE-4.3.x is shaping up very very nicely.

Thanks as ever, Old CPU.

I’ll keep going now until I acheive breakthrough, and report back to this thread with my experiences. I wouldn’t have known where to start without your advice, so I’m deeply grateful.

Look out for panic-driven posts on kernel upgrading!!!