Installing Leap 15.3 from Leap 15.0

After a long time I’m trying to upgrade my Leap 15.0 machine to Leap 15.3 using zypper, following the instructions on the download web pages. So far I have successfully (I hope) upgraded to 15.1 but I’m having difficulty going any further. When I try to download and install Leap 15.2 it tells me “Nothing to do” and stops. It’s also telling me “Permission to access ‘’ denied”, which may or not be relevant.

How do I proceed from here?

That Packman repo has vanished some time ago. Search for another mirror, like$releasever/

There are many instructions on a varied ways to upgrade. As long as you do not tell rather exactly what you did, I am afraid help can only be improvised.

You seem to do it version by version, which in itself not a bad idea, but as 15.1 and 15.2 are already E.o,L, for some time, I do not know if their full repository set is still available.

Thanks. It’s running now.

I followed, quite literally, the instructions at
Hopefully, with the mirror corrected, things will run (more or less) smoothly now.

Well, IMHO opinion Packman is not important ATM at all. It would always disable Packman during such an online Upgrade, only to enable it again (and then do the “Vendor Switch”) after my upgrade of the main repos was sucessfully finished.

I am unsure if you are now on a successful course, but I assume you will report back when not. And then please always show what you did: the exact commands at least. There are still so many small diversions and maybe errors to be made. And we can not give any advice when we are not informed.

Thanks Hank. With a correct mirror for Packman Leap 15.2 is now installing, so getting that right was obvious very important.

And I take your point about reporting the details. However, with the reboots what I typed is lost, so I have only the instructions to refer to. Hopefully, as Suse is developed, the procedures will get even more simplified.

And now it’s telling me that openSUSE-Leap-15.3-Oss is invalid, since valid metadata can’t be found there. This on entering

zypper --releasever=15.3 dup --download-in-advance

Has the mirror for this changed as well? Are there another other repository changes that I should know about?

15.3 has added new repos. This is the content of the two new repo files on this PC:

# ls -Gg /etc/zypp/repos.d/*BP*po /etc/zypp/repos.d/*SLE*po
-rw-r--r-- 1 240 Jul 27  2021 /etc/zypp/repos.d/UpdateBP.repo
-rw-r--r-- 1 135 Jun  2  2021 /etc/zypp/repos.d/UpdateSLE.repo
# cat /etc/zypp/repos.d/*BP*po /etc/zypp/repos.d/*SLE*po


It could be because of many updates since initial release that some things can’t work without those enabled.

When something like this is reported here (and the OP then assures that he he all the time used the same repo URL), we normally advice to wait for a few hours because the mirror may just be updating.

In your case, you did not use it all the time. So we might be interested in checking what you try to use. What about

zypper lr -d

I do not think he is already there. He seems now to have a 15.2 (which did not have the new repos) and trying to upgrade online to 15.3 That should automagically add those two new repos. No need to do anything particular, except a zypper up afterwards (because the new repos have many patches).

So I tried checking this morning and got

#  | Alias                         | Name                                    | Enab
led | GPG Check | Refresh | Priority | Type   | URI                                
                                      | Service 
 1 |    | nVidia Graphics Drivers                 | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
e/leap/15.2                           |  
 2 | gyazo_gyazo-for-linux         | gyazo_gyazo-for-linux                   | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
-for-linux/opensuse/15.2/x86_64       |  
 3 | gyazo_gyazo-for-linux-source  | gyazo_gyazo-for-linux-source            | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
-for-linux/opensuse/15.2/SRPMS        |  
 4 | openSUSE-Leap-${releasever}-1 | openSUSE-Leap-15.2-1                    | No  
    | ----      | ----    |   99     | NONE   | cd:/?devices=/dev/disk/by-id/ata-HL
-DT-ST_DVD+_-RW_GS40N_K06FC7H2230     |  
 5 |         | Packman Repository                      | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
packman/suse/openSUSE_Leap_15.2/      |  
 6 | repo-debug                    | openSUSE-Leap-15.2-Debug                | No  
    | ----      | ----    |   99     | NONE   |
distribution/leap/15.2/repo/oss/      |  
 7 | repo-debug-non-oss            | openSUSE-Leap-15.2-Debug-Non-Oss        | No  
    | ----      | ----    |   99     | NONE   |
distribution/leap/15.2/repo/non-oss/  |  
 8 | repo-debug-update             | openSUSE-Leap-15.2-Update-Debug         | No  
    | ----      | ----    |   99     | NONE   |
update/leap/15.2/oss/                 |  
 9 | repo-debug-update-non-oss     | openSUSE-Leap-15.2-Update-Debug-Non-Oss | No  
    | ----      | ----    |   99     | NONE   |
update/leap/15.2/non-oss/             |  
10 | repo-non-oss                  | openSUSE-Leap-15.2-Non-Oss              | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
bution/leap/15.2/repo/non-oss/        |  
11 | repo-oss                      | openSUSE-Leap-15.2-Oss                  | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
bution/leap/15.2/repo/oss/            |  
12 | repo-source                   | openSUSE-Leap-15.2-Source               | No  
    | ----      | ----    |   99     | NONE   |
/distribution/leap/15.2/repo/oss/     |  
13 | repo-source-non-oss           | openSUSE-Leap-15.2-Source-Non-Oss       | No  
    | ----      | ----    |   99     | NONE   |
/distribution/leap/15.2/repo/non-oss/ |  
14 | repo-update                   | openSUSE-Leap-15.2-Update               | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |
/leap/15.2/oss/                       |  
15 | repo-update-non-oss           | openSUSE-Leap-15.2-Update-Non-Oss       | Yes 
    | (r ) Yes  | Yes     |   99     | rpm-md |

This doesn’t look too good to me if I’m reading it right. Comments would be very helpful.

But I then decided to try the upgrade again and it’s now running. The repository must have been out for a Saturday celebration with friends or something.

Hm, a bit difficult to read (because you broke the lines, to small a terminal screen?). But it does not look to bad. Of course you should have disabled those gyazo repos before you started. Do not the instructions tell you to disable all extra repos?
As I told above, I do the same for Packman.

BTW, your repo list does have output, but you did not include the line with the prompt:command. So we have to believe that you did the correct command. We do not believe much, except when it is copied/pasted computer text.
Same for your earlier report about the error you got. What we prefer to see is the complete prompt:command - output - new prompt sequence. All to avoid misunderstandings. All to avoid you forcing your conclusions upon others that want to draw theor own conclusions from the unchanged information.

Due to the above missing of the real output, we can not check what exact URL is mentioned there, let alone try for ourselves. So disable non-standard repos, and redo

zypper --releasever 15.3 dup --allow-vendor-change  -download-in-advance

and post here complete.

Users are not interested in disabled repos. Have a preview and adjust window size before submitting:

**erlangen:~ #** zypper lr -uEP 
#  | Alias               | Enabled | GPG Check | Priority | URI 
 5 | Packman             | Yes     | (r ) Yes  |   90     | 
14 | openSUSE-20191106-0 | Yes     | (r ) Yes  |   99     | 
19 | repo-non-oss        | Yes     | (r ) Yes  |   99     | 
21 | repo-update         | Yes     | (r ) Yes  |   99     | 
 1 | Application_Geo     | Yes     | (r ) Yes  |  100     | 
 3 | BellSoft            | Yes     | (r ) Yes  |  100     | 
 7 | chrome              | Yes     | (r ) Yes  |  100     | 
11 | jalbum              | Yes     | (  ) No   |  100     | 
**erlangen:~ #**

Users are not at all interested in repos. They only want functioning working environment.

It is system managers that should be interested in repos.

For all practical purposes I am the system manager. It’s just that openSUSE has worked so well these past few years that I haven’t been following the changes and many of the technicalities have slipped my mind.

I posted the output from zypper lr -d far too soon. I tried rerunning the upgrade, as I later posted, and that’s appeared to work. However, when I rebooted it failed to start the graphical interface. It tells me “Welcome to openSUSE 15.3” and offers me the command line logon.

Above this is states “Failed to start Load Kernel Modules” twice.

(Incidentally, the output I posted was complete. It just doesn’t fit on the line. I’ve started another thread about this, but I’ll worry about that when I’ve got the system back up and running.)

Yes, a new thread for the new problem is indeed better.

Do you want me to start a new thread about my Leap 15.3 not loading the graphical interface?

Would be better wouldn’t it? A new title advertising it with the graphical card type would hopefully draw the attention of those using that card. Your present thread has another subject.

Users wanting a functioning working environment are their own system manager. They read the documentation which says:

To avoid unexpected errors during the upgrade process using    zypper, minimize risky constellations.   
  •   Quit as many applications and stop unneeded services as possible and      log out all regular users. 
  •   Disable third-party repositories before starting the upgrade, or lower      the priority of these repositories to make sure packages from the      default system repositories will get preference. Enable them again      after the upgrade and edit their version string to match the version      number of the distribution of the upgraded now running system.

The problem was solved in the new thread. What I had to do was simply to use zypper up. That did the trick.