Installing KDE4.2

Hi,
I have just installed openSUSE 11.1 (gnome) and I want to install KDE 4.2.
However, when I try to run the installer at KDE/KDE4 - openSUSE, I get an error:

There are some conflicts on the transaction that must be resolved manually.

What gives?

Save the error to file with the expert button in the error box and post it here, we can help you through it.

Post terminal output also of;

zypper lr

Can’t find any expert button but the problems appears to be.

  1. libkdepimlibs4-4.2.3-3.1.i586 requires libical0 >= 0.43 but this requirement cannot be provided.

  2. kde4-akregulator-4.2.3-6.1.i586 requires kdebase4-runtime >= 4.2, but this requirement cannot be provided

I gather I have the choice of not installing more than 50 libraries/apps. I have chosen to cancel installation.

The output of zypper lr follows:

| Alias | Name | Enabled | Refresh
—±-------------------------±-------------------------±--------±-------
1 | 20090508-154633 | 20090508-154633 | Yes | Yes
2 | KDE:42 | KDE:42 | Yes | Yes
3 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Yes | Yes
4 | Mono | Mono | Yes | Yes
5 | devel:tools:building | devel:tools:building | Yes | Yes
6 | mono-stable | mono-stable | Yes | No
7 | openSUSE:11.1:Update | openSUSE:11.1:Update | Yes | Yes
8 | repo-debug | openSUSE-11.1-Debug | Yes | Yes
9 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | No
10 | repo-oss | openSUSE-11.1-Oss | Yes | No
11 | repo-source | openSUSE-11.1-Source | Yes | Yes
12 | repo-update | openSUSE-11.1-Update | Yes | No

Cheers

Remove repo #3 you don’t need reop #8 and 11 enabled either
Make sure the Updates repo is set to 99 priority
refresh everything
try again

you may also want the 42 community for kde4
Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42

Hi,

tried this but the first error still appears and the second has changed.

So I started the Software Manager and upgraded libical0 to a version > 0.43. This got rid of the first error. Why didn’t the KDE4.2 installation do this automatically? Or is the Package Manager at fault for allowing an upgrade that is incompatible with some installed package?

The second error now is:

kde4-gwenview-4.1.3-4.7.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be met.

Does this imply that different parts of KDE 4 require different versions of kdebase4-runtime? Doesn’t this make KDE4 uninstallable?

Totally Confused
Russell

You need to delete kde4-gwenview
or use the do not install kde4-gwenview option to allow the install of gwenview (note not prefixed by kde4) this is the kde4.2 version

Thanks for your help and patience.

Are we to assume it is OK for you now?

Everything seems to be working properly - well almost.

I do get several errors when I logon and logoff:

Unable to use GStreamer Multimedia backend:
The shared library was not found.

I haven’t tracked this down yet.

Check through this
Check your multimedia problem in ten steps - openSUSE Forums