Installing kate source


I wanted to fix something in the Kate editor. So instead of downloading it from it’s website (Get It! – Kate | Get an Edge in Editing) I wanted to download the “openSUSE Kate” source package.
So I tried:

$ zypper si kate
Reading installed packages...
Loading repository data...
Source package 'kate' not found.
Resolving package dependencies...

Nothing to do.

But as you can see, there is no source package available. I tested it with source installation of “zypper” (zypper si zypper) and it worked.

Any ideas? Is the kate source code in another package?


On 04/06/2011 08:36 PM, Ctwx wrote:
> Any ideas? Is the kate source code in another package?

do you have the source repo enabled and refreshed?
for me, i don’t know for you (since you didn’t say your operating system)…

CAVEAT: [NNTP via openSUSE 11.3 + KDE4.5.5 +
Thunderbird3.1.8] Can you believe it? This guy Ralph wins $181 million
in the lottery last Wednesday, and then finds the love of his life just
2 days later. Talk about LUCK!

Yes I have enabled the source Repo:

$ zypper lr -u|grep source
11 | repo-source                               | openSUSE-11.4-Source                      | Ja        | Ja            |

You can take a look at Index of /source/distribution/11.4/repo/oss/suse/src and search for “kate”. You won’t find anything. :confused:

I got the solution.

Kate’s source code is either in kdesdk4 or in KDE:Unstable:SC’s “kate” source code package. I got this information on #opensuse-de.

I don’t understand why you install kate from a website. It’s in the repos. It may very well be that the fix/change you’re looking for is already in there. May I, as a kate user, know what exactly you want to change?