Installing Joomla 3 on OpenSuse 12.3

I need to install and configure Joomla 3 on my newly installed OpenSuse 12.3.
I used Joomla 2.5 in OpenSuse 12.1 where it was much simpler because of single LAMP server installation took care of Apache, MySQL and PHP at once.
While 12.3 has LAMP server (patterns-openSUSE-lamp_server) available with the distro, but I couldn’t figure out how it would meet the prerequisites of Joomla 3 installation.

As prerequisites, following packages required for Joomla 3 installation:

|PHP (Magic Quotes GPC off)|5.3.1 +|5.3.1 +|
|Supported Databases:|
|MySQL[1]](!#cite_note-MySQL6.0-0) (InnoDB support required)|5.1 +|5.1 +|
|MSSQL|10.50.1600.1 +|10.50.1600.1 +|
|PostgreSQL|8.3.18 +|8.3.18 +|
|Supported Web Servers:|
|Apache(with mod_mysql, mod_xml, and mod_zlib)[2]](!#cite_note-mod_rewrite-1)[3]](!#cite_note-PHPFileHandler-2)|2.x+|2.x+|

Following packages installed and running on my OpenSuse 12.3:

  1. PHP5
  2. Apache2 ← started the service from YAST | System | Service
  3. MySQL (MariaDB) ← started the service from YAST | System | Service
  4. phpMyAdmin

Note that, I didn’t install patterns-openSUSE-lamp_server, because I am not understanding, why I need this when PHP, MySQL and Apache are already installed.

When I started installing Joomla 3, installation wizard asks me to create a database, but MariaDB doesn’t allow me to create a new DB.

Here are the commands and their associated outputs:

jrahman@linux-x4ab:~> mysql -u rootWelcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 2
Server version: 5.5.29-MariaDB-log Source distribution

Copyright (c) 2000, 2012, Oracle, Monty Program Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB (none)]> 

MariaDB (none)]> show databases;
| Database           |
| information_schema |
| test               |
2 rows in set (0.00 sec)

MariaDB (none)]> 

MariaDB (none)]> create database myjoomladb;
ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'myjoomladb'
MariaDB (none)]> 

Notice that, MySQL prompts (MariaDB) has a “none” beside it, it means that, it doesn’t started with any existed user of the MySQL.

I tried following command to create the “root” user, but it failed:

jrahman@linux-x4ab:~> mysqladmin pingmysqld is alive

jrahman@linux-x4ab:~> sudo mysqladmin -u root password "abc123"
root's password:
mysqladmin: Can't turn off logging; error: 'Access denied; you need (at least one of) the SUPER privilege(s) for this operation'

What I need to know:

  1. When and how I could reset the root password of the MySQL (in this case, MariaDB) ? (guess, if I could set the root password for MySQL, my Joomla installation may be successful)
  2. Does phpMyAdmin interface with MariaDB, if does, how ? (I think this question would be answered when I could create at least the “root” user)

Any other suggestion or advice would be appreciated.
All I need your help to successfully install Joomla 3 on my OpenSuse 12.3

Thanks in advance.

Still waiting for solution !

Resetting root passwd on mySQL is not that hard. Huge documentation page dedicated to it here or here

MariaDB is meant to be a full drop in for mySQL meaning that if php admin works for mySQL then it “should” for just fine for Mariadb. I have not tried so I would not know. But the MariaDB devs say its a exact replacement just now. Dont knwo how long this will last for though as im sure their fork in mySQL will take its own path soon enough.

Any help to you?

EDIT: also according to a couple of blogs, php admin works fine with MariaDB phpmysqladmin in the more recent versions ( here

Yup, you need to set the mysql root password first. You might try to use “su -” then the “mysqladmin” command instead of sudo.
phpMyAdmin needs at least one user + password to run. It doesn’t accept passwordless entry.

BTW: the difference between MariaDB and Mysql is that MariaDB is better. If things don’t work as expected, that’s not the place to look for a cause.

BTW: I always suggest using the pattern-container packages. They make sure you don’t miss a single needed package.

Thanks for all the help to resolve the issue.
Yes, there are plenty of good docs on creating/resetting of MySQL user/password as referenced above.
However, this one is very straight forward.

However, here is the summary of steps:

0. Open a console and logon as root (su - root)
1. If already started, stop the mysql daemon (/etc/init.d/mysql stop)
2. Issue the command: [FONT=courier new]mysqld_safe --skip-grant-tables
[/FONT]3. Then issue the commands:mysql --user=root mysql
update user set Password=PASSWORD('new-password') where user='root';
flush privileges;

4. Restart MySQL daemon normally

I dont want to double post so Ill continue with my problem:

Following this thread and countless more I think that the files created were with root and phpMyAdmin writes “Access denied” ( this is my noobish conclusion )
When I issue mysqld_safe --skip-grant-tables i get

130428 19:11:55 mysqld_safe Logging to '/var/log/mysql/mysqld.log'.130428 19:11:56 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql

it doesnt give me


so I can continue

What seems to bee the problem here?