installing guest additions

ok,i spent enough time to find an answere to my question in so many different posts and forums and also googled for past two days and tried so many different tricks that have worked for someone else that had almost the same situation as i do,but here i am now in square one with the frustration of not being able to install the GUEST ADDITIONS FOR OPENSUSE 11.1.

The host is vista 64 and i am using virtualbox 2.0.4.

installing the guest additions for windows xp and ubuntu was a snap and despite being a newborn in linux world ,i could walk my way through installations easily with no helping hand.

after checking some other people’s post regarding the same issue ,i learned to check the "GCC,GCC-C++, MAKE ,KERNEL SOURCE " and made sure they are all installed.

When i try to run the “sudo sh VBoxLinuxAdditions.run” in terminal ,after typing my root password ,i will receive an error message that says ,the file or directory does not exist or something like that .

i was ready to delete the opensuse from virtual machine ,but i thought why not try forum and see what are my chances here,as such i had graet result in the past with my other opensuse problems.

Thank you all.mike

When you select guest additions from the tool bar of Virtual Box, openSUSE will mount it as /media/VBoxGuestAdditions (or something like that). You should see a window pop up in the lower left when this happens and you can click on the entry. Then you need to cd to this directory before executing the sh command.

cd /media/VBoxGuestAdditions

By the way, VirtualBox 2.1.4 is out as well as 2.2 beta, which is what I’m using now and the guest additions work fine.

I would recommend downloading the latest version of VirtualBox from:

VirtualBox

In response to installing VBoxLinuxAddition.run:

Make sure that you installation the correct VBoxxxxx.run driver. If your guest operating system is 32-bit install VBoxLinuxAddition-x86.run - for 64-bit VBoxLinuxAddition-amd64.run.

Example install for 32-bit:

sudo ./VBoxLinuxAdditions-x86.run

Good Luck and Welcome to the openSUSE Community!!

Cheers!

Then you need to cd to this directory before executing the sh command.

Thank you for that quick respond.

can you please explain little more when you say " you need to cd to this directory".

when i click on that cd ,a small window opens with about 6 or 7 different folders which has “vboxlinuxadditions.run” in it too and when i click on that ,i receive “this has to be done as admin. priviledge .click on enter to close” and then when i try the command ,it says “not a file or directory” or something to that nature.

can you please explain kind of step by step.

thanks.mike

Good Luck and Welcome to the openSUSE Community!!

Cheers! [QUOTE][/QUOTE]

Romanator
thank you .it is nice to be a part of this community.

The window that opens up that contains those files is the directory you need to move to. That’s what the cd command I posted above is for. The directory is listed in the address bar of that window.

So you would open a terminal and become root, then cd to the /media/VBox(something). Then you can run the sh command. I believe it has x86 in the file name. That’s the one you want, unless you’re running 64bit Linux.

sh VBoxLinuxAdditionx86.run:

That’s probably not exactly right but you should see the right file when the window opens. Just copy that.

I do not know what i am doing wrong.As you mentioned ,i upgrade to beta version of VB.then i took this steps:

1-opened the device on the toolbar and clicked on “install guest additions”.a small window on the left bottom part of screen opens and shows a cd with the title of vboxadditions 2.0.2 beta…

2-i click on that cd icon inside the small window,a bigger window appears with some different folders.one of those folders is “vboxlinuxadditions amd 64.run”.if i click on this folder ,i will receive another small window that does some fast initial process and asks me because this action has to be done with root password,then i have to click enter in order to close that window.

then i decide to open a terminal here ,and as you said type :
/media/VBoxLinuxAdditons… and then hit enter ,i receive an error message that says " no such file or directory"

3-finally ,after getting nowhere ,i thought i will try the sh command in your post ,and again receive the same error message “no such file …”

I know that i am doing something wrong and the reason is that i really do not understand alot of basic terms and tricks in linux .for instance ,when you ask me "So you would open a terminal and become root, then cd to the /media/VBox(something). Then you can run the sh command. "
honestly ,i do not know what exactly the process is to open a terminal and become root,my guess is that i have to type “sudo” in front of anything to become root.that is the only thing i know about root.and then again when you say “then cd to the /media/…” i do not know what the “cd” stands for.is it for “change direction” or change directory,in any case i use only my guess and that is why i am not getting nowhere.
Now .with the above expalination ,please let me know ,where is it that i am not doing right and if you don’t mind ,please correct me and talk to me a five year old child language.thnks for your pateince.http:///home/mike/Documents

Just a tip:

When in the directory go su in the terminal and enter your password.
Use the TAB key on your keyboard to autocomplete text, it will do so as far as possible, you then need to add the next digit in the actual file you want and then hit TAB again until you have all the file. Just type:

sh V{TAB}

A really easy way to do this is to open a file browser as root so when you run that script it too runs as root. Easy as this:

hit alt+f2

type

gnomesu nautilus

then click run.

The file browser will come up.

on the left hand side choose the mounted VBOXADDITIONS

Click on the script VBoxLinuxAdditions-amd64.run and click run.

This time it will complete instead of asking you to become root.

Hope this helps!

Ian

when i try this ,all i get is “the command not fund”

and when i try to do this

hit alt+f2

type

Code:
gnomesu nautilus

then click run.

it deos not give me any option to hit “run”.

in fact ,after that command line comes up ,when i type “gnomesu natilus” the blinker still blinks and waiting for next thing to be typed up.i even tried "enter " and some other keys ,but nothing happened.

I really appreciate everybody’s help and concern.I know it is frustrating.as i said i am just trying to learn how to walk.

Hi,

It should be

gnomesu nautilus

not natilus.

just copy and paste that after you hit alt+f2.

I’m guessing you’re using gnome since you’re coming from ubuntu.

If you’re using kde then you would hit alt+f2 and then type

kdesu dolphin

I’ve never used the file manager method to run shell scripts that others have mentioned here. So if it works, great. If not , I’ll try to clarify the command line method.

Konsole, terminal, command prompt are all terms to describe the bash shell that is used to control your operating system with typed commands. You mentioned in earlier posts that you tried the cd command to go into /media/VBOXADDITIONS so I’m assuming you know how to open Konsole i.e. a terminal or command prompt.

If you use openSUSE as a normal user, the terminal opens in your home directory with your user name and the name of your user machine on the first line. Since you need to become root to install the guest additions, you would type su (press enter). Then type your root password. Now you have the root privileges that you need to install the guest additions.

The directory that contains the guest additions is mounted in a different directory so you need to move to that directory in order to run the install script. That’s what the cd command is for (change directory).

When you type commands in the terminal, they have to be exactly right. Spelling, spaces, punctuation, everything has to be perfect. That’s why, as already mentioned in this thread, it’s a good idea to use the tab key to auto-complete your commands when possible. So if you use the cd command, you can do this:

cd /media/VB (just press tab here) and it will complete like this:

cd /media/VBOXADDITIONS_2.2.0_BETA1_44647-1

If the tab key doesn’t complete the whole name, just keep typing the next letter and pressing tab until the complete name is displayed in the terminal.

That is if you have already mounted the guest additions iso by clicking on it’s name in the small window that pops up at the lower left of your screen.

Then you can run the shell script like this:

sh VBoxLinuxAdditions-x86.run

or

sh VBoxLinuxAdditions-amd64.run if you’re using 64bit openSUSE.

Again, you can just type sh VBoxL, then press tab to complete the name. Follow the steps above for using the tab key if you don’t see the entire name of the file after pressing tab the first time. Make sure the file name in the terminal is exactly the the same as the name in the guest additions directory.

I’ve seen some misspellings in your posts on this thread so remember, commands in the terminal have to be typed exactly right. Check and recheck before you press enter.

HTH

… and be sure you have
-kernel-source
-kernel-syms
-gcc

installed in the guest system!

Thank you very much for that great detailed post.

I just followed your instructions ,and everything fell in place with absolutely no problems.

The installation of guest additions started and went halfway through until it stopped and i received the following error message:

"Testing the setup of the guest system

Building a test kernel module…

Make file :38:*** Error:unable to find the include Directory for your current linux kernel.specify KERN_INCL=<directory> and run make again…stop.

Building the test kernel module failed.
Giving up due to the problems mentioned above."

Now ,would you please let me know what do i need to do next.

BTW. my desktop envoirenment is KDE.

Thank you . I checked and they are already installed.

Irt the requirements (kernel-source, etc.) make sure kernel-source is the same version of your kernel.

How do i check to see if they are both (kernel source & kernel) the same version?

thanks.mike

Simple way from the command line:

rpm -qa | grep kernel

Or you can start the YaST2 software install tool and look to see if it shows matching kernel and kernel sources. Just type kernel in the search field.

The kernel in openSUSE 11.1 is in three parts so you should see something like this:

kernel-default-base-2.6.27.19-3.2.1
kernel-default-extra-2.6.27.19-3.2.1
linux-kernel-headers-2.6.27-2.28
kernel-source-2.6.27.19-3.2.1
kernel-default-2.6.27.19-3.2.1

OK.i got it

The credit goes all to you nice poeple in opensuse community.

The guest additions is installed.The seamless mode for some reason is grayed out and the full screen does not work.To me mouse was the most important one and i have it now.

I am wondering that full screen problem ,is common or i did something wrong.

Thank you all again.

You probably need to edit the file:
/etc/X11/xorg.conf
in the Linux Guest

Symptom: The dynamic windows were not working, limiting movement of the Guest window on the kde destop. The Mandriva menus were covered and the side bars were not working.

Solution: The Guest Tools must be installed and working. Use a very simple xorg.conf file. When installing Mandriva the system created the usual xorg.conf with fixed resolutions. Using the below file resolved the problem. Note the absence of mode lines etc.

#Section “Device”

Identifier “Configured Video Device”

#EndSection

Section “Monitor”
Identifier “Configured Monitor”
EndSection

Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
EndSection

Section “InputDevice”
Identifier “Configured Mouse”
Driver “vboxmouse”
Option “CorePointer”
EndSection

Section “Device”
Identifier “Configured Video Device”
Driver “vboxvideo”
EndSection