Installing gnucash 2.2.9 - library problem

I’m running OpenSuSE 11.1 with the KDE environment. I’m trying to install version 2.2.9 of gnucash. (The distribution only has 2.2.7.) I downloaded the source and tried to make it. I got the following:

checking for libgnomeui-2.0 >= 2.4… no
Package libgnomeui-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libgnomeui-2.0.pc’ to the PKG_CONFIG_PATH environment variable No package ‘libgnomeui-2.0’ found
configure: error: Library requirements (libgnomeui-2.0 >= 2.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

I don’t quite know how to interpret that message. My system has version 2.4 of libgnomeui, which presumably is newer than 2.0. But is the message telling me that the compilation wants an older version? What does >= mean in this context? And in any event, what do I need to do to proceed with the installation?

Try installing it after searching for it here:
Make sure that you choose 11.1 and then search for gnucash. Also, choose the version you want from the differernt versions displayed as search result.

Thanks – that worked. I succeeded in starting up Gnucash 2.2.9, and it seems to be running fine. The only tricky part was that I had to install gnucash-lang before installing gnucash.

I think it’s still worth to answer your original question because you might run into a similar situation with your next package.

gnucash (and others) have quite a few dependencies. To compile these packages it is not sufficient to install just the libraries but you also need the respective -devel packages. The easiest way is to install the whole Gnome development scheme, because this will satisfy most of the dependencies. Then hunt for the rest. configure will list whatever is missing but the preferred procedure is to read any INSTALL and/or README files available in the source distribution which should list the dependencies.

In some rare cases there are no suitable packages for the dependencies and these must be compiled and installed separately. In such a case don’t forget to run ldconfig after installation of a library.