Installing Gnome

I’m trying to install Gnome on my (old) laptop as KDE takes quite some time to load.
However, when I try starting with Gnome/Xorg I get system crashes (something went wrong - yeah I bloody noticed). Is there a best proceedure to follow when installing Gnome - haven’t found one step-by-step (shouldn’t be all that complicated really) to follow?

As you do not tell how you try to install Gnome it is rather difficult to comment on what you did.
Also, it seems that you already finished that installing (whatever you did), because you are already trying to run it.

So skipping all what you say, what I would do when trying to add a DE to my installation is using
YaST > Software > Software Management, and then from the View menu choose Patterns, scroll down at the left to Graphical Environments where I see three Gnome patterns, select them for installation and Accept.

Likely graphics and Wayland… can you post the output from;

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

If you log out, is the an option to select GNOME on Xorg, if so try that…

Here is output

[martin@linux-q155 ~]$ /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
        DeviceName: 64
        Subsystem: Hewlett-Packard Company Device [103c:17df]
        Kernel driver in use: i915
[martin@linux-q155 ~]$ 

I’ll try with instead see what happens.

If I use Gnome on I get the

Oh no, something went wrong


Plasma works but is slow in loading.
And yes, I did as in hcvv reply - installed all three of those “patterns”.


If you create a test user and login as that user with GNOME on Xorg, still an error? If so are you using sddm or gdm?

Created new test user.
Logged out of KDE, changed to Gnome on
Logged in

Same error

Oh no, something went wrong.

That happened to me with an older computer (which has since gone to the recycling center).

It was caused by the nvidia graphic driver.

I uninstalled nvidia, and then reinstalled mesa. After that it worked.

I don’t know whether that will help in your case – I don’t even know if you have a nvidia card. But it is likely that the issue is related to your graphics card.

It’s not Nvidia, it’s an old Intel.
But hmm, that would suck … Even if the laptop is 7+ years old.

I mean, KDE Plasma works but it’s slow to start (then all is good … ish).
Maybe Cinnamon will give it a snappier performance?


I have a 10 year old laptop with Intel graphics. And it is working fine (both Gnome and KDE).

Honestly, just stick with KDE. Yes, startup is slow. But once it has finished its startup, it runs very well. I suspect the KDE developers made a decision to put concentrate on the efficiency after startup, at the cost of a slower startup.

Ha, MacBook3,1 late 2007 still running fine here, but it has a nice Intel GPU… :wink:

If you prefer KDE type apps, try the LXQt DE, it uses the same Qt framework so supports similar or even same apps. But not all the automated stuff so much lighter feel


Ah, didn’t know that one. I might consider it.
I’ve always liked KDE better than Gnome, but the startup time is starting to irritate me. But as nrickert said, after it has started it runs really well on my HP Elitebook. The only thing is the ridiculously small screen, but this is - unfortunately - nothing that even Gnome can fix.