Installing GNOME on openSUSE 12.3 with installed KDE4 desktop

Hi, I am using KDE4 desktop on openSUSE 12.3. I just tried to install GNOME desktop with yast -> Software Management -> Patterns.
And after I click on GNOME, it showed a message which said gnome-12.3-7.10.1.x86_64 requires patterns-openSUSE-gnome ,
and I should uninstall patterns-openSUSE-kde4_pure-12.3-7.10.1.x86_64 for installing **patterns-openSUSE-gnome

**Should I do it? or there is other ways to by pass this problem and get GNOME installed?
Thx :slight_smile:

You should.
I’m not sure, but guessing from the name patterns-openSUSE-kde4_pure seems to be meant for a pure KDE system. Therefore it conflicts with other DEs.

Don’t fear though. Uninstalling a pattern has no influence whatsoever on your installed packages.
A pattern is just a means to install a group of packages automatically.
You don’t really need it anymore after the installation. And the packages don’t get uninstalled if you uninstall the pattern.

I just install Gnome alongside KDE when installing from the DVD image. I think the installer silently deselects “patterns-openSUSE-kde4_pure-12.3-7.10.1.x86_64” so I never see that message. In any case, it is no problem to uninstall that pattern. Just do it.

well, I did so, and get GNOME installed. But I failed to log in with GNOME, even after I restart the computer… :expressionless:

I use GNOME and i have the following patterns installed

• patterns-openSUSE-gnome
• patterns-openSUSE-gnome_basis
• patterns-openSUSE-gnome_games
• patterns-openSUSE-gnome_imaging
• patterns-openSUSE-gnome_internet
• patterns-openSUSE-gnome_laptop
• patterns-openSUSE-gnome_multimedia
• patterns-openSUSE-gnome_office
• patterns-openSUSE-gnome_utilities
• patterns-openSUSE-gnome_yast
• patterns-openSUSE-sw_management_gnome

How could I see & export this list corresponding to gnome installation?

You can probably use zypper to do this from terminal/Konsole
zypper - pakcage manager
se - search
i- indicates installed packages

$zypper se 'patterns*gnome*'
Loading repository data...
Reading installed packages...

S | Name                                   | Summary                                       | Type   
  | patterns-openSUSE-devel_gnome          | Meta package for pattern devel_gnome          | package
i | patterns-openSUSE-gnome                | Meta package for pattern gnome                | package
  | patterns-openSUSE-gnome_admin          | Meta package for pattern gnome_admin          | package
i | patterns-openSUSE-gnome_basis          | Meta package for pattern gnome_basis          | package
  | patterns-openSUSE-gnome_basis_opt      | Meta package for pattern gnome_basis_opt      | package
i | patterns-openSUSE-gnome_games          | Meta package for pattern gnome_games          | package
  | patterns-openSUSE-gnome_ide            | Meta package for pattern gnome_ide            | package
i | patterns-openSUSE-gnome_imaging        | Meta package for pattern gnome_imaging        | package
  | patterns-openSUSE-gnome_imaging_opt    | Meta package for pattern gnome_imaging_opt    | package
i | patterns-openSUSE-gnome_internet       | Meta package for pattern gnome_internet       | package
i | patterns-openSUSE-gnome_laptop         | Meta package for pattern gnome_laptop         | package
i | patterns-openSUSE-gnome_multimedia     | Meta package for pattern gnome_multimedia     | package
  | patterns-openSUSE-gnome_multimedia_opt | Meta package for pattern gnome_multimedia_opt | package
i | patterns-openSUSE-gnome_office         | Meta package for pattern gnome_office         | package
  | patterns-openSUSE-gnome_office_opt     | Meta package for pattern gnome_office_opt     | package
i | patterns-openSUSE-gnome_utilities      | Meta package for pattern gnome_utilities      | package
  | patterns-openSUSE-gnome_xgl            | Meta package for pattern gnome_xgl            | package
i | patterns-openSUSE-gnome_yast           | Meta package for pattern gnome_yast           | package
i | patterns-openSUSE-sw_management_gnome  | Meta package for pattern sw_management_gnome  | package

it is straightforward if you use gtk version of YaST

rpm -qa | egrep "patterns*gnome"


Sorry, typo…
Should be:

rpm -qa | egrep "patterns.*gnome"

And “grep” instead of “egrep” should work as well.

Thx :slight_smile:

And here is what I get:


Well, that seems to be ok compared to vazhavandan’s list. (I don’t think you need patterns-openSUSE-gnome_laptop to be able to login… :wink: )

What exactly happens, when you try to log in to GNOME?
Do you get any error message?

What Login Manager are you using now? Still KDM?
In that case, which GNOME session are you logging into? AFAIK the “GNOME classic” session doesn’t work from KDM.

Maybe upload ~/.xsession-errors to SUSE Paste or similar, perhaps there’s a clue in there…

Well, I selected GNOME session while I logged in, and then an error message showed.

And, okay, I am using a traditional Chinese version, so I don’t know the exact English translation of this message, but the meaning is:

“** OOps! Something goes wrong.** There is a problem and the system can not recover. To prevent any further problem, all the extension functions are disabled”

And a button of “log out” is under this message.

The .xsession-errors looks like this:

There’s a similar problem here:
But that is for GNOME 3.9.1 on openSUSE Factory.

So, the first question would be, which version of GNOME did you install? (“rpm -q gnome-shell”)
Did you add any additional repos?

Another thing I can think of right now would be a graphics driver issue. (GNOME 3 seems to be very peculiar about that)
So could you please install the package “Mesa-demo-x” and post the output of:

glxinfo | grep render

Try creating a new user and login into that new user

That user already had the same problem with GNOME 3.8.2 on Tumbleweed after a kernel update:
And according to his Xorg.0.log he is using the nouveau driver, so this might indeed be gfx driver related (part of the nouveau driver is in the kernel)…

Okay, I added a new user, and again got the same error:

SUSE Paste


cwpeng@linux-nd5d:~> rpm -q gnome-shell

Mesa-demo-x is already installed.

cwpeng@linux-nd5d:~> glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on NV94
    GL_NV_conditional_render, GL_AMD_conservative_depth, 

The only real error I find in there is this:

/usr/bin/gnome-shell: symbol lookup error:
/usr/bin/gnome-shell: undefined symbol: meta_plugin_manager_set_plugin_type

See here: Re: [opensuse-gnome] GNOME 3.6 entered GNOME:Factory
Follow the suggestion there:

Especially look at mutter, if you have version 3.6.0 installed (and the
respective libmutter* packages).

So please post the output of:

rpm -q mutter libmutter0

And to be sure, please also your repo list:

zypper lr -d
cwpeng@linux-nd5d:~> rpm -q gnome-shell

OK, that seems to be the one from the standard repo.

So you’re indeed using nouveau, coincidence?:sarcastic:

Direct Rendering seems to work for you though, but maybe you should try to install the proprietary nvidia driver?

Edit: I compared the .xsession-errors files and the other user doesn’t have this symbol lookup error in there. (although other stuff is similar, like those virtualbox warnings)
But i do think that is your problem…

Indeed, I did not have** libmutter0 **installed on my system. And after I installed it, I could log in to GNOME!

Thanks a lot!

(However, if this library is required for GNOME, why didn’t YAST installed it when I used it to install the GNOME desktop? )

Maybe a missing dependency?
But AFAICS gnome-shell from 12.3 DOES require libmutter0, so no idea why it didn’t get installed…:\

The right column lists the requirements, libmutter0 is listed there.

Well, maybe you had an older mutter package installed as a left-over from an older distribution, or something like that?
That would have satisfied that dependency, but wouldn’t work with the newer gnome-shell…