Installing from mounted ISO image over LAN

So i’ve been battling this for a while now, trying all sorts of different options and searching the boards before I finally decided to post this.

I can’t make CDs or DVDs, so my only option is to mount the downloaded ISO file on my laptop with CloneCD, then set up PXE DHCP,TFTP server. This method works on other distros but this one in particular is causing me problems in the installer.

So here’s the process:

I copy the files vmlinuz and initrd from the \boot\i386\loader directory to my tftp root directory.

on the system I am installing, i run gPXE, at the prompt type vmlinuz initrd=initrd

I have tried a large combination of different options {install=nfs after I have been having trouble which I will get to later.

the kernel loads, the installer starts. prompts for “Please make sure CD #1 is inserted” naturally, i hit back and select NFS as the install source.

It then prompts me for DHCP configuration and the NFS server IP and directory.

I’m running an NFS v3 server (haneWIN NFS to be specific) and exported the mounted ISO (this case F:) as /suse.

Enter the parameters and /suse

The installer then fails with No Repository found.

While watching with Wireshark, I can clearly see that the installer did not even attempt to send one packet

I then subsequently set up FTP and HTTP servers to host the contents of the ISO, again the installer did not even attempt to send a packet.

The only option that yields any further results was the TFTP install option after I copied the contents in to the TFTP server directory.

Then it would load the files and bring up Yast2, starting with the license agreement. Looks great at this point. As I continue the System Analysis option goes through all the steps and fails at Initialize Package Manager bringing up a pop up saying "unable to create repository from URL ‘tftp://’ and it fails from this point on.

I would really love to install OpenSUSE so I can test the XtreemOS 3.0 beta however i’m reaching the end of my options.

The ISO images I’ve been using were the Full 4GB DVD then after that failed I tried again with the NET version, again the same result. It appears that the installer does not even try to use the other protocols.

An option i have not yet considered is copying the contents of the ISO to the install system’s HD, I find this moot since it would also be re partitioned.


If you have a USB port, it might be easier to install from a USB stick.

Did you try one of those:


This is how I install openSUSE from lan (in virtual machines though).

It sounds like you are heading in the right direction.
You’ve got a lot of things going on so I’ll show what I have done to get this working and hopefully we can get this figured out for you.
First thing I did was copy the contents of an openSuse DVD into my web server directory.
I used HTTP for the install source because it was easy to setup and I can figure what the installer is looking for by looking in Apache’s error and access logs.
I used pxelinux for PXE booting with the following config entry

# install
label install
  kernel linux
  append initrd=initrd vga=normal install=http://<my_install_server>/ insecure=1 autoyast=http://<my_install_server>/profile/

You don’t need the autoyast part, that’s only needed if you have an autoyast file for automagically installing packages and other system settings.

Hope this helps,

Thanks all for your replies.

I have tried those options to no avail. Looking into it further I discovered that I can not even ping from the shell. It grabs a valid IP from DHCP however. (i have also tried manual configuration, also changing from a /16 network to a /24 thinking maybe it just didnt like large subnets) I’m just baffled why only the TFTP would protocol attempt to connect to the server and none of the other protocols even leave the NIC. Perhaps it’s a problem with the network driver.

The kernel log shows this:

repository: looking for
rescanning devices
url mount: trying
(Realtek RTL-8139/8139C/8139C+)
interface setup: eth0
err, eth0: Failed to lookup hostname via DNS: Temporary failure in name resolution
sending DHCP request to eth0… ok.
eth0 activated
nameserver 0:
loading → /content
error 7: couldn’t connect to host
disk: mount ok but test failed
url mount: failed
repository: not found
no openSUSE repository found
Automatic setup not possible.


Yes i have the openSUSE-11.4-NET-i586.iso

but just to satisfy sheer curiosity i’m downloading it again and verifying the checksum.

well you all are going to laugh at this one. I know I sure did. After all the hours (days/nights) I spent on it, it finally dawned on me to turn off the firewall. Even tho it had all the ALLOW rules in place, for some reason it was still filtering it out. I’m still uncertain why other installers would work however.

so there you have it. If you are trying to do what I did and run into problems like this, be sure and turn off the firewall filtering – even tho the rules say allow all – i guess we can’t trust what the program says, just turn it off and it will work. lmao

still running in to trouble with the setup asking for files like /add_on_products that doesn’t exist. I think I can work with that at least.



What a beautiful operating system. I am glad I was finally able to get it working. I still can’t believe the blonde moment about the firewall, that has to be too simple.
Now I get to repeat the process a few more times for the other nodes. I’m not sure if it will work on the old Beast dell server that only contains 256MB of ram, but we shall see (perhaps text only).

On 2011-06-16 06:06, iotaatoi wrote:
> I’m not sure if it will work on the old Beast dell server that only
> contains 256MB of ram, but we shall see (perhaps text only).

It will work, once installed. That is, the problem is installing.

The usual trick is to partition the disk in advance, creating and
initializing a swap partition at least (make it 2 GiB at least).

Mind you, graphical mode will work, but slowly. Don’t use kde nor gnome.
Don’t try applications like libreoffice; even firefox is huge. Disable
flash. Graphical mode is useful for running YaST, even though it runs in
text mode too.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Better use icewm or openbox. Have a look at this post: Would like to confirm that problem is – in fact – a bug.

can i know the option to turn off the firewall. below is the cfg file . please help

default linux
prompt 1
timeout 72
label linux
kernel vmlinuz-SLES11.0_x86_64-sp2
append initrd=initrd-SLES11.0_x86_64.img-sp2 netdevice=eth0
nfsopts=vers=3 textmode=1

can i know the option to turn off the firewall. below is the cfg file . please help.
After migrating to ZFS we get this error.
mount: nfs mount failed, server says: permission denied

[FONT=Helvetica]default linux[/FONT]
[FONT=Helvetica]prompt 1[/FONT]
[FONT=Helvetica]timeout 72[/FONT]
[FONT=Helvetica]label linux[/FONT]
[FONT=Helvetica]kernel vmlinuz-SLES11.0_x86_64-sp2[/FONT]
[FONT=Helvetica]append initrd=initrd-SLES11.0_x86_64.img-sp2 netdevice=eth0[/FONT]
[FONT=Helvetica]110/profiles/autoinst1_x8664_SP2.xml [/FONT]
[FONT=Helvetica]install=nfs://xx.xx.xx.xx/export/local/x86_64/sles/110/base/SP2/cd1 [/FONT]
[FONT=Helvetica]nfsopts=vers=3 textmode=1