installing current ATI driver

Hi

Just came back to opensuse from Ubuntu as the 64bit stuff has got a lot better and just wanted gather some advice

Ubuntu as opensuse dont really update the ATI driver and as it is still playing catch up with nvidia, being stuck on 9.2 is actually regressed my current expereice as they are a lot of better releases since then.

on Ubuntu i have been installing the driver via the AMD download .run file and using the automatic install option + usual other commands after i.e aticonfig to set it up.

how reliabile is this system under opensuse? or is it better to make the script produce RPM’s?

cheers

  • acreda1234 wrote, On 07/14/2009 10:16 AM:

> how reliabile is this system under opensuse? or is it better to make
> the script produce RPM’s?

Works fine. IMHO making RPMs is only useful when you got more than one machine.

Uwe

acreda1234 adjusted his/her AFDB on Tuesday 14 Jul 2009 09:16 to write:

>
> Hi
>
> Just came back to opensuse from Ubuntu as the 64bit stuff has got a lot
> better and just wanted gather some advice
>
> Ubuntu as opensuse dont really update the ATI driver and as it is still
> playing catch up with nvidia, being stuck on 9.2 is actually regressed
> my current expereice as they are a lot of better releases since then.
>
> on Ubuntu i have been installing the driver via the AMD download .run
> file and using the automatic install option + usual other commands after
> i.e aticonfig to set it up.
>
> how reliabile is this system under opensuse? or is it better to make
> the script produce RPM’s?
>
> cheers
>
>

Personally I stick with just running the script and not creating the rpm.

“My” reason is that as AMD/ATI try to update the drivers every month and you
only need to re-install if there is a kernel update/upgrade which happens
far less frequently ( unless you like playing ) then you will be taking an
unneeded extra step in creating the rpm and then installing that.

Takes approx 3mins here to drop to console init 3, accept agreement, compile
new, rmmod old ( just to be certain )*, modprobe new, init 5.voila Robert`s
your fathers sister in laws husband.

Took longer to post this than to install/re-install/update the drivers :slight_smile:

And notice not one reboot needed, the only time I reboot a machine for a
video driver is if it is the first time the ATIs or Nvidias are being
installed on a fresh system and that is just some old legacy way of thinking
and I still cannot remember why.

Works for me though YMMV.

  • you can throw a “depmod -A” and a ldconfig in there somewhere if you want,
    will not harm.


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

Well things seemed to go well, it also has cleared up an issue when X wouldnt display after the normal GDM command after a restart - probably not the suse fglrx shutting down properly and of course much better compositing graphics, no google earth and other flash movies braking through the desktop!

now to sort out another prob (rss-glx)

thanks for the advice, have to say even under suse, slightly eaiser then the nvidia kernel package.

Mind you, SaX2 didn’t seem to recognized the install and stayed on the VESA driver, still all running fine and fglrxinfo and the catalyst centre was working…