Installing Brackets

So I tried to install the Brackets text editor using an RPM from this page I went into a console and typed

sudo zypper install brackets-1.4-2.2.x86_64.rpm

The output I got was:

Loading repository data...                                                             
Reading installed packages...                                                          
Resolving package dependencies...                                                      

Problem: nothing provides needed by brackets-1.4-2.2.x86_64
 Solution 1: do not install brackets-1.4-2.2.x86_64
 Solution 2: break brackets-1.4-2.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

I decided cancel it.
How can I fix this?

Try this instead: sudo zypper install brackets

I tried that and it outputted:

Loading repository data...
Reading installed packages...
'brackets' not found in package names. Trying capabilities.
No provider of 'brackets' found.
Resolving package dependencies...

Nothing to do.

Your first command was correct to install the downloaded rpm, your issue is no libudev0;

Then use the zypper command for both rpms at the same time;

sudo zypper install brackets-1.4-2.2.x86_64.rpm libudev0-182-5.2.1.x86_64.rpm

Assuming both rpms are in the same location.