Installing ATI graphics on Compaq 6910p

I just installed opensuse 12.3 on a Compaq 6910p. It has ATI Mobility Radeon x2300 in it for graphics. I had to use the No KMS on the setup install screen to get it to install other wise it would just hang. Installed it with the yast2 text installer I think that is what it was. Now when I boot it stops at the [OK] Reached target Graphical Interface just hangs there. I can hit alt-f1 and it brings me to the text login. I would really like to get graphics working but I am a nuebie to linux and need some help. Can anyone give me some advice on what to do here?

First try booting to safe mode. press advanced then the second entry

If that does not work try editing the kernel start up parameters.

press e at boot screen this will bring up a simple text editor.
finf the line starting with linux pres end to go tothe end of that line and add a space then nomodeset,
press f10 to continue with the boot

This should start up with a lesser driver which should allow things to proceed .

Either seemed to help. The line that has linux at the start seems to already have nomodeset in it.

Check out post#26 and #27 on this thread. … the users had different radeon hardware, but it is possible their fix will work for you.

In essence, remove any ‘nomodeset’ boot code, and replace it with " radeon.modeset=1 " . Also you may need to in addition remove any " vga=0x317 " (or similar) line.

Check if any booting efforts with that will work.

Installing drivers for such an older card I dont think will work too well, after all those old drivers are no longer supported.
If you are a gamer eh, you may be better off with the open drivers.
If openSUSE worked without the drivers I would just use the open drivers anyway.

At command prompt text
I tried

su -

mod probe -r radeon

mod probe radeon modeset=1


Then I get into graphics mode. But on root. Want to be on a user not root. Can i switch user in root? When I logout root it goes back to command prompt in text.

Also is there anyway to make this happen at boot?

When I put radeon.modeset=1 in boot screen text editor it hangs.

Don’t use startx use init 5

startx no longer works as you expect and is being phased out

init 5 doesn’t work to get graphic user interface only startx very irritating.

What error do you get with init 5?
Running in terminal as root???

startx usability has been changed because of permission settings

Nothing just goes to the next line. In root.