Installing ATI drivers - Black screen ctrl+alt+f1-f6 no luck

Installed the ATI drivers from the ATI repository last night for an onboard Radeon 3200… but forgot I did so and rebooted this morning and was greeted by a black screen.

Tried both fail safe and a normal boot with the same result, so I tried ctrl+alt and f1-f6 … no luck, same black screen.

Just the screen that seems to be failing since I can reach its NFS shares just fine…
tried alt+f2 and typing
konsole [enter]
su [enter]
password [enter]
init 3 [enter], hoping I’d end up in the console… but that didn’t work either.

So how do I get to a console to execute su -c ‘SaX2 -r -m 0=fglrx’.
Preferably without using the rescue dvd as the computer has no optical drive, can take it from my desktop if needed however.

Boot with

vga=normal 3

mmh I forgot to mention the version again uh…
***** openSUSE 11.1 / KDE 4.1

How would I actually go about changing it? I was expecting to be able to either tab my way to “Boot options :” or or by pressing F8… as I think there should be an option with some F# key allowing you to modify the boot parameters, tried them all… but no luck, only options it offers are:

  • F1 - Help
  • F2 - Language
  • F4 - Keyboard

Both failsafe and normal boot are set to vga=0x345

Pressing escape to bring up the GRUB editor works.

Okay problem solved, didn’t go quite as planned, it just gave up booting the GUI halfway cause it couldn’t load smart… something, smartd?

Anyhow, I ended up in the console and could configure SaX… KDE desktop effects crapped out on me so had to disable them, but Full HD playback is smooth :slight_smile:

Thanks for the help.

You don’t need to “Tab your way” anywhere with openSUSE’s GRUB, you can directly edit the “Boot Options” with your keyboard.