Installing Ardour, says libaudio.so.2()(64bit) not available

while installing Ardour, says libaudio.so.2()(64bit) not available… but,
it IS available in the packman repos as part of libaudio2
and not only that, it is already installed on my machine.
I’ve tried installing every version I could find Ardour 2.8, Ardour 3, Ardour 3.5
all give the same error and won’t install because:
“nothing provides libaudio.so.2()(64bit)”

I badly need to install this program to do some recording work to be ready in the next few days, if anyone could help I would much appreciate it.

I am running Tumbleweed supported with added repos from Packman and the openSUSE Multimedia apps and libs repos for Tumbleweed and factory.

Help needed :’( I will even change distro if I have to in order to get my work done.

ah heres the zypper print:

Retrieving repository 'Packman Repository' metadata ......................[done]
Building repository 'Packman Repository' cache ...........................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libaubio.so.2()(64bit) needed by ardour3-3.5.380-14.12.x86_64
 Solution 1: do not install ardour3-3.5.380-14.12.x86_64
 Solution 2: break ardour3-3.5.380-14.12.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 1
Resolving dependencies...
Resolving package dependencies...

Nothing to do.


Note that it says libaubio.so.2 instead of libaudio.so.2 , this is not correct. There is no such file and certainly not needed by ardour. So, why is it looking for this? It happens with every version I try to install from the repos. not just this 3.5.
Are they packaged wrongly?
how can this be fixed at short notice?

Just a wild suggestion (but I see you are in a hurry, thus, who knows?).

  1. Break … by ignoring …
  2. Install libaudio.so.2 (when it is not installed already)

Then try to run to see if that typo in the PRM is also blocking in the executing phase.

And when that works, please carry on reporting this to the buiilder.

I would have suggested the same, but I did an RPM search now, and there is indeed a libaubio2:
http://software.opensuse.org/package/libaubio2

So try to install this.

And when that works, please carry on reporting this to the buiilder.

libaubio2 was included in openSUSE 13.1, but is not part of 13.2 and Tumbleweed any more (it got replaced by libaubio4).
So apparently the OP tries to install an outdated package, or one not intended for 13.2/Tumbleweed.

Please post your repo list:

zypper lr -d

And where do you actually get that package from, I don’t see it at all in the Packman repo?

zypper in -s ardour

Actually I don’t even find it in multimedia:libs and multimedia:apps either, just in some home: repo where it doesn’t even build any more for some time. That’s probably the reason why it needs libaubio2…

PS: home:giordanoboschetti does have both ardour3 and libaubio2 (see the search above), so add that repo and install ardour3 with YaST/zypper then, or use this 1-click install:
http://software.opensuse.org/download.html?project=home%3Agiordanoboschetti&package=ardour3

Wolfi! you’re great! and giordano boschetti does have the lot…
I did install ardour first by ignoring, but it would not open. I downloaded libaubio2 from giordano’s repo, altered the realtime scheduling on the computer (along with some other limits with help from this pagehttp://linuxmusicians.com/viewtopic.php?f=27&t=2607 ) and, Bob’s Your Uncle, we had blast off! Ardour in action.
thank you, for sending me in the right direction… ehm I can’t add to your reputation, it wants me to give credit to others first :slight_smile: but this is the second time you pulled through for me… thanks again.

BTW the Ardour webpage recommends immediate upgrade on all distros to provide the latest version 3.5.403 as there are some serious security issues with 3.5.378 that compromises a user’s files on disk. How could i tell mr Boschetti about this?

OK that last thing I figured out and am commenting to him on the build service… sorry, but I still am just getting used to how openSUSE works, especially with the community.

Hm?
AFAICS his repo does contain 3.5.403…

But in general you can reach the maintainer of a repo by going to the project page on OBS and click on “Users”.
You have to login to see the email address though (OBS should accept the same username/password as the forum).
Or you can leave a comment there (again, you have to login for that).

Normally there should also be a “Report Bug” link, but that is somehow missing in this case…

To get to the OBS project page, just click on the repo name on the software search result page.
In this case it’s: https://build.opensuse.org/package/show?project=home%3Agiordanoboschetti&package=ardour3

yeah, got it… an oversight… I had to uninstall the version from that outdated repo… giordano’s up to date…
So AFAIAC this issue is completely solved :wink: thank you.