Installing and setting up brand new HP printer for first time and failed!

Yes, printer discovery relies on advertisements made within a given subnet. If the printer is on a different subnet, then manual configuration is necessary.

I always use the manual method from within HP-Setup from Yast and this works for all the other printers but not this one.
I have now had a reply from HP concerning updating the firmware and logging into the machine. With their help we were able to update the firmware using USB connection and now I have been sent the new access password, or rather the way to get it now as it was changed and is now available from the printer itself. Once logged in I was able to check the network settings and these are pretty much as I expected:

IPv4 is set correctly with the static IP.
IPv6 is off.
TCP/IP is enabled
LPR/LPD is enabled
IPP is enabled
Airprint is enabled
WSD is enabled
mDNS is enabled.

When I found the machine
SLP was not enabled
UPnP was not enabled.

Interestingly I have a similar problem with windows 10. I cannot now recall if I had relocated the printer before or after I had set up the first windows machine but trying to set up another machine it failed and for the first machine scanning failed absolutely so it is not just my workstation problem.

All the connections on desktops are wired so I am not troubled by L2 blocking from wifi aps but when I get time I shall check the UTM firewall settings and then go to cli configuration using cups tools for driverless. No time just now but will keep you informed.

I am trying a slightly different approach trying to get hplip v 3.22.10 from the HP site:-


Forgive my incorrect pasting.

Running the script which this download gives me requires half a page of new files to install and this was going well until I ran into


AFAIK this has been superseded when python was upgraded on Leap 15.4.
I have seen a thread on this in an Ubuntu forum which suggests that it is not possible to try and install this because it would break the system but the thread goes on to suggest it doesn’t do anything when installing hplip and to install a dummy. All well beyond my skill set and I am not sure this is correct. I am posting this here but if it would help I can start a new thread. Grateful for advice please.

Why are you pursuing the HPILP installation? I thought you were clear that this printer supports AirPrint and the ULD drivers. I’ll leave you to it - you seem to be all over the place in your threads.

Sorry and yes I have been all over the place. I need some time to concentrate on my planned solution but meanwhile in the office I have been moving computers, printers and amending the configurations of several machines to work in the revised environment. Much of this has been on windows machines and I took the opportunity to try and update my hplip installation in between boots and updates etc. Shouldn’t have troubled everyone with this but perhaps reported in elsewhere because the developers website does report that the installer works with Leap 15.4 and it doesn’t.
That’s all.

For whatever it’s worth, HP’s Color LaserJet M255dw (and I believe its multifunction twin) should be fully supported. I’ve been using the 255dw for the last year without any issues in LM 20.x and 21.x and (briefly) in Leap 15.3.

But you did read the thread? Budgie is using a complete other type MFP179fnw

Yes I read the thread, hui. What is it with you folks anyhow…

There’s more than one way for Budgie to seek relief to this issue. The one, already discussed up-thread, is to be patient and wait (and potentially hope) for HP to add support for the MFP179fnw to HPLIP. The other is to advise other units also produced by HP exist which are known to be supported in HPLIP, and which may be just as good of an option as the 179 model.

Most hardware manufacturers out there have a history of not directly supporting — or being fickle in supporting — GNU+Linux, so it is conceivable any particular model of their hardware, including the 179, might not get HPLIP support. Now, hopefully that won’t be the case, but there’s nothing wrong with being prepared, just in case.

Hi hui,
I am returning to this now to try and finish the task. In spite of having all the uld downloads here and “installed” I am stuck. I believe my problem is my ignorance on how to use the various cli tools which are available for setting up driverless printing and explained in the link you included in post 6 when the printer is on another subnet. I have the IP of the printer and can ping it from here, my home IBM workstation:-

alastair@ibmserv2:~> ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=62 time=0.730 ms
64 bytes from icmp_seq=2 ttl=62 time=0.423 ms
64 bytes from icmp_seq=3 ttl=62 time=0.419 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2044ms
rtt min/avg/max/mdev = 0.419/0.524/0.730/0.145 ms

But nothing I have tried so far gives me the response I want when trying to create an URI etc. using cli.

Using HP-setup falls down even when I have all the info from the uld files. Strange but it did work intermittently with the original firmware but since this was updated nothing.

Should I temporarily put my workstation on to the other subnet and try again or would you have time to help. As I stated I have the uld and have run the but it hasn’t worked yet but all the parts are in my system.

Had to break off from trying this on office workstation. I have therefore returned to my private HP Z640 which now has a reliable network connection thanks to the fix provided on a different thread.

Following on from my musings above I have putt the HP Z640 machine onto the same subnet as the problem printer but still could not get any response from

driverless list

unless I stopped the firewall although I had opened ports 9100, 631 and a few others as well before I started all this!

Once I had the driverless list command working and with the information provided I was able to log into CUPs
and install the printer using the ipp address so, after many failed attempts, I have been able to get the printer working and it is now shown in the Yast>hardware>printer settings.

Once working I started the firewall and could still print.

Sadly however when I switched my network connection back to my to my private subnet there was no printing. I believe this is probably due to the extra L2 switch in the route as L2 does not do routing, only working with MAC addresses and I think the connection is failing and will until I set addressing manually on each device in the route. (The switches in my office network are L2/L3, ie they are not true L3 managed switches but improved L2 so have some routing capability and less troublesome for me.).

So I can report a measure of success but have been disappointed by the problems I have experienced in spite of all the information and tools being shown as enabled in the printer.
Thanks for the help all.

Show us the working device URI (when you had the printer working in the same subnet), and we can go from there.

lpstat -t

Hi Dean,
I am on the HP Z640 with my NIC set for DHCP and with a default route set for the default gateway on the subnet to which I am connected. The port is an access port for that subnet, ie not my private network but the subnet to which the problem HP printer is connected.

I can ping the printer:-

alastair@HP-Z640-1:~> ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.308 ms
64 bytes from icmp_seq=2 ttl=64 time=0.256 ms
64 bytes from icmp_seq=3 ttl=64 time=0.292 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2030ms
rtt min/avg/max/mdev = 0.256/0.285/0.308/0.021 ms

Running lpstat -t first gave me nothing. Similarly:-

alastair@HP-Z640-1:~> driverless list
DEBUG: Started ippfind (PID 3250)
DEBUG: Started post-processing (PID 3251)
DEBUG: PID 3250 (ippfind) stopped with status 1!
DEBUG: PID 3251 (Post-processing) exited with no errors.

I then turned off the system firewall and was able to get the URIs:-

alastair@HP-Z640-1:~> driverless list
DEBUG: Started ippfind (PID 3417)
DEBUG: Started post-processing (PID 3418)
"driverless:ipp://NPIB9BEED.local:631/ipp/print" en "Hewlett-Packard" "Hewlett-Packard HP LaserJet 600 M602, driverless, cups-filters 1.25.0" "MFG:Hewlett-Packard;MDL:HP LaserJet 600 M602;CMD:PDF,PCLM,PS,PCL,AppleRaster,URF,JPEG;"
"driverless:ipp://HPC46516775738.local:631/ipp/print" en "HP" "HP OfficeJet 3830 series, driverless, cups-filters 1.25.0" "MFG:HP;MDL:OfficeJet 3830 series;CMD:PCLM,PCL,PWGRaster,AppleRaster,JPEG,URF,PWG;"
"driverless:ipp://HPC018039F6646.local:631/ipp/print" en "HP" "HP Color Laser MFP 179fnw, driverless, cups-filters 1.25.0" "MFG:HP;MDL:HP Color Laser MFP 179fnw;CMD:PCLM,AppleRaster,JPEG,URF;"
DEBUG: PID 3417 (ippfind) exited with no errors.
DEBUG: PID 3418 (Post-processing) exited with no errors.

I then started the firewall but I can then still get the URI info and usie it to creat the printer connection which enables me to print. Here is the result of your command even with firewall enabled:-

alastair@HP-Z640-1:~> sudo lpstat -t
[sudo] password for root: 
scheduler is running
system default destination: HP_LaserJet_600_M602
device for CUPS-PDF: cups-pdf:/
device for HP_Color_Laser_MFP: ipp://HPC018039F6646.local:631/ipp/print
device for HP_LaserJet_600_M602: hp:/net/HP_LaserJet_600_M602?ip=
CUPS-PDF accepting requests since Wed 22 Feb 2023 21:35:42 GMT
HP_Color_Laser_MFP accepting requests since Fri 03 Mar 2023 17:51:54 GMT
HP_LaserJet_600_M602 accepting requests since Wed 22 Feb 2023 20:55:16 GMT
printer CUPS-PDF is idle.  enabled since Wed 22 Feb 2023 21:35:42 GMT
printer HP_Color_Laser_MFP is idle.  enabled since Fri 03 Mar 2023 17:51:54 GMT
printer HP_LaserJet_600_M602 is idle.  enabled since Wed 22 Feb 2023 20:55:16 GMT

The ports I have opened are 9100, 631 and 80 on both UDP and TCP but it seems the discovery process must use another port.

To get the printer to work I used the CUPS local web interface and used the ipp data from the discovery process. Here is the connection detail:-

Connection:	ipp://HPC018039F6646.local:631/ipp/print

and the ppd from the uld download which is saved at:-


This is the limit of what I have achieved so far.

Ok, all I requested was the lpstat output. Anyway, the URI is of the form


As you can see, it is using the Avahi hostname ‘HPC018039F6646.local’. This won’t resolve outside of the local subnet. You can change that to the actual IP address, and then the printer should be reacheable.

Hi Dean,
That has fixed it even going through all the switches and having reverted to my private subnet. Brilliant and many many thanks.

BTW the actual printer is dreadful; cheap, flimsy, impossible to set up and one toner cartridge ran out before any work printing, other than these the testing prints, had been completed. I even have had serious time wasted with all the office windows machines. My mistake was buying from HP website which had a very poor selection. I now find there are many better HP machines still available but at least it is now working.

The colour laserjet I had to throw because the cost of the toner and imaging drum now totalled much more than a new printer, I have had from new, bought in 1998. It did all I needed from then when I had been using OS/2! That’s progress for you.

Good. As expected. :wink:

I hesitate to ask further of you but my workstation here does print but uses a different connection, I believe because I had opted for TCP/IP connection and this is working. Here is the connection taken from Yast:-

socket://    HP HP Color Laser MFP 178 179

For my workstation I need to be able to scan. Using Leap 15.4 I have always used Skanlite but now the printer is on a different subnet SANE cannot find the scanner even with no firewall running. I am still reading and will ask again when I get stuck.

You will need to add the IP address to the appropriate SANE config file. If you’re not sure which driver (scanner backend) is used, you can test with the scanner in the same subnet (as you did with the printer).

scanimage -L

Once you have the scanner enumerated, it should be possible to advise further.

Hi Dean,
Working on laptop with wifi connection to required ssid I have:-

alastair@IBMW530:~> scanimage -L
device `smfp:net;' is a HP HP Color Laser MFP 178 179 on Scanner
device `hpaio:/net/HP_Color_LaserJet_2840?ip=' is a Hewlett-Packard HP_Color_LaserJet_2840 all-in-one

I think this is what I needed but…

Please ignore the hpaio line which should now be deleted from my system.

Do you have a configuration file (/etc/sane.d/smfp.conf) present?

I’m not certain about your particular Samsung model, but I suspect it is using the ‘xerox_mfp’ backend (which is known to support a number of Samsung models). For example, this Ubuntu thread:
networking - How to setup Samsung M2070FW network scanner - Ask Ubuntu.

Try editing /etc/sane.d/xerox_mfp.conf and add the following entry to the end of the file


See how that goes.