Installing and setting up brand new HP printer for first time and failed!

Could you try adding the devel repository and installing the package from there? The actual version in Printing/hplip is 3.22.10.

According the hplip site this printer is not supported yet (or you gave us a wrong printer type):

This printer is nowhere to find on the hplip site, not even in the release notes which lists (all) printers which were added in the new releases…

Hi hui and thanks for the info. So much for retiring my HP LJ 2840 which, sadly, is on its way to recycling depot as I type.

How long will it be before the support is added and is there anything I can do until then? I was able to download what HP stated are linux drivers from their website but there were no installation notes or other details. The download directory was named “uld” and the contents are as follows:-

alastair@ibmserv2:~/Downloads/uld> ls -l
total 24
drwxr-xr-x 1 alastair users 174 Jun 16  2020 aarch64
drwxr-xr-x 1 alastair users 174 Jun 18  2020 i386
-rwxr-xr-x 1 alastair users 446 Jun 18  2020
-rwxr-xr-x 1 alastair users 446 Jun 18  2020
-rwxr-xr-x 1 alastair users 848 Jun 18  2020
drwxr-xr-x 1 alastair users 174 Jun 18  2020 mips64
drwxr-xr-x 1 alastair users 904 Jun 11  2020 noarch
-rwxr-xr-x 1 alastair users 328 Jun 18  2020
-rwxr-xr-x 1 alastair users 328 Jun 18  2020
-rwxr-xr-x 1 alastair users 383 Jun 18  2020
drwxr-xr-x 1 alastair users 174 Jun 16  2020 x86_64

alastair@ibmserv2:~/Downloads/uld/x86_64> ls -l
total 6300
-rwxr-xr-x 1 alastair users   36808 Jun 16  2020 gettext
-rwxr-xr-x 1 alastair users 2180256 Jun 16  2020
-rwxr-xr-x 1 alastair users 2841035 Jun 16  2020
-rwxr-xr-x 1 alastair users   58200 Jun 16  2020 pstosecps
-rwxr-xr-x 1 alastair users  105192 Jun 16  2020 rastertospl
-rwxr-xr-x 1 alastair users 1204656 Jun 16  2020 smfpnetdiscovery
-rwxr-xr-x 1 alastair users   10480 Jun 16  2020 usbresetter

Are these the files that are needed?

When you follow the installation guide, you will execute the run file in a terminal/console. That means it is easy to mark the terminal/console output → right-click → copy. Then you are able to paste it here.

Installation guide:

But if your printer is not supportet yet by the linux hplip, the chances are small even if you rerun the installer. The timeframe is unknown (for me) when this new printer will be supported by hplip.

Hi and thanks for the message. I think my problem was running the shell by clicking on it rather than running it from cli.

Will go back and try again but meanwhile I have been advised that my new printer has not yet been included in HPLIP but is driverless so how do I install a driverless printer please?

A good explanation

Many thanks, Getting there slowly but spoilt for choice here on what way to go with installation. Will return when I have digested the explanation.

Samsung Printer?
because of the uld driver?

Hi Sauerland, many thanks for the link. I tried to edit it for English but as soon as I tried it took me to the support site.
I think, however, that was where I found the uld download but didn’t mean much to me as there was no readme documentation or help with installation.

Not sure why you mention Samsung. No Samsung printers here.

I have made some progress with the driverless installation but clearly I am not a coder and cannot get any connection to work although my new printer is found. I am hoping for a step by step guide. There are so many ways of making this work but so far I have failed.

HP does the support for Samsung…

Inside the unpacked uld there are some Scripts for Installation…


In principle, zypper installs all necessary software. try
zypper in hplip

Once done, to install your network printer, in a console, do

hp-setup address of your printer (ex: hp-setup

Your printer will appear in Yast and in hplip.

While you’re at it, install the plugin to scan with

and ‘d’ to download it.

Everything is ready in principle

My fault:

Hi Sauerland many thanks and this is what I have already downloaded. My problem is what to do with it.
If I use driverless command and try and follow the guidance given above I fail. Tried several methods but still no joy.
Will keep trying.

Many thanks. Sadly this printer is not yet selectable from hplip.

Unpack the driver, goto the uld directory and execute the Script, or the or the

Try zypper updates every day :slight_smile:

zypper up -y

Hplip is regularly updated. The generic driver and/or the dedicated driver will necessarily be in the next packages.

Unfortunately, the only solution is patience, which will be rewarded.
The hp commands shown are powerful.
Good luck.

@ straight_ahead

I do not find the driver for the mentioned Printer in hplip, only:

- HP Color LaserJet Pro MFP M179fw
- HP Color LaserJet Pro MFP M179cfw

Hi and many thanks. I ran it correctly and more confidently having received your advice and both print driver and scan driver have been installed, so there is a start.
Not sure if now I should try Yast again. Will try and report back.

I just saw on the HP site that your printer is supported for linux suse with the drivers for the HP Color MFP 170 but in the basic version.

Look on this page, it’s the link indicated by @Sauerland :

Remember to install xsane to scan directly with this software

zypper in -y xsane