installing anaconda

Just wondering if this bug was ever fixed : It’s been awhile but before I create a problem for myself I’d like a heads-up.


I was not aware of that thread…
Reviewing it…

I would not recommend installing as root (which places the anaconda file tree in a subdirectory of /root/),
I’ve only ever seen documentation to install as your normal User which results in a subdirectory of your currently logged in /home directory, likely avoiding everything that User had problems with… thereby making your install simple and likely problem free. If your Anaconda app requires elevated permissions, it will likely mean you will have to “sudo” and can’t “su” to ensure your ordinary User PATH points to /home/*

And, of course it should be noted that the system $PATH will be prepended with the path to your Anaconda directory of course, thereby taking precedence over Qt and python installed from openSUSE repos.

If you do what I describe you should more or less avoid practically everything mentioned in that Forum thread except the Qt issues which weren’t described very well so which would remain uncertain.

If you did decide to do what the User did in that Forum thread,
Then I highly disagree with what they did which was to modify the environmental variables in bashrc which only configures for a specific User… They should have instead placed their “export…” commands in a /etc/profile.local file or in a script file placed in the /etc/profile.d/ directory,… both which then apply the modified variables to all Users on the system (ie both root and current non-root User plu any other Users).

That’s the bottom line…
Can’t know if there are any current problems but the Forum thread you referenced has a lot to be improved upon.

IMO and HTH,


Thanks for the reply. I'm going to give it a try this weekend when I have time. There's not really a lot of info anywhere about this issue. Most posts I've found elsewhere seem short and cut off in the middle of the resolve so I'll post back here with a success or failure so people have something a bit more up-to-date to go by.

Thanks again,

I highly recommend to NOT install anaconda as root. I’m not saying this wouldn’t work, but one has to really-really understand the consequences and required counter-measures in advance to do that.
A few months ago I’ve installed anaconda on my Tumbleweed machine as a regular user and everything went well enough (at least, the problem I was trying to solve with this was solved)

It would make a good general advice as well: using things in the undocumented way is possible, but requires deep knowledge of internal machinery; so, unless you really know what you are trying to achieve, stick to the docs :wink:

I’m a programmer so using things in an undocumented way is the normal for me, which is why I keep a bottle of Aspirin and pot of coffee next to my computer.

Installing Anaconda didn’t go well, no login problems but it keep crashing so I tried installing Spyder3 from YaST which turned out crashing as well with a file not found error: “/usr/lib/python3.7/site-packages/spyder/local” not found. This was solved with just uninstalling and reinstalling via pip. No problems now. After 20 plus years with Linux and Programming I’m use to issues, so worries!

I’ve just recently (a month ago) gave in and started learning Python because of the big AI and Machine Learning boom. Between Eric6 and Spyder3 I should be good to get started. I’ve got hard year ahead of me but at least, maybe, I can keep you Kids from putting me out of a job.


If you’ve set up a working environment you’re happy with, congrats.

When you install Anaconda, you install a complete alternative environment, so apps from openSUSE can be expected to break if they have hard references to libraries installed by openSUSE, and in this case appears to be a subdirectory of a python library. When ?Anaconda is installed, you have to run apps that are within the anaconda file tree.

If you’re returning to apps from the openSUSE repos, you should remove Anaconda.
Minimally, simply removing the Anaconda file tree should be sufficient but you may want to do a proper job by also removing the Anaconda PATH entry.

Since your’e developing, I’d also recommend adding the special Python repo instead of relying only on default OSS packages.