installing an rpm with 11.4

I probably missed something as I come from 11.2 but I downloaded a few rpm (like opera and crossover).

upon installing I right click, select install/remove software and up comes KpackageKit telling me its going to install the rpm. Fine I think, then a new window opens showing me the progress and I see it’s installing loads of items I previously removed. For example I have de nvidia repo but I did the drivers the hard way, KpackageKit now installs the repo drivers again. I removed pulseaudio and nouveau but KpackageKit installs them again while it install the opera or crossover RPM. None of these packages are dependencies for the 2 RPM I want to install and I can easly remove them via yast.

the only way I can seem to be able to install these 2 RPM’s without getting all the stuff back I removed earlier is either manually from the command line or I make a repository of a local directory and use yast that way ?

So am I missing something here or ?

Thanks :slight_smile:

Yeah, It’s the best way to do it. Making a repository in a directory is a good practice.
This way you can keep your rpm in an organize way. I usually put a taboo on those rpms that yast wants to delete or install if there isn’t a dependency problem against the rpm I want to install from the directory.

You are ok. And as conram said yeahh it is the best way because your rpm packets are organized.

installing an rpm with 11.4

Installing rpm software has not differents in 11.4, it is faster, but the way who you install a rpm is the same in all opensuse versions.

thanks for your answers, so its normal for KpackageKit to reinstall stuff I removed before ? that sort of the odd part, under 11.2 this did not happen.

On 03/12/2011 06:06 PM, Xilanaz wrote:
>
> thanks for your answers, so its normal for KpackageKit to reinstall
> stuff I removed before ? that sort of the odd part, under 11.2 this did
> not happen.

wait…how does KpackageKit get involved?

if i download an RPM to install, i right click it and pick “Open with
Install/Remove Software” and YaST springs to life…and does NOT try
to install stuff i have previously removed…

so, are the others saying that YaST is not available in 11.4 if you
right click an RPM? (it sure is in 11.3!!)

or, are they doing some kind of Windows magic and double left clicking
the rpm–do NOT do that!!! well, i just left clicked an RPM and STILL
it launches YaST and not KpackageKit…hmmmm, i don’t seem to have a
kpackagekit…

is it new in 11.4? if it is, and it is routinely reinstalling stuff
the user has uninstalled, then: log a bug!!
http://en.opensuse.org/Submitting_Bug_Reports


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

DenverD, as I wrote in the first post:

“upon installing I right click, select install/remove software and up comes KpackageKit telling me its going to install the rpm.”

so because you mentioned it I tried a double click but gives the same result, so hence my question “am I missing something” because as you said yast used to do it.

So if someone can confirm this I gladly log a bug, right now it might just be me ?

Try to install a rpm

su
# zypper install <rpm software>

Yes. The updater applet has been also substituted… It was the only logic step.

Here it works just fine.

On 03/12/2011 08:06 PM, RedDwarf wrote:
>
> Yes. The updater applet has been also substituted… It was the only
> logic step.

but, if it does not work correctly, it becomes illogical…right?


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

That is a feature, not a bug; once you have activated the NVidia-Repo, YaST will automatically choose the right packages for your gfx-card. However, that is bad when you have the driver installed from the .run-file already, so either unintstall that one or simply deactivate the NVidia-Repo.

okay, I can sort of understand that but since I removed pulseaudio I can’t really disable the main repo can I.

anyways, I did a quick clean install in a VB and can reproduce it, the checkboxes in the repository list have to be all enabled and autorefresh turned on.

so will make a bug report.

I wonder if this could possibly be related to one of the patterns you have installed. The removal of pulseaudio may be interpreted as missing dependencies.

Just a thought

I get different behaviour again, and also different from 11.2, also unusable.
I find a .rpm I want, on say download.opensuse.org and click to download it. I am asked if I want to install it, and with with what, kpackagekit is the only option:
http://i127.photobucket.com/albums/p145/wakou/partition/rpm1.png

It downloads, I am asked again:

http://i127.photobucket.com/albums/p145/wakou/partition/rpm2.png
I say yes, and kpackagekit gives me this:

http://i127.photobucket.com/albums/p145/wakou/partition/rpm.png

expanding the ‘more details’ only gives this:

http://i127.photobucket.com/albums/p145/wakou/partition/rpm3.png

Someone said I needed the PK_TMP_DIR ‘repository’ others say to delete it. It does not work either way!

Has no-one else seen this? It is a real PITA, means I can’t install anything not in my repos.

Have you tried using zypper from the command line to install? If so, does it give the same warning?

On 03/30/2011 03:06 AM, wakou wrote:
>
> Has no-one else seen this? It is a real PITA, means I can’t install
> anything not in my repos.

as a work around, try this:

  1. instead of selecting install in this step:
    http://i127.photobucket.com/albums/p145/wakou/partition/rpm1.png
    select “Save File” and let it save to your home’s Download directory

  2. when finished, go to the Download directory, find the gparted rmp,
    and right click it

  3. i think you will be offered “Open with Install/Remove Software”,
    select it…

i think it will install from your Download directory…let us know…

if it does then i guess there is a permissions problem with your
/tmp directory, i think a terminal command like




should result in something kinda like:

drwxrwxrwt 12 root root 4.0K 2011-03-30 09:31 tmp/

let us know how you get on…


CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

On 03/30/2011 09:50 AM, DenverD wrote:
>


>
> 

should result in something kinda like:

drwxrwxrwt 12 root root 4.0K 2011-03-30 09:31 tmp/

oh no! that command won’t work, try these, in order:


cd /
ls -hal | grep tmp

(there are two Ls and no Ones in that command…)


CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

Thankyou Wrath and Denver. I eventually installed that particular .rpm with zypper, pointing it at the downloaded .rpm on my local system, IIRC right-clicking it in Dolphin gave the same results as when I tried to install from a remote (web) .rpm. I will have a tinker with DD’s commands and report back anon. Ta again :slight_smile:

Glad it worked for you, Wakou.