Installing an nvidia driver - easiest I have found to date.

Before doing this there are a couple of things to do. Removal of the nouveau driver is probably not needed but I did. Also only tried on 11.4

Check that the repository is still there by pasting the following into your browser

This should show a number of directories 11.4, 11.3 etc. Using yasts repositories facility select new, url and past in the link and add the version eg

If it isn’t there any more tough. Nvidia for instance mention an http one in their docs but it seems to be empty.

In yast software management search xorg and find the nouveau driver and mark it for un install (X just click the box till X comes up) after checking that the standard nvidia drivers are on the system. Hit accept and when finished reboot. Xorg should fall back onto the nv driver.

Run YAST again and select on line update. It should offer you a host of nvidia stuff. Accept it and reboot. Using the console log in as su and enter /etc/bin/nvidia-xconfig. This will generate an xorg.conf file /etc/X11/xorg.conf. This should be the end with modern monitors. Mine needs more though and modern ones may need tweaking at times.

xorg.conf can be edited with kedit complete with colour syntax highlighting. To do this open dolphin in su mode and navigate to /etc/X11. Just click root to see etc. Click xorg.conf to start up kedit. I then save a copy of what ever I’m working on. In this case use “save as” NVxorg.conf. Then edit the xorg.conf as needed but remember to use “save as” xorg.conf. When doing this sort of thing again and again things can be restored easily from the prompt if it goes wrong. Navigate to the directory and use copy ie cp filename xorg.conf. Kedit adds a ~ to the end of the file name each time it’s changed. If you enter ls the file names can be seen.

As sample xorg.conf files seem to be thin on the ground here’s mine.

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 260.19.44 ( Sun Feb 27 22:59:57 PST 2011

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”

Section “Files”

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"


Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"


Section “Monitor”
Identifier “Monitor0”
VendorName “Belinea”
ModelName “2225 S1W”
HorizSync 31.0 - 81.0
VertRefresh 56.0 - 60.0
Modeline “1680x1050_60.00” 146.25 1680 1784 1960 2240 1050 …
Modeline “1152x864_60.00” 81.75 1152 1216 1336 1520 864 867…
Modeline “1024x766_60.00” 63.25 1024 1072 1176 1328 76…
Option “DPMS” “FALSE”
Option “DPI” “100 x 100”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “useEDIDFreqs” “FALSE”
Option “useEDIDDpi” “FALSE”
Option “ModeValidation” “NoEdidModes”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
Modes “1680x1050_60.00” “1280x1024” “1152x864_60.00” “1024x766_60.00” “800x600”
Option “DPMS” “FALSE”

Thanks for the help from Deano. The sections that may need changing are monitor and screen. I have added the options with EDID in them. This frees up resolutions. I have added horizontal sync frequencies and vertical refresh rates from my monitor manual. My monitor will refresh faster than that but why help wear it out. I’m happy with 60Hz. The horiz is in Khz and the vert in Hz. I have truncated the modelines so that they will fit on this forum.

If in doubt the best option is to forget edid for a while and leave as is. Then add all of the resolutions that your monitor supports as in Modes under the screen section but do adjust the sync and refresh rates if you can. The modes must start with the highest then reducing through the range. They might be “1240xwhatever” etc forget the ones I have with _60. The horizontal resolutions must divide precisely by 8. Then reboot. You may even get the highest res you want, seems unlikely with many wide screen monitors. Next use kedit to scroll through /var/log/xorg.0.log. No need for su here. Some where along it you will see notes that x is rejecting certain resolutions. Make a note of which ones. On the other hand there may be none in which case you have them. Open up xorg.conf again in kedit using dolphin in su mode. Open up a console and enter starting with the highest resolution that isn’t working

cvt “horizontal resolution” “vertical resolution” “refresh rate”

This will generate a line beginning modeline highlight the lot with the cursor and copy/paste into xorg.conf where I have. Repeat for each resolution.As many as you like. Add the EDIC options and correct the modes as needed by adding the _xx.xx as I have done. Save and reboot and you should have the lot. Check the xorg.0.log file again just to make sure. I add 2 DMPS FALSE statements following a tip from elsewhere. As systems sometimes get upset by tabs I always format with spaces. I have also added the DPI “100 x 100” option. From comments on other sites this seems to offer the chance of adjusting text size. There may also be a scale option.

If things go wrong use cp to get back to where you were from the prompt. If this doesn’t work out re install. When it gets to partitions choose import and make sure it doesn’t want to format your home disc or partition. If it does which is doubtful change it. It’s possible to change from 64 to 32 or the other way round this way but mail will be lost. Tar etc the entire mail directories and expand and use import to get them back. For some reason accounts can’t be imported. It could do that at least in part.

Perhaps some would like to add anything they think I have missed. This sort of thing may help newbies gain the courage to have a go. As to me well I don’t wish to work in the shell.

One remaining problem. The nvidia settings utility under launch,system,configuration will not fire up. I suspect this may be down to it using an X windows display. Not sure. While KDE for some reason haven’t included properties on these via a right click they can be found and edited in /usr/share/applications/nvidia.settings.desktop. Can anyone provide me with the correct incantations.

One oddity :wink: KDE screen res reckons my monitor is running with a 50Hz refresh rate. My monitor and X reckon it’s 60Hz. It would also bring up invalid mode at 50Hz but still work. Can’t help wondering where it gets this from. Clearly from the wrong place.


There is one thing I should have added to this. Do keep a copy of system files such as this one some where. I don’t think it will happen in this case but sometimes an update will change system files and not take any notice of what you have added.

Also on re installing I generally copy what I must keep onto a usb drive just in case. Not always as I have found suse good in this respect. The mail files may need to be compressed including all sub folder before copying to a usb disc. This may be down to a flaw in my last installation or it may be a general thing I do not know. It also pays to ensure that the copy to the disc has actually completed as from time to time many disto’s have been a bit weak in this area.

I have also just found out that having the dreaded nv and nouveau open source drivers about isn’t a problem. That’s hardly surprising really as what matters is what is in the xorg.conf file. The install takes care of low level software changes. :expressionless: Who knows though this may change in the future. I also haven’t tried installing while the nouveau driver was active but this should not matter a jot.


Havind just updated to the latest kernel I found myself without the nouveau driver but with something called fbdev and stuck in 800x600 on the desktop.

I used the same procedure as above and things worked a little easier this time. I entered as an additional repo with url checked. This time yast loaded it as one of it’s usual repositories. I then did an update with view packages and accepted all as before. This has installed everything perfectly and I just had to copy my xorg.conf file back to /ect/x11. I keep a copy of things like that in a spare partition on my system disc and also off the machine completely.

I also checked the repo with a browser 1st so expected things to be a little different.

rotfl!Moral If the technology is there why not use it.

One thing more to add. Following the nvidia driver install reboot immediately. This may be why the nvidia settings utility didn’t run the 1st time I did it this way. I checked that it existed in the launch menu and also attempted to start it. Bit pointless as the driver for the card wont be used until X is rebooted. I can’t think of any reason for this change other than that the files in the repo have been changed.