Installing amdgpu-pro on Leap 42.3 - Radeon HD7850

Hi Guys,

For a while now I’ve been struggling with the amdgpu-pro driver. Since I upgraded to 42.3, I’m unable to get it to build. Previously i was on 42.1 and still using fglrx.

Right now when I try to install the driver I get this:
uilding initial module for 4.4.76-1-default
Error! Bad return status for module build on kernel: 4.4.76-1-default (x86_64)
Consult /var/lib/dkms/amdgpu-pro/17.30-465504/build/make.log for more information.
warning: %post(amdgpu-pro-dkms-0:17.30-465504.noarch) scriptlet failed, exit status 10

Then in the log, I found this:

/usr/src/linux-4.4.76-1/scripts/ recipe for target ‘/var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdgpu/amdgpu_drv.o’ failed
make[4]: *** [/var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdgpu/amdgpu_drv.o] Error 1
/usr/src/linux-4.4.76-1/scripts/ recipe for target ‘/var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdgpu’ failed
make[3]: *** [/var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdgpu] Error 2
make[3]: *** Waiting for unfinished jobs…
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm/ttm_bo_vm.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkcl/kcl_drm_global.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkcl/kcl_bitmap.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkcl/kcl_pci.o
/var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm/ttm_bo_vm.c: In function ‘ttm_bo_vm_fault’:
/var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm/ttm_bo_vm.c:271:6: error: incompatible type for argument 3 of ‘vm_insert_mixed’
In file included from /usr/src/linux-4.4.76-1/include/drm/drm_vma_manager.h:28:0,
from /var/lib/dkms/amdgpu-pro/17.30-465504/build/include/drm/ttm/ttm_bo_api.h:35,
from /var/lib/dkms/amdgpu-pro/17.30-465504/build/include/drm/ttm/ttm_bo_driver.h:33,
from /var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm/ttm_bo_vm.c:35:
/usr/src/linux-4.4.76-1/include/linux/mm.h:2170:5: note: expected ‘pfn_t’ but argument is of type ‘long unsigned int’
int vm_insert_mixed(struct vm_area_struct *vma, unsigned long addr,
/usr/src/linux-4.4.76-1/scripts/ recipe for target ‘/var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm/ttm_bo_vm.o’ failed
make[4]: *** [/var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm/ttm_bo_vm.o] Error 1
make[4]: *** Waiting for unfinished jobs…
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_pasid.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_doorbell.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_flat_memory.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_process.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_queue.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_mqd_manager.o
LD [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkcl/amdkcl.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_mqd_manager_cik.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_mqd_manager_vi.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_mqd_manager_v9.o
/usr/src/linux-4.4.76-1/scripts/ recipe for target ‘/var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm’ failed
make[3]: *** [/var/lib/dkms/amdgpu-pro/17.30-465504/build/ttm] Error 2
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_kernel_queue.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_kernel_queue_cik.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_kernel_queue_vi.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_kernel_queue_v9.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_packet_manager.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_process_queue_manager.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_device_queue_manager.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_device_queue_manager_cik.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_device_queue_manager_vi.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_device_queue_manager_v9.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_interrupt.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_events.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/cik_event_interrupt.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_int_process_v9.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_dbgdev.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_dbgmgr.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_crat.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_rdma.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_peerdirect.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_ipc.o
CC [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/kfd_debugfs.o
LD [M] /var/lib/dkms/amdgpu-pro/17.30-465504/build/amd/amdkfd/amdkfd.o
/usr/src/linux-4.4.76-1/Makefile:1428: recipe for target ‘module/var/lib/dkms/amdgpu-pro/17.30-465504/build’ failed
make[2]: *** [module/var/lib/dkms/amdgpu-pro/17.30-465504/build] Error 2
Makefile:150: recipe for target ‘sub-make’ failed
make[1]: *** [sub-make] Error 2
Makefile:24: recipe for target ‘__sub-make’ failed
make: *** [__sub-make] Error 2
make: Leaving directory ‘/usr/src/linux-4.4.76-1-obj/x86_64/default’
linux-yi6l:/home/thor/Downloads/amdgpu-pro-17.30-465504 #

Anyone ever seen this before? Or at least, any ideas as to what I may try? I couldn’t find much related to this. This was happening with the 17.10 version as well, so it is not something with this particular one.

Any help would be greatly asppreciated, as digging thgouth the code is a dawnting task, seeing how my C skills are not that great.

Thanks in advance,

That’s a Southern Islands card Pitcairn?

/sbin/lspci -nnk |grep -A3 VGA

Unfortunately there is no support for this card (GCN 1.0) in this kernel, Xorg etc.

You will get it with later kernels but only the amdgpu driver, not the proprietary driver AFAIK.

From what I see on AMD’s download page, it lists AMD Radeon™ HD7700/7800/8500/8600 as still supported under the 17.30 amdgpu-pro version.

I don’t dissagree that it may be time for an upgrade, but for the time being, that won’t happen, so I’ll need to get this one working. Since their site claims it is supported I’m not sure why it would fail to compile :-?

Can you provide the output from the lspci command to confirm the engineering name?

Is the system all up to date since your error shows the old kernel 4.4.76, current 4.4.79.

The other option is to look around the AMD forum as there may be a kernel patch required.

I’ve just looked through the AMD forums. There is mention of a patch, however, upon opening it I found it just adds an additional line for OS identification, but is unrelated to the build failure I’m getting. I will try it however, just to continue troubleshooting with clean slate. In the meantime:

lspci -nnk |grep -A3 VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP] [1002:6819]
Subsystem: PC Partner Limited / Sapphire Technology Radeon HD 7850 2GB GDDR5 DVI-I/DVI-D/HDMI/DP [174b:e221]
Kernel driver in use: radeon
Kernel modules: radeon

I haven’t done any updates yet, this is a fresh install. You’ve got a good point there though, I’ll update and then post the results.


Well I think you may be out of luck with SI support in this kernel without patching and even then it may not work. I suggest you ask on the AMD forum and see what they indicate.

Did you ever resolve the build failure?

I’m afraid not. I never got the chance to get back on it as it was a busy month. Am looking at it again in the following days, I hope at least. But it doesn’t look promising. I’m tempted to try CentOS or Ubuntu just to see what happens.

As an update, I have tried with the latest updates applied. Same result though. Still fails to build the same way. I’m thinking there may be a way to make it work, but one may have to dig deep in the code. Takes time and patience…