Installing Adobe SVG Viewer in Firefox (Bilingual [EN-HU])

<<Magyar leírás az fórum végén.>>
Caused me a lot of pain, to solve the Adobe SVG and Firefox dilemma, and to solve this confliction, I decided to share this solution here. Allow me as well, to do it in Hungarian as well, so this way, I give support to the Hungarian SUSE users.

  • First, you need to download the Adobe SVG Viewer from Adobe site. (Many sites says that the 6th version is needed but for Windows! Not linux.)
  • As root, unpack all the files – except the shell scripts – in one of the following directories:
    /usr/lib/browser-plugins (This directory searched by Opera and Konqueror as well, for sure.)
    /usr/lib/mozilla
    /usr/lib/firefox
  • Make all the *.so file executable.
    Almost done! (For Opera it is done already!) The interesting part is, that the viewer want us to see the licence agreement for the first run, and for some interesting reason, it is not shown until it isnt started from an object tag. (Who knows why…) Also it is not opened with Adobe SVG if you want to open svg directly.
  • So next step, look for an SVG sample in Firefox, that is embeded with the object tag, like the W3C SVG examples, or my favorite pong animation. This will make the licence agreement pop up (may be behind Firefox) and accept it. Don’t close the page just in case. You’re Done!
  • For Konqueror you will need to go in Settings->Configure Konqueror->Plugins switch to Scan tab click on Scan new plugins.
  • Just in case, in the configuration window, select File Associations go to image and check all svg types on the Embedding tab if they have been associated with Netscape plugin viewer (nsplugin) and set it to the first place.

You have now done for the main browsers!
Have fun!
Ádám Juhász

Ps.: If it still not works, try to disable the built-in svg-plugin, by rename /usr/lib/browser-plugins/libmozsvgdec.so. Thats all difference I have.

<<End of English description>>
<<Magyar leírás>>
Rengeteg kín szenvedéssek árán, de sikerült megoldanom a Firefox és az Adobe SVG konfliktust. Mivel ilyen kényelmetlen volt ezt megoldani, ezért úgy döntöttem, hogy megosztom itt is.

  • Első lépésként töltsed le az Adobe SVG Viewer-t az Adobe honlapjáról. (Néhány helyen írják, hogy a 6-os verziót töltsed le, de Windows-hoz, és nem Linuxhoz.)
  • root felhasználóként csomagold ki az összes fájlt – a szkriptek kivételével – a következő mappák eggyikébe:
    /usr/lib/browser-plugins (Biztosan látni fogja az Opera és a Konqueror is.)
    /usr/lib/mozilla
    /usr/lib/firefox
  • Az összes *.so fájl attribútumát állítsad futtathatóra.
    Már szinte kész is! (Opera felhasználók már be is fejezhetik!) Az érdekes az az, hogy az Adobe SVG első használatkor meg akarja mutatni a licenszet, és valami különös ok folytán nem akar megjelenni, amíg a program nem egy object elem segítségével jelenik meg. (Ki tudja miért…) Ha direkt az svg fájlt akarjuk megnyitni, akkor nem az Adobe SVG megjeleníti meg.
  • Ezért a következő lépés az, hogy egy object elemmel beágyazott SVG fájlt keresünk Firefox-szal, amit megtalálunk a W3C SVG példa oldalán, vagy az én oldalamon található kedvenc pong animációmban. Ez megjeleníti a licenszet, (ami lehet, hogy az ablak mögött jelenik meg,) és fogadjuk el. Ezzel kész is!
  • Konqueror-ban még szükség van arra, hogy a Beállítások->Beállítás: Konqueror->Bővítőmodulok részben, a Keresés fülben, az Új bővítmények keresésére kattintsunk.
  • A biztonság kedvéért, a beállítás ablakban menjünk át a Fájltársítások részbe, és az image alcsoportban az összes svg típusnak a beágyazás fülén bizonyosodjunk meg arról, hogy a Kezelőprogram Netscape bővítményekhez (nsplugin) hozzá van rendelve, és az első helyen áll.

Most már kész is vagy a böngészőkkel!
Kellemes időtöltést!
Juhász Ádám

Ui.: Ha még mindig nem működik, akkor tiltsad le az alapértelmezett svg megjelenítőt, azáltal, hogy az /usr/lib/browser-plugin/libmozsvgdec.so fájlt átnevezed. Ezzel a lépéssel különbözik az én beállításaim.