Installing a hp all-in-one - hplip or an other way?

This is not (only) a request for help but I think concerning to printer installation I am in the most appropriate sub forum.


what is the best/easiest way to install a all-in-one device from [/size]Hewlett Packard (hp)[size=2]?

Is there a way/makes it sence
to set it up via Yast?

I do not know why this wiki

How to set-up a HP printer - openSUSE

shout be [/size]“obsolete” (at least not for all-in-one printers)**.
And for “only” printers: Is there an other way including bidirectional communication (ink etc.?).

I don’t know the best way.

Here is where I posted my experience: openSUSE Forums - View Single Post - HP WLAN capable inkjet printers under Linux ? with the main thread here: HP WLAN capable inkjet printers under Linux ? - openSUSE Forums

My HP All In One Premium (C309a model) printer works great under openSUSE Linux. A key point is to ensure one has hplip installed first.

pistazienfresser wrote:
> what is the best/easiest way to install a all-in-one device from
> Hewlett Packard (hp)?

i guess it depends a lot on the printer you have, see this thread
started earlier today for a success story:

hint: sometimes it is good to see if others have already asked a
particular question, give the forum’s advanced search a whirl :-]

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Thanks for your hint to the post of this morning. Maybe I was looking to much for “wiki” and “hplip” and thinking about the subforum wiki or Hardware so see it:X.

But I think tread is also a argument against marking the wiki article about hp-lip “obsolete”, or?

Ok. Installation on a lan or wireless lan is an other difficult issue. Maybe I will try to ad it to that wiki. I also found out that having the IP adress of the printer may be the key issue there.

I think your way is just an other way of initiating the hplip-setup process (and not an easier one).

But so long: No cause for marking the wiki article “obsolete”, or?

But an other question:

Why an printer with an wireless lan access of its own?

  • Router without WLAN?
  • Wanting to print pictures direct from a smartphone?
  • Separate room for the printer and no way to get it connected via LAN cable?

I have an hp all-in-one device with scanner, printer, fax and lan connection but without WLAN of its own (HP Officejet Pro 7590). If I log in my WLAN with my laptop I can print and scan (and maybe just fax from computer). Do you have a separate WLAN (not the same IPs as your normal LAN)?



hplip obsolete?

Where did you read that?

Thats news to me. I have always used it.

I don’t understand this question.

Some comments on my earlier posts with the printer.

We have 6 computers in our apartment and they all use wired. Our primary router has ONLY 4 ports. We had an extra router lying around (which also has 4 ports), and for about 2 years, with us being too cheap to buy a switch, we plugged the extra router into the primary router and thus we had access to the 4 ports on the extra router. BUT all PCs on the extra router, were in essence on a SUBLAN, and their IP address assigned by the extra router, and not the main router. That added a layer of complexity in our printing/scanning, because the printer used the wireless on the primary router. Hence all computers on the SUBLAN had to print through the extra router’s firewall to access the all-in-one-wireless printer. Too say that was ugly and complicated is an understatement.

The extra router finally died, and I replaced it with a nice switch, and I plugged the switch into our primary router, and now all our PCs have IP addresses assigned by our main router, and we have no SUBLAN. Things are simple now. :slight_smile:

I refer to the “{{Obsolete}}” in the head of the openSUSE wiki article marking the article as “obsolete” since the 13th of January of this year.

How to set-up a HP printer - openSUSE
Revision as of 21:16, 13 January 2010

Could not find anything in the new wiki-wiki to replace this en-wiki article.

Did the wiki-writer think that “installing” hplip via Software Manager would do the work?


I have a wireless HP All-in-one. Had to download latest hplip to get it working competely. Some HP models support some basic printing, but for any of them you will need their drivers to take full advantage.
One of the nice things of this wifi all-in-one, is that anybody in the house can scan using skanlite no matter whether other systems are on.

The latest from

Then deleting/deaktivating that wiki artikel How to set-up a HP printer - openSUSE would be not quite wise, would it?

No computer at all? Where are the scans copied to?


For my printer, they can be scanned to a USB stick or to an SD card.

Great. I tested 1 page on a USB flash divice.This seems to be quite!

Under linux I could handle it, too.

But under MS XP the software allways wanted to cut something and had driven me quite mad…:’(


Every time I have installed hplip after I have installed a new distro, its features have increased. So, yes - install the latest version of hplip; then install the printer using YaST where you also have the chance to pass on some default settings to hplip.

This would be now 3.10.5 see HPLIP Release Notes
Have you build it for your openSUSE by yourself?

Via Yast > Printer?

  • not a bit complicated? Can the settings not be changed after installation?
  • also good for all-in-one devices with fax, scan, copy?


Havinghad a look at the wiki article, I can see why it is ‘obsolete’.
You don’t have to uninstall anything. (Even with openSUSE 11) - hplip generally works ‘out the box’!
Just install hplip and then run hp-setup as root and install the printer.
Older network printers running jetdirect may need you to enter the ipaddress to find them, but otherwise the printer together with the correct .ppd file are detected.
You can then, after installation, got to the cups server (localhost:631) and set up the rest of the printer defaults (like memory, default trays, duplex, etc).
One thing about hp printers is that they do work and have manufacturesupport in linux, unlike other brands.)

If you want to re-write the wiki article, I am sure there will be no objections.

Haven’t tried fax as I don’t have any use for it but everything else has always worked since I first started using my all-in-one five years ago. What has changed has been the number of services offered by the hplip frontend.

If you have your printer plugged in during install, it will be installed automatically; if you do not, you need to go into YaST when you next connect to it. Then it makes sense to set the defaults. Otherwise, you can do everything from within the hplip frontend.

Did some testing. Once the correct hplip is installed, these devices can be configured through Yast fine.

I have a related issue. Hope someone can point me in the right direction. I have an HP all-in-one. I have set up the printer and fax. In the HP print manager software, under the print function is a scan function.

Clicking on the scan function brings up xsane, my preferred scan software. But, if I go through the start menu and click on either xsane or skanlite, I get an error dialog saying no scanner detected. There appears to be no way to get to a preference menu in either of these, they just close with the error message. Odd that xsane finds the scanner with HP software but not on its own.

Obviously, I already have a work around. But, it would be nice to have it work both ways.

Thanks for your testing.
I am not quite sure what step and what way of proceed you mean.

Do you refer to 1 c or 2 b?:

a) downloading and installing the program hplip via Yast>Software Manager
b) installing/first configuration of/setup of the printer/all in one device via terminal


and hp’s graphic setup program
c) configuration/more individual configuration via graphic Yast

a) downloading and installing the program hplip via Yast>Software Manager
b) installing and configuration of/setup of
the printer/all in one device
via graphic Yast>Printer
and graphic Yast>Scanner
and *? > Fax


I have just clicked on graphic YaST>Scanner and “installed” (the Scanner of) my all-in-one hp OfficeJet Pro 7590 (after being surprised not to find it there already).
I cannot remember if I was able to run the scanner via xsane before that (I mostly use the hp Device Manager).

Maybe Yast>Scanner will help you, Prexy.
Good luck

Ok, maybe I forget/do not use that, cause I have my HP device connected to my router via LAN and my laptop connected to my router via wireless Lan (WLAN). Connected that way my hp OfficeJet Pro 7590 to my openSUSE system did not start the installing/configuration process automatically.

If I recall it right I did once a install that way:

  1. Connecting my printer to my laptop via USB.
  2. Running the automatic installation process (hplip?).
  3. Looking for the IP-address of my hp device on the router.
  4. Correcting/installing the device(s) a second time.

But if I did a new installation of openSUSE now I use terminal>