Installing a Canon MX330

Hi,
I reinstalled Cups and the Gutenprint Drivers for Cups, but got the same results. Does it matter that I’m working under KDE rather than Gnome?
s660117

I reinstalled Cups and the Gutenprint Drivers for Cups, but got the same results. Does it matter that I’m working under KDE rather than Gnome?

No, it doesn’t make a difference. All I can suggest, is to review avertything from the top.

  1. Read this old thread, and the ‘guide’ link concerning the 64-bit library linking if relevant.

  2. Try using YaST (rather than CUPS web interface) to configure the printer. (I’ve only ever used the latter because of problems with the YaST, but in your case its worth a go).

Well here I am again hopefully with some positive news. I cannot replicate s660117’s situation exactly because I have openSUSE 11.2 and a Canon MX310 and he/she has openSUSE 11.1 and a Canon MX330. However, working on the assumptions that:

A) the MX330 has more or less the same guts as the MX310 with just a newer plastic box and

B) openSUSE 11.2 is a slightly enhanced version of openSUSE 11.1,

I decided to try installing the Canon MX330 drivers myself (Canon do not provide a Linux driver for the MX310 note) as follows:

  1. Downloaded the RPM package from the Canon site. This is a gzipped tar that contains two rpms and an ‘install.sh’ script.

  2. Extracted the two rpms and ignored the ‘install.sh’ script

  3. I moved the two rpms to my local, simple directory, repository at ‘/usr/local/rpm’. You can set up such a personal repository for the odd package under Yast.

  4. Ran Yast and than Software Management.

  5. Searched for the string ‘cnij’. The two rpms are called ‘cnijfilter-common’ and ‘cnijfilter-mx330series’

  6. Selected the ‘cnijfilter-mx330series’ for installation and then checked the ‘Installation Summary’ tab. This showed the ‘cnijfilter-common’ and ‘libpopt0-32bit’ rpms had been chain selected as dependencies. Note that the 64bit verion ‘libpopt0’ was already installed. Clicked to accept.

  7. All packages installed without error.

  8. Re-Logged on as root (very bad, I know, but it does save a lot of time in some situations). Printer had still not been powered on or connected to the computer at this stage.

  9. Went to ‘Manage Printing’ (CUPS at localhost:631) and checked to see if there were any USB options for Adding a new USB printer. None present. Exit CUPS.

  10. Plugged Canon MX310 (this is usually connected to my openSUSE 11.0 system) into a USB port and powered on. Checked ‘dmesg’ which showed the printer had been assigned to port ‘/dev/usb/lp0’ with driver ‘usblp’. ‘Usblp’ is a kernel module and its presence showed up under ‘lsmod|grep usblp’

  11. All seemed well on the hardware side so ran CUPS again and added a new printer called ‘canontest’. On the Device drop down list on the next page I now had the relevant options of:

‘Canon MX310 series Fax USB#2’
‘Canon MX310 series USB #1
‘Gutenprint USB Printer #1
‘Gutenprint USB Printer #2

I choose the third option here.

  1. Clicked continue and after several seconds it then proceeded to the next page where the ‘Canon MX330 series Ver 3.10’ entry was highlighted in the drop down list of PPD files. Accepted the suggestion.

  2. CUPS then asked for a user name and password and I entered ‘root’ and its password.

  3. CUPS reported that ‘Printer canontest has been successfully installed’ (roughly - I didn’t write that all down) and then showed the ‘Set Printer Options’ page.

  4. Changed the paper size from US letter to A4 and clicked the ‘Set Printer Options’ button. It then returned with an error:

‘Filter pstocanonij for printer canontest not available. No such file or directory’.

I think there was an earlier post about this possible problem and the cause is that CUPS, on a 64 bit system, looks in ‘/usr/lib64’ for some components instead of ‘/usr/lib’ where the Canon rpms store them.

  1. Decided to do a naughty and copied ‘pstocanonij’ from ‘/usr/lib/cups/filter’ to ‘/usr/lib64/cups/filter’. There is some backend stuff in a similar situation but I left that for now.

  2. Attempted to do a test page for ‘canontest’ but it still complained about the missing filter as before. Restarted the CUPS server by making two equal and opposite trivial changes in CUPS itself.

  3. Realised the Start Printer button for ‘canontest’ was highlighted so clicked on that and printer fired into life and produced two excellent Test Printer pages. However on the third and subsequent pressing of the Test button it comes up briefly with this odd error message:

‘Received 152 bytes of unknown back channel data!’

but it still prints. I think it may be something to do with the backends not copied from /usr/lib to /usr/lib64. Any body have any opinions on that?

So it looks as though the MX330 working under the same driver should work.

Hope that helps.

but it still prints. I think it may be something to do with the backends not copied from /usr/lib to /usr/lib64. Any body have any opinions on that?

Good work plodder. Your efforts with this are sure to be helpful. Its one of the potential issues I alluded to in my previous post - its mentioned in the guide linked to in the thread link (if that makes sense :P)

Hi,
And thanks for all your help. I’m afraid that I have to admit my mistake, as painful as it is. When prompted for a userid and password, I was NOT entering root/password. It all worked fine once I used root.
Thanks again for your assistance,
s660117

Hi,
And thanks for all your help. I’m afraid that I have to admit my mistake, as painful as it is. When prompted for a userid and password, I was NOT entering root/password. It all worked fine once I used root.
Thanks again for your assistance,

Making mistakes helps us to learn, so the time was not wasted, and I’m sure this thread will help others anyway. :slight_smile: