Installing a binary file in GUI mode

I am having a hard time trying to install a binary file. When I try to do it via terminal I end up with an error saying „The installer is unable to run in graphical mode. Try running the installer with the -console or -silent flag.”. Thing is I cannot install that file either with the -console or with the -silent flag as it’s unsupported. If I double click the bin file it opens an “unknown type” message box asking me to select an application. I installed some X Windows packages with no success. I don’t know what else to do. I am a newbie to linux (though the more I use it the more I like it over Windows OS) and a complete retard when it comes to openSuse. I don’t even know the yum or apt-get equivalent. But I really need to use this OS as it’s amongst the few that allows me to run 2 different molecular design software (if I succeed to install that second bin). And some functions are only available for Linux platform. The bin file I am trying to run is the installation package for Discovery Studio Client.

that bin file most likely needs root privileges, try it as root

su -

that file is most likely a gzipped file with a bundled bash script it does not use any system installer like apt or yum, openSUSE uses zypper as a command line package manager, as it is an rpm based distro it also uses rpm, you can install and use yum too but imo yum is inferior to zypper.

if you really need to run it in text mode, press ctrl+alt+F1, login as root, go in text mode ie init 3 by executing

init 3

run that script then go back to graphic mode by executing

init 5

If you have no objection to revealing the binary,

In most openSUSE Desktops, you should be able to select your console output and paste in your Forum post (use the hash button to create


I don't know that a lack of permissions would throw a "unable to run in graphical mode" error...


Well that would depend on how the script was written it could have only one error output, the only other binary installer that needs to run in text mode I can think off is nvidia’s propitiatory driver (the hard way) that’s why I said if running as root does not fix the error he should go in init 3, it could be that that file comes with nvidia’s run driver, using that driver is not the best choice for leap as we have prebuild rpm’s that are updated.
now I’m just speculating but there could be some extra switches so Will7 could also post the output of

./his_installer.bin --help

Many thanks to both of you for taking time to help me.

I_A, after logging in as su in terminal I was able to launch the bin in GUI mode, but after the first Next it would disappear. I changed the OS to openSUSE Leap 42.1. After that it refused to start in GUI mode even with su. I managed to get it working after randomly checking and installing some libx files in Yast (I honestly wouldn’t know to select the same files a second time). And to my joy I managed to run through the whole install process.
openSUSE Leap 42.1 (KDE) way way better than openSUSE 13.1.

TSU2, I don’t know how to reveal the binary (but I’d like to know how) and I am probably not allowed to post it since it’s proprietary software. It’s also larger than 300MB.


PS Btw, --help command is not supported:

The wizard cannot continue because of the following error: Invalid command line option: -help is not supported (1001) (403)
WARNING: could not delete temporary file /tmp/ismp001/9049499
WARNING: could not delete temporary file /tmp/ismp001/2759054
WARNING: could not delete temporary file /tmp/ismp001/3025061

I thought that it was a bash installer (they do not have gui’s)
opensuse does not allow gui’s to run under su or sudo for that you need to use kdesu or gnomesu, so in a terminal do

kdesu path_to_installer

gnomesu if you are using gnome.