Installing 11.1 for dual boot


Installing 11.1 for dual boot

I have a laptop [new] with XP and 160gig HD.

I want to install 11.1 - just ordered from Amazon.

What is the procedure

Do I have to partition the hard disk in windows before installation or will the suse disk do this.

I will be using 11.1, so what would be the advice on partitions for XP, 11.1 and the home file.


Installing suse after XP is very straightforward. Let suse make the decisions for you. I installed that configuration a few times. Each time, suse suggested about a 50-50 split of the disk and set up 3 linux partitions. That has always worked for me. You can ask suse to change the size of the XP partition, but if all you want is more space for suse, you could use a shared folder in your XP partition.

By the way, Vista is trickier. It demands more space. The bootloader has to be put in the MBR or Vista won’t boot. XP - Opensuse installs can be pretty automatic.

Good thread to read before you attempt to install.

NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums

Thanks for the reply.

What does ‘The bootloader has to be put in the MBR or Vista won’t boot.’ or is this in the advice for newbies?


Yes, Thanks I saw that after posting - it’s very good. Still waiting my copy of 11.1 at the moment. Just getting ready. This is my first ever installation myself… I just wanted to keep Vista but as usual does not come with disks!


Also look at:
Partitioning/Install Guide - openSUSE Forums
This is vista specific.

Thanks for the links.
Looking at my disk first comes PQSERVICE partition
then OS partition and I think one of those links mentioned that.

It appears 11.1 is now being shipped by Amazon and mine is on it’s way?

So tomorrow could be the testing day. Just doing the restore disks, fragmentation ready.

Thanks for the advice everyone.

There are many threads here describing difficulties with Vista dual boot setups. You can save yourself a lot of headaches by following the instructions at swerdna’s howto on multiboot setups. This shows how to fix a problem. However, the key issue was to boot from the Master Boot Record. So, when installing opensuse, at one point you are asked to choose where to boot from. There are several radio button choices. The default one was a suse partition. Further down the page was a choice for MBR. I selected that one and had no problems dual booting Vista. In other words, installing it right rather than fixing a problem later.

That linked page says suse 11.0, but it worked on 11.1 for me. Swerdna has many excellent tutorials and how-to’s at that site. They are worth reading and following to prevent aggravation.

Thanks again for the excellent advice.

Trying to install 11.1 as a dual-boot for my XP box

Got the ISO of 11.1, checksummed it - ok, burnt it (brand name disc) - ok, checked the files on the DVD - ok. So that shouldn’t be the problem

Get through the prompt part of the install process until I hit the following snag:

‘Error setting type of partition /dev/sda5 to 82’
Error code -1012

First time it took ages after hitting Install, the second time it hit that immediately

Thanks in advance

The limit for a hard drive is 4 Primary Partitions. The implication of your error is as far as I know (not far) is that you are exceeding this.

Remember those hidden partitions from ms must also be considered.

Extended partitions can alleviate this problem

Ok, thanks.

My next (predictable?) question is how do I fix that. Or work around it. Is it in the section of install where it pops out a recommended process and you can select ‘Edit’ or something?

I have limited experience with partitioning or Suse, any help appreciated

PS: Where’s the resource/API whatever where I can look up those error codes. Has to be online somewhere.

Maybe it would be more direct if you post your partioning setup. At least in outline.

I imagine that you have already used the custom partion part of the installation before since suse seldom gives sda5 as a default option.

Just a list of the partitions an what is or should be on them…

I had to repair and re-activate Vista (before SP1 though) after installing openSUSE.

If you don’t have genuine installtion media, then the only installation I’d attempt would be on a second hard disk, and I’d remove the power to Vista’s system disk.

Unless of course, I was wiping Vista totally.

May be you feel luckier than me :slight_smile:

you needn’t worry about that. whatever system will provide a tool to help partition when you are installing

Thanks for this reply. It works great and was easy to install, did the MBR as suggested and all working. Thanks to Swerdna as well - great site. I did miss be able to register my product as my router was not available during installation. Any idea how I register now? No body seems to know at Novell.

Thanks Again;)


Thanks for the reply.

yes Suse did the the partitioning, resizing and reformatting of the Suse partitions.

You mean I know something that Novell doesn’t know??!!! rotfl!

yast–>support–>support registration

Interesting times

Went back into XP, something or someone had created 2 partitions that were doing nothing, not appearing to explorer etc & only appearing in Computer Management. Deleted those, and SUSE installed pretty much faultlessly.

Until it got to installing GRUB, which cacked itself (this error: GRUB and XP problem - openSUSE Forums), and wouldn’t let me put XP as the first option. The ‘Repair’ function apparently destroyed the boot records for XP. After that, it wouldn’t boot at all, off SUSE on the hard drive, XP on the HD, or either CD/DVD. Very annoying. All the fixes seem to be based on getting the thing to boot in the first place, this’d load the splash screen (Boot/Repair etc.), then try and boot off HD without any user input

So now I’ve got XP booting on my other hard drive

Why does this happen.

Not that anyone’s probably interested, but I solved using the very good document on ‘How to Repair Your Grub Multiboot’. Then, since I’d swapped over HDs from primary to secondary, back to their original state, I plugged the new one back in, as a second volume. And had to install GRUB/Fix MBR/do boot order yada yada yada all over again.

Must say, the bit in ‘Automatic Repair’ mode which is meant to fix bootloaders is a piece of turd. I must have run that thing 15 or 20 times over the last few weeks. Fixes nothing.