Installing 10.3 and 11.0 in parallel? Partitioning?

I am scared. Therefore I want to keep my working Suse 10.3 until I am sure 11.0 is up to the task. How do I install it in parallel?
My previous tries on installing 10.3 in parallel to 10.1 failed and I want to avoid the same problem from happening again!

Here’s a description of the old problem: 10.3’s YAST automagically configured GRUB with entries for both 10.3 and 10.1, but the two entires for 10.1 did not work at all. I could still boot 10.1 through the GRUB command line though (I manage, but my wife does not. It is important that she can boot the old system while I fiddle with the new one!). I suspect that the problem might be due that I did not mount the root partition of 10.1 in 10.3 and vice versa - since I do not want one system to be able to touch the other. Do I need to mount it read-only somewhere in the other system?

Another error-source might be that /dev/sdc is a SATA disk connected via a cheap PCI-SATA-Controller on an 8 year old mainboard. Booting via SATA-DVD fails, but somehow 10.3 does boot fine.

Here’s my disk layout:

/dev/sda1: NTFS (17GB)      /windows/system 
/dev/sda5: Swap (666MB)
/dev/sda6: ReiserFS (10GB)  / (for 10.1 unmounted otherwise)
/dev/sdb1: FAT32 (75GB)     /windows/data 
/dev/sdc1: ReiserFS (10GB)  / (for 10.3 unmounted otherwise)
/dev/sdc5: Swap (1GB)
/dev/sdc6: EXT3 (688GB)     /home 

So what should I do when installing 11.0? How should I partition my disks? Obviously I only intend to format /dev/sda6 and make it root for 11.0, but I have enough space on sdc6 to move around stuff.

If it were my box, I would install 11.0 on sda6, with grub in the root partition (not to the MBR). Do not use sdc6 as /home for 11.0 unless you use a different user name in 11.0 than the username you use in 10.3 (incompatibilities of application versions may cause problems if using the same user name for both installations in the same /home partition). Using different usernames means different user folders in /home, and the problem of incompatibilites ceases to exist. Of course, if you want to use the same user name, then don’t use the /home partition for 11.0. Just let 11.0 create a /home directory in sda6

When 11.0 is installed, and before re-booting, open /boot/grub/menu.lst (in 11.0) and copy the menu entry for 11.0. Then mount sdc1 and open /boot/grub/menu.lst in 10.3 and paste the menu entry into it after the entry for 10.3.

On re-boot, you should see both versions of OpenSUSE in the menu, and both should work.

When 10.3 is booted, the partition for 11.0 is not mounted because 10.3 doesn’t know about 11.0 yet. When 11.0 is booted, the partition for 10.3 will be mounted if there is an entry in /etc/fstab for sdc1 (in 11.0’s fstab).

I’ve had various versions of SuSE and OpenSUSE installed for some years now. Like you, I am a bit worried about how well the latest version will work until I’ve tried it for a bit. (And in my case, the latest version is often a Beta version so it is especially important to have working parallel systems.)

My solution is to use separate partitions for various OS versions and a home partition that is separate from the OS partition. (I also use a different user account for testing than I use for production use.)

In your case, I would suggest that you select the expert partition option during the install. I always edit the proposed partition layout because it never fits the way I want my disks and this is what I suggest that you do too. You are going to want / on sda6 and /home where it is now on sdc6; if the installer proposes to do anything else, make sure that you change it to the way you want the partitions to be. I also suggest setting sdc1 to a mount point of /10.3 – that way you can copy files off that drive if necessary.

To help me deal with all of the partitions that I have, I create a little cheat-sheet listing the various partitions and what I want there so that I can label things the way that I want them during the expert partitioning portion of the install.

My sheet for yesterday’s install of 11.0 with KDE 3.5 (for compatibilty with 10.3) looks like this:

sda1 /windows/restore     vfat
sda2 /windows/C           ntfs-3g
sda3 /windows/D           vfat
sda5 swap                 swap
sda6 /                    ext3
sda7 /oldhome             reiserfs
sdb1 swap                 swap
sdb2 /KDE4                ext3
sdb3 /10.3                ext3
sdb5 /local               ext2
sdb6 /home                reiserfs

Sorry if thinking too simple any maybe a missing a comment on 10.1… :slight_smile: But why not install 11.0 over the 10.1 partition and share you /home (but as stated earlier use different user names as not to mix user application configurations between 10.3 and 11.0).
10 GB should be enough for the install and normal apps.

The important thing to booting correctly with grub is just a matter of where its all pointing to.
If you first make a backup of /boot/grub/menu.1st from your 10.3 setup, if things go wrong with the grub setup, you can always manually add back the correct boot parameter for 10.3.


Thanks for the answers thus far. Of course I want to erase 10.1 and install 11.0 on /sda6 (that’s what I wanted to express with the last sentence of my first post).

However, my problem is how to configure Grub correctly so that I can boot either 10.3 and 11.0: Previously copying the entries around produced lots of error messages during booting - I had the feeling that the correct kernel was booted with the wrong root device.

I tried entried like “chainloader=/dev/sda6 root=/dev/sda6” but this did not work at all. What is wrong there?

Sorry for the oversight with /sda6… I was looking at /sdc6 and was stuck with the thought you wanted to resize and split it.

Well, you don’t need to chainload when booting between Linux OS’es. Thats only needed when booting to a foreign OS.
It might be easier you use YaST > Boot loader to input the correct values for your new entry, in the menu.1st it would look something like:

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - (default)
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/sda2 resume=/dev/sda1 splash=silent showopts vga=0x314
    initrd /boot/initrd-

Alright, I guess the “root (hd0,1)” was missing somehow, because it worked when I entered it via the GRUB-commandline.

I think I’ll manage to edit the menu.1st then. Thanks!