installer does not see SSD

This is about Machine # 1

I am having trouble installing Leap 42.2 .
I made a bootable USB installer for 42.2 using rufus.
I secure wiped my OCZ Vertex 4 [ssd 5 years old] with OCZ’s utility. [including this time, have done this before and never had problem]
I partioned to GPT type and EXT4.
My EUFI/BIOS sees the SSD and the USB installer.
They are set to the proper boot order in EUFI/BIOS.
The USB installer boots into the screen that lets you choose if you want to install or upgrade or boot from HD.
When I choose install it seems to load, but then hangs and does nothing with a green line at the bottom of the screen that states Leap 42.2 at the end of the line.

Could anyone suggest what might be wrong?

Because I cannot leave this machine without an OS I tried to reinstall Leap 42.1 from a bootable USB and it does install.
I would like to use 42.2 and am now downloading another copy of Leap 42.2 to see if the original download was not correct.
Still appreciate any advice in this matter. Thank you.

Rufus will not work. Be default it modifies the iso and this will break the installer. If working from Linux use either dd or cp to copy the iso to the device. Rufus may have a dd mode which should work

cp *pathtoiso /dev/sdX *

Where sdx is the device you wish to make the install device.

The problem may be video card related which do you have? I doubt it is a problem seeing the drive

Or since i7 CPU maybe need a newer kernel 42.2 comes with 4.4 but 4.5 plus is needed for the newer Intel chips. It should install though???

Please ensure to use the “dd” copying option with Rufus, or better still use SUSE Studio Image Writer if you still have a working openSUSE.
Then press “ESC” at the green line screen to see where exactly the installer hangs (usually at installing a driver, maybe a video driver?)

cp the ISO to the device (not to a partition, eg not to sdx1, but to sdx) will also work, as will dd

Besides what was posted,
Be aware an installer will look for free, unpartitioned (and unformatted) space.
If you format your disk (eg ext4), then the installer won’t see the disk as a viable target.


Thanks to all who replied: gogalthorp, OrsoBruno, Fraser_Bell & tsu2.

Nothing seems to be working, yet.

I installed opensuse 42.1 again to be able to do the bootable usb thru opensuse using Suse Studio Imagewriter.
rebooted, plugged bootable usb in and made sure it was in the right order in EUFI/BIOS and proceeded to the install screen.
Again it allowed me to choose to install and then the green line at the bottom of the screen ran all the way to the right side of the screen where it said opensuse 42.2 and hung there. I hit <esc> and saw that it had loaded what it called ‘basic’ drivers and the cursor was blinking but doing nothing. I should have written down the drivers it said, but didn’t. However, because of what gogalthorp & OrsoBruno said [re: video driver] I did see that it had not loaded a video driver.

Or since i7 CPU maybe need a newer kernel 42.2 comes with 4.4 but 4.5 plus is needed for the newer Intel chips. It should install though???

my i7cpu is 3770K and it worked fine with 42.1.

Be aware an installer will look for free, unpartitioned (and unformatted) space.

I am currently downloading a fresh copy of 42.2 iso and will try once more to install, but before I do I will go back and use GParted to clear any formatting from my ssd.

If it shows (only some) basic drivers and nothing more, maybe it is hanging (or waiting) for some “odd” USB device to show up: try disconnecting everything USB (including disabling bluetooth or webcam?) before installing.
With integrated video (i7-3xxx should have no problems AFAIK) you don’t see a video driver explicitly loading. To be on the safe side, try booting with the “nomodeset” boot option: that will load a basic video driver that should allow installation and rebooting, video troubleshooting, if any, can be done afterwards.
If you have discrete graphics, try disabling it if possible if you still have problems (but the installer should run to an extent anyway…)

if 42.1 is installed, do a dist upgrade to 42.2?

I downloaded a new copy of 42.2, used Suse Studio Image writer to make a bootable usb.

@tsu2 - I cleared formatting from ssd.

**@**OrsoBruno - the only usb devices I have connected are mouse & keyboard and of course the bootable usb stick.

As of now, when I hit <esc> all that is shown is “Loading basic drivers…”, On using the pior bootable stick I was getting specific driver info, as in loading driver for this or that.

@ndc33 - That is a thought to do that, however I have since uninstalled 42.1 see tsu2 comments]. Although it is certainly something to consider trying.

**@**anyone - Could things have changed so much between 42.1 and 42.2 that I am unable to use 42.2? My machine is only 5 years old.

Really? I mean, without even an OK at the end of the first line, so you are stuck at the first box?
Here is a typical screenshot from a booting installer for your reference:
-basic drivers
-HW detection
-disk controllers
-usb devices
-network controllers

From 42.1 to 42.2 THE KERNEL changed, from 3.16.x to 4.4.27 (in the installer DVD): might this be enough to stumble on unusual HW?
(I understand that the Asus P8Z77-V Deluxe you are dealing with is/was a gamer’s MB, not a basic one…)

I am writing this from my new install of 42.2.
Yesterday, at lunch, I came home and decided to give the install another try.
Again it stalled on “Loading basic drivers…”.
Frustrated, I simply let it sit there and checked it about a 1/2 later, but it was still “Loading basic drivers…”.
I left it as it was and when I came home from work it was sitting there waiting for me to begin the install.
I was gone approx 4 hours, so I don’t know when it went past the “Loading basic drivers…”.
The only thing I did different was to format 1/2 the ssd and leave the other half unallocated.

re: tsu2’s comments ]Be aware an installer will look for free, unpartitioned (and unformatted) space.

So why was it so slow? It all seems to be working OK now, except for chrome and kwallet problem which I will address in another post.

Thanks for all the help and advice.

Check the BIOS/UEFI and see if a floppy disk is marked as being there. At one time that could be a problem since the BIOS was tell the installer there is a floppy but the installer could not find it. Thought that was fixed but could be something like that fo another piece of hardware. BIOS says there is one installer can’t find and the timeouts are set too high