Installer does not boot with GRUB for EFI

I cannot upgrade my OpenSUSE 15.3 to 15.4, since the installer ends up with red message, saying something “cannot perform upgrade, because the BIOS is EFI, but the installer has been booted with Classic BIOS” (very vague translation).

I didn’t find anything about the error in the forums. Reading documentation, it seems it says that installer should automatically select “GRUB for EFI” and then the installer should look differently, with different options (no boot parameters, etc.). This evidently failed in my case.

The same thing happened during the last update, I think I hacked it somehow, by booting from an old installer and pointing it to a new installation media to start a new installer. But that was very hacky and I would resolve this problem once for all.

The PC is OpenSUSE only machine and have ever been.

  • UEFI BIOS 1820 x64
  • AMD DRyzen 7 3700X 8-Core Processor
  • 32768 MB DDR4 @ 3200MHz
  • Two SSD drives

Current system boots via “opensuse-secureboot (Force MP510)”. That’s what BIOS says.

Any advices to fix the issue appreciated.

There are several ways to do that upgrade. Please do not assume other people can read your mind and know what you are doing exactly.

You talk about an “installer”, thus you do not use the on-line way (which is very easy).

When you booted something to do this, that boot it using the same method as all booting from the system. Thus as the system uses EFI (and thus your 15.3 is booted using EFI), then also boot the “installer” (whatever you mean with that) using EFI. Do not mix!

Go to UEFI boot menu and select the USB stick as first option:

I tried my best to put all the information, just didn’t realized the installer part. It’s full OpenSUSE installer on 4GB USB media. It’s that media I boot (via BIOS boot menu) and it’s kernel.

The documentation literally says, that upon booting, the installer will select different GRUB with different option, if the BIOS is EFI. They even depict the two screens and point out the differences.
But I could get something wrong, of course.

Thank you for suggestion, but please forgive me that I’m not sure I get the idea even after reading your post like 5 times.

What I do:

  1. I created installation USB media
  2. Upon BIOS being loaded, I press F8 to get into “BIOS Boot Options”
  3. Select USB installation media
  4. Proceed with installation wizzard (like selecting partition to update, activating online repository,…)
  5. When everything is set, in the last step, I get that Warning message - this time I left it in English: Cannot upgrade the bootloader because of a mismatch of the boot technology. The upgraded system uses EFI boot while the installation medium has been booted using Legacy BIOS boot.

Maybe it’s something prior starting the Installer, maybe reading GRUB differently when on Installation media. So I’ll try to make USB stick the primary booting media in the BIOS. I’ll test it now.

It does not matter what you read or did. There is only one important fact: all operating systems to be booted, those already on the system (for multi-boot, or for being upgraded), the installation medium, the new system (when it is about a new installation), must use the same way of booting. Either all the old MBR way, or all the EFI way.

Thus you have to find out how to do that if the USB stick is MBR booted spontanious and your system is EFI booting. THat is where we can try to help you. As @karlmistelberger already tried.

But again, why did you choose for an installation medium (in your case on an USB stick)? Why not using the on-line way? You may have a reason, even a very valid reason, but I am curious, because IMHO the on-line way is far easier (and it involves no other boot then that of the upgraded system).

You did not choose the Upgarde from the first menu, but choose Installation?
When I understand this correct, you did not even do an upgrade, but a fresh installation.

In any case the rule applies, all booting must be done in the same way.

Show picture of boot menu listing available boot choices.

Maybe it’s something prior starting the Installer


maybe reading GRUB differently when on Installation media.

No. When system supports both legacy BIOS and UEFI boot you usually have two lines in boot menu for each removable device. Exact names and order vary on different systems.

OK, changing the Primary Boot Media in BIOS (not just boot media at Boot time) did the trick!

So I guess it’s not about which installer starts (that was correct), but also which device provides GRUB. I’ve been doing it using Boot menu for over two decades, but OK, now I’ll remember to switch primary booting media.

Installation is easiest with CSM (compatibility Support Module) disabled: Video shows how to enable CSM. Make sure it is DISABLED.

I’ll have a look at that. And thank you very much for your help.