Installer did not recognise it is a laptop

Hi,

I have got a Fujitsu Lifebook A512, and installed an openSUSE 12.3 x86_64 with KDE.

The problem is that after installation, I realised that the system behaves like it should on desktops. E. g. in Kickoff menu, the computer icon is not a laptop, but a desktop. In system settings, it does not recognise the touchpad, so I cannot configure it (however pointing and left-click-tap works). In power management settings, there are also missing settings: there is no way to set different behaviour on laptop lid states. And one more: on system tray, there is no battery indicator by default. If I enable the battery indicator, it always shows that battery is totally empty and it is not charging.

How can I solve all of this issues? Where does the system decide if it is a laptop or a desktop? During install? Or it has an option somewhere in a configuration file?

What version of plasma-desktop are you using?

Are all power-savings options activated in the BIOS?

What local security level did you set? Normal setting, secure settings?

The fact that the touchpad works, means that you have it running and it is correctly recognized. The icon of the PC is only an aesthetic issue without any meaning. If you would run the “junk fruit icon set” then it could be e.g. a foul banana. It is arbitrary and has nothing to do with working or not with laptop. You could install the package powertop to see if your powersavings are working or not. There are settings you can join to the start line of your boot manager to activate power savings of the processor and other features. As not all machines are produced following the standards, I would try them one by one to see if compatible or not. At the end you could write them into the grub menu in yast, so they are executed in automatic.
Look in the system settings if power management is activated for your system. But recall, first control in BIOS.

I have checked two laptops. On both of them, the computer icon is a desktop. However, they were recognized as laptops by the installer.

That happens when the touchpad driver does not recognize the touchpad. But it is still recognized as a PS/2 mouse.

Your power management problems are most likely also a mismatch between driver and hardware.

I had similar problems with a laptop I purchased a couple of years ago. But by now the drivers have caught up, and all is working fine.

First of all, thank you for your answer.

Version of my plasma-desktop: 0.4

Unfortunately there is not any settings in BIOS regarding to power-saving (except of a silent fan-control option).

What do you mean under ‘local security level’? I did not set any special. The firewall runs with system default settings.

As for the touchpad, I have already figured out, that it is recognised as a PS/2 generic mouse, that is why there is no possibility to configure it in system settings. Of course, the PC icon is not an important thing. I have just mentioned it, becouse on a laptop installation it supposed to be a laptop icon, and I think something is wrong with the system if it could not detect that it is running on a laptop.

I have installed powertop, and I will make measurements about power consumption. But bigger problem is that the system did not detect the battery and it cannot notify if it goes empty. The only clue for that it is the battery LED starts blinking. Then I have to turn off or hibernate the computer manually, becouse due to the lack of battery-recognition, there is no settings regarding to the level of the battery.

Did you mean pm-profiler in YaST > System services? I have activated it. And now what?

On 2013-04-26 14:36, helmet91 wrote:
> What do you mean under ‘local security level’? I did not set any
> special. The firewall runs with system default settings.

It is a setting in YaST, security center and hardening, miscellaneous
settings.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

In short: Fujitsu built the laptop that way. And it’s not their only model. And not their only model that doesn’t have the power management features accessible through the BIOS.
A question: did you install with a wired connection active? I remember reading posts on linuxquestions.org where users of Fujitsus reported that their laptop was treated as a laptop only when the install was performed without cable connection.
Second question: when booted from a Live USB, do the features work?

Provided you have an intel-chipset you can join these parameters to the boot-manager line (after showopts, typically).

i915.i915_enable_rc6=7 i915.i915_enable_fbc=1 i915.lvds_downclock=1 drm.vblankoffdelay=1

. For me with a Core i5 this lengthens the battery time a lot.

Well I said in KDE system settings powermanagement.
Now with the battery… what KDE version? Kann you give me the output of:

upower -d

?

Yes, I installed with wired connection.
And no, Live systems (I tried several distros with both Gnome and KDE) don’t work properly either.

Yes, power management is active.
KDE version: 4.10.2

Upower output:

Device: /org/freedesktop/UPower/devices/line_power_ACAD  
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/ACAD
  power supply:         yes
  updated:              Fri Apr 26 15:44:04 2013 (15404 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             no


Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT1
  vendor:               PAC
  model:                BAT1
  power supply:         yes
  updated:              Fri Apr 26 20:00:47 2013 (1 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              24.84 Wh
    energy-empty:        0 Wh
    energy-full:         47.412 Wh
    energy-full-design:  47.52 Wh
    energy-rate:         9.828 W
    voltage:             3.423 V
    time to empty:       2.5 hours
    percentage:          52.3918%
    capacity:            99.7727%
  History (charge):
    1366999247  52.392  discharging
    1366999217  52.574  discharging
    1366999187  52.733  discharging
    1366999157  52.961  discharging
  History (rate):
    1366999247  9.828   discharging
    1366999217  9.266   discharging
    1366999187  12.064  discharging
    1366999157  12.852  discharging


Daemon:
  daemon-version:  0.9.19
  can-suspend:     yes
  can-hibernate:   yes
  on-battery:      yes
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no

It seems like the battery is properly recognised by the system, but KDE battery indicator doesn’t work.

I did some powertop measurements, both with AC adapter plugged-in and without.
Results when battery is charging
Results when battery is not charging

@stakanov: Could you please check my powertop results and review the boot parameters that you offered?

Boot parameters:
there have had been various regressions on the powersaving functions of intel CPUs. Therefore all Kernels from kernels >= 3.6.2 and < 3.8 on Sandy (and rarely, Ivy) Bridge processors have the deep power saving sleeps states of the GPU disabled. If you want to try you can put them on with the:

 i915.i915_enable_rc6=7 i915.i915_enable_fbc=1 i915.lvds_downclock=1 

where enable_rc6=7 is the state** “deepest”. If you encounter problems in wakeup (sometimes possible, depends on intel-gpu model, try to use* “rc6=3” which is denominated “deep”. ***

Can I find out if my GPU did actually change sleep state? Yes we can (well, that did not want to be politic).

watch -n1 'cat /sys/kernel/debug/dri/0/i915_cur_delayinfo'

Should do.
The biggest consumers however are SATA (and there the wakeups can be difficult to controll, do not forget to set nepomuk to NOT index while on battery otherwise it is a real bat drainer. WLAN can be “quite resistant” against switch off. If you have a hardware switch to switch off WLAN when not needed you should use it. consumes much less when e.g. reading a book.
LVDS is the so called “low voltage differential signaling technology” that should go end of life 2015 in favour of hdmi and display-port. **i915.lvds_downclock=1
**lowers its refresh rate but can cause trouble with some monitors like flickering. If you encounter that, take it out.
FBC (frame-buffer compression): with the command you activate frame-buffer compression. In some systems that does not work well, screen does not repaint. If you encounter this, take it off. Since the frame buffer is compressed you use less memory bandwith and therefore in the ideal case less energy.
The ***drm.vblankoffdelay=1 ***should give you less wake-ups of the CPU = less consumption.

Bluetooth is a consumer. If you do not use it, switch it off. If you switch it off, do it in yast as only in KDE it might show you “switched off” but may continue to send and consume. If you NEVER EVER use it and you are definite about this, you may switch it off in the BIOS. Very effective, obviously.

I don’t know, did this help you in any way?

On 2013-04-26 22:16, stakanov wrote:
> I don’t know, did this help you in any way?

Why not use laptop-mode-tools?


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

because laptop-mode tools do not set these parameters, they are “sperimental” if you wish so, because it is not forseeable if the user has one of the machines hit by the bug. The parameters named as of above are set one by one and then written to grub by the user within yast, if they are compatible. I have laptop mode installed but with these changes on top of these, I have a much higher autonomy.The question if that helped was more referred to the comment of the OP to “comment on the values” I gave him. As I did not really want to know what he did expect by saying “to comment” I suppose he wanted to know “what does what” for not having to do these changes on “blind trust”.

Thank you very much for the well detailed descriptions about the boot parameters. Now I know what to expect when I set them.

Well, actually I wanted to make sure that you gave me correct parameters, becouse earlier you knew only that I have an Intel chipset, that’s why I provided some extra info about the system. I thought that the boot parameters are depending on detailed system specifications. I’m sorry, if you misunderstood my request.
But again, thank you for the useful info.

And another mystery: If Upower can perfectly see my battery, then KDE why not (and not only KDE, but Gnome either)? I don’t know too much about the OS, but it seems like (for me) that there is a component between the kernel’s power-manager-part and KDE, which doesn’t work.

You may well be hit by this bug: 304510 – Battery plasmoid does not show remaining time

Some news:
Upower detects the battery only if I runned Powertop before. Otherwise upower -d outputs this:

Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/ACAD
  power supply:         yes
  updated:              Sun Apr 28 14:21:35 2013 (78 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             no


Daemon:
  daemon-version:  0.9.19
  can-suspend:     yes
  can-hibernate:   yes
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no

Sorry for multiple posts in a row, but I could not edit my previous post.

When I run Powertop so that Upower can detect my battery, and then I logout and login, then KDE battery indicator works correctly. The options in System settings > Power management regarding to battery level also appeared. (And last, but not least, in Kickoff menu, the Desktop computer icon became a laptop icon. :))

So I think we are facing to a Upower bug.

On 2013-04-28 15:06, helmet91 wrote:
>
> Sorry for multiple posts in a row, but I could not edit my previous
> post.

That’s an intentional feature of these forums :slight_smile:

> When I run Powertop so that Upower can detect my battery, and then I
> logout and login, then KDE battery indicator works correctly. The
> options in System settings > Power management regarding to battery level
> also appeared. (And last, but not least, in Kickoff menu, the Desktop
> computer icon became a laptop icon. :))
>
> So I think we are facing to a Upower bug.

openSUSE:Submitting bug
reports


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

To be a bit more verbose: you should really report the bug. This will have several advantages: you are doing something of value to everybody. You are also having a good chance they may give you a solution as “hotfix” and you will be a direct beneficiary when the official bugfix comes out. So really, great you did find out this valuable information, Fujitsu is a quite frequently sold laptop so go ahead. Thank you in advance.