Installer blackscreen

hi,

got a laptop with an amd R5 gfx card (https://support.hp.com/emea_middle_east-en/document/c06041490) which is running leap 15.
it has a power draining issues though when shut down so for the bugzilla I wanted to install the latest kernel (tumbleweed) alongside leap 15 so I can test it with that.
So downloaded the tumbleweed installer and put it on the usb, it boots up, select installing in grub, the normal message scroll over the screen (you know found drives etc. etc) and then the screen turns black and that is it.
I tested this with the full install, the network install and the live cd and they all behave the same.
It all scroll by really fast but I think I see something like it starting the opensuse installer (or something along those lines) and then it goes black, it feels a lot like it wants to set a screen resolution or frequency which is not supported.
ctrl+alt F1 to F7 give no visible changes

Checked out the posts here like “Kernel 4.19.1 won’t boot (black screen)” which looked familiar and tried the idea’s posted there:


radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1

plymouth.enable=0 console=tty

but most of the stuff there is about an already installed tumbelweed, which is not the case here.
so a bit at a loss here…

When you have the Grub menu screen, hightlight the Install option, do not click it. Press “e” to edit. Add nomodeset to the end of the boot command line.

If that does not work, add this to the end of the command line:

Textmode=1

This will give you an ncurses version of the installer. Yep, looks a little kludgy, but works much the same as the GUI installer.

thank you for the answer, nomodeset got me into the ncurses installer with a message that the x-server could not be started.
installation is done but of course tumbleweed itself shows the same behavior, so it seems to be something with this kernel version 4.19.11 and the R5, will fiddle around a bit more

edit: see this in dmesg: [drm:amdgpu_init [amdgpu]] ERROR VGACON disables amdgpu kernel modesettings

well what I can tell, by comparing leap with tumbleweed is that in tumbleweed amdgpu does not show up in lsmod while it does in leap.
But how that can be solved, no clue… or if it is even the cause.

1-Does the current kernel cmdline contain nomodeset, as was used to install? It’s only a crutch, a troubleshooting tool that allows a functional environment for performing repairs. It absolutely prevents use of competent X drivers. Specific cmdline parameters for amdgpu can’t do anything when nomodeset is blocking the X amdgpu driver.

2-Is xf86-video-amdgpu installed? It may be necessary.

3-Which R5 do you have? Output from ‘lspci -nnk | grep -A3 VGA’ would tell us, as would output from ‘inxi -Gxx’, and if you could get into X at all to run it in an Xterm it would report which X drivers are in use and available.

4-Have you tried disabling the GUI startup? Sometimes it causes black screens. Turn it off temporarily via the cmdline parameter plymouth.enable=0 appended to the linux line in the Grub menu. More permanently it can be done placing that parameter in /etc/default/grub and running grub-mkconfig or with yast2-bootloader. Uninstalling plymouth is another option, what I do always.

5-Is kernel-firmware installed? R5 needs it.

6-Note there are multiple layers of “driver”. First is kernel, built into it, but requiring kernel-firmware for full function. Next are the various potential X drivers, which include xf86-video-amdgpu, xf86-video-ati, and the modesetting driver integrated in the X server.

7-Having /var/log/Xorg.0.log to see will help us help you when you can get logged in. Easiest way is usually the susepaste cli command, which may or may not already be installed (inxi probably isn’t, but is easily installed once logged in: ‘zypper in inxi’).

hi mrmazda, thanks for all the questions :slight_smile:

well I feel dumb now, it was… I guess because it was used to get the installer running
so removed it and now I got the exact same issue again as with the installer, a blackscreen

it was not, installed it and rebooted, blackscreen again

lspci -nnk | grep -A3 VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] [1002:98e4] (rev da)
    Subsystem: Hewlett-Packard Company Device [103c:84d0]
    Kernel modules: amdgpu
00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:15b3]

inxi -Gxx
Graphics:  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard 
           driver: N/A bus ID: 00:01.0 chip ID: 1002:98e4 
           Display: server: X.org 1.20.3 driver: ati,radeon,vesa unloaded: fbdev,modesetting 
           tty: 100x37 
           Message: Advanced graphics data unavailable in console for root. 

tested with the cmdline parameter, blackscreen

it is, although there are some messages

dmesg | grep Firmware
    0.256330] [Firmware Bug]: cpu 0, invalid threshold interrupt offset 1 for bank 4, block 0 (MSR00000413=0xd000000001000000)
    0.401355] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    0.402203] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge

here is the xorgs logs, it just feels like its trying an unsupported resolution or freq, at least that is how the gold old monitors in the past would react and go all black :slight_smile:

Tumbleweed (no X starting) http://paste.opensuse.org/44588718
Leap 15 (X starting) http://paste.opensuse.org/26772900

There are no (EE) lines in the TW Xorg.0.log, so X thinks it’s working. Which role did you install, Gnome? KDE? Other? You may need to switch DM.

Maybe globally disabling compositing would at least help with troubleshooting. Try adding to /etc/X11/xorg.conf.d/ 30-local.conf containing the following:

Section "Extensions"
        Option          "Composite" "Disable"
EndSection

its KDE. (both TW and Leap)
tried your xorg option, no change.
Basicly the screen goes black right after grub, so when Plymouth normaly does its stuff.

I also updated to TW 4.12 snapshot of today, no luck.

funny part it, everything works, screen even goes into standy if I wait long enough, so it’s at the login prompt, I just don’t see it .

I do think its bugzilla time though …

Are you using an external display? Or, dual display?

I have a feeling that the login is there, but offscreen.

Try closing your laptop lid and re-opening, see what happens.

I’m grabbing at straws, here, but worth a try?

I don’t understand this statement.

4.12 is the Leap 15 kernel

20181224 is the previously released TW snapshot.

20190108 is the most recently released TW snapshot.

What was your meaning?

sorry, meant 4.19.12 which was in the 20190108 release.

playing around with tumbleweed cli to see what version of tw it went wrong, because I have booted it with a TW live cd fine somewhere last year, just don’t know the exact date

seems oldest snapshot to go back to is 20181119 kernel 4.19.2-1 which has the same behavior.

just the laptop screen and no it did not help.
However this gave me an idea, so I hooked the laptop up to a monitor with an HDMI cable.
laptop screen stays black, but monitor showed a screen, the login prompt was on the laptop so did not see that, but after typing in password the KDE desktop showed up on the monitor, so when to KDE settings, screens and saw both the laptop and the monitor, the laptop screen was disabled, so enabled it and it worked just fine…
it wont survive a reboot but at least shows that the laptop screen is fine (as leap already showed)

https://raw.githubusercontent.com/torvalds/linux/master/Documentation/fb/modedb.txt describes how video= can be used on kernel cmdline to force a display on. Maybe this is what your laptop’s display needs until a better solution can be found.

interesting:

video=1024x768M@60m works, plymouth shows, KDE shows (at 1920x1080)
video=1920x1080M@60m blackscreen
video=1920x1080M@60me blackscreen
video=1920x1080M@60mD blackscreen
video=eDP:1920x1080M@60m blackscreen
video=eDP:1920x1080M@60me blackscreen
video=eDP:1920x1080M@60mD blackscreen
video=eDP:1024x768M@60m blackscreen
video=eDP:1024x768M@60me blackscreen
video=eDP:1024x768M@60mD blackscreen

amdgpu.dc=0 solves it

https://bugzilla.kernel.org/show_bug.cgi?id=200695

Great! … and thanks for reporting back, may help someone else.:good: