Installed the basis KDE 4.1 desktop, but it wont work.


Hi. I installed the KDE 4.1 basis from the opensuse’s download page. Now when I select the desktop I installed, through kdm (KDE 4.1 RC1) the system shows the desktop background and a nice gray cursor with the konqueror logo jumping, then the konqueror logo disappears and the system does not do anything. If I press ctrl+alt+del i get the choice to turn off, finish session and another one i cant remember. Back in kdm I can set the kde3 desktop and start it as usual (I’m writing this entry from there).I also updated all the packages this morning and nothing.

Hope you can help me. I wanna try this RC.

Dude, I had the same problem. But no desktop Just grey screen
It would not work for me so I went back to 4.0.4

However, I did get to the 4.1 desktop once, this way.

Re-name your .kde4 folder to .kde4old (the folder is in /home/user* view hidden files)
Ctrl-Alt-Backspace to restart the desktop
Make sure to select 4.1beta
And I could get to a working 4.1 (like a fresh install of course)
But when I tried loging in again, just get blank grey screen.

See what happens for you.

The deal is that I don’t wanna mess up the system. There must be a cleaner way to get the desktop to work.

I forgot to say… immediately after installing the kde basis packages i was able to run the desktop just one time, but it was late in the night so i turned off the laptop, and when I rebooted it kde 4.1 was dead.


Today I found this page : KDE/KDE4 - openSUSE and installed the OCI of KDE 4.1 (not the kde4.1 basis) and the same thing.

I think (remember i’m a noob) there’s something up with konqueror, because I can start a plasma panel, and add widgets to it. I added the clock, the watch and the system tray thought I can’t see the windows i’ve opened in the tray. It wont allow me to change the “widgets” position so they look like in the screenshot.
With kicker I started konqueror and in “about” it says it’s konqueror 3.5. The problem seems to be konqueror.

What I desribed earlier to you was simple enough. It just starts you off with all new settings which can be a simple way to elliminate buggy issues. You can easily revert back by deleting the new .kde4 and re-name .kd4old back to .kde4

The correct repos for 4.1 that everyone is currrently using is:

As I say, your issues are very similar to what I experienced. I’m still with 4.0.4

I did it but it only works once. To use it i’d have to rename/delete the .kde4 foldar everytime i want to.

Same here. I reported this issue to bugzilla @ novel/opensuse

this is their reply to me

“the crash happens if you have old kde 4.0 applets installed and those get still

“do you have any useful output from ~/.xsession-errors upon the 2nd login?”

I haven’t been back and tried again as I rolled back to 4.0.4 for now

This is the whole xsession-errors log (I’m actually posting this from KDE 4.1)


PD: I updated everything a few minutes ago and it still wont fully work.

Thread moved to Pre-Release/Beta

Try going to yast-software management and examine the packages for kde4.x version and be sure all are from the 4.1. There might be missing packages for the 4.1 or left over from your previous kde4.0.4 installation.
I am using the kde 4.1 beta 2. See my new post at the screenshot section

I’ve got the same problem. I have create new account to test if it is problem with configuration in .kde4/, I have installed rpm’s form KDE Factory and the same problem.

Here is my output from plasma crash:
Application: Przestrzeń robocza Plazmy (plasma), signal SIGSEGV
e?1034h(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb59a29e0 (LWP 3816)]
[New Thread 0xb41cdb90 (LWP 3818)]
(no debugging symbols found)
[KCrash handler]
#6 0xb76c044a in KConfigGroup::config () from /usr/lib/
#7 0xb7fc676e in Plasma::Containment::addApplet ()
from /usr/lib/
#8 0xb7fc6980 in ?? () from /usr/lib/
#9 0xb7fc6a59 in Plasma::Containment::addApplet ()
from /usr/lib/
#10 0xb808c112 in DesktopCorona::loadDefaultLayout ()
from /usr/lib/
#11 0xb7fce146 in Plasma::Corona::initializeLayout ()
from /usr/lib/
#12 0xb80990a6 in ?? () from /usr/lib/
#13 0xb809b3cf in ?? () from /usr/lib/
#14 0xb809b4f1 in ?? () from /usr/lib/
#15 0xb808f2ca in kdemain () from /usr/lib/
#16 0x08048802 in _start ()
#0 0xffffe430 in __kernel_vsyscall ()


Ok - i have installed some plasma libs (i think kde-plasma-addons) and its starts to work like a charm :slight_smile:

On Yast I searched “KDE4” (including description) and the results showed me that of all the packages installed, none were less than 4.0.98 version… It seems to be another thing.


Installed Plasma-addons and nothing. Have to say that i haven’t installed the 4.0.5x. I only have KDE3 and KDE 4.1.

Yesterday when trying to get the desktop to work i checked the repositories in Yast. There I realized that the KDE4 Repository was 5 TIMES. Then I deleted all of them, run the KDE 4.1 ymp file to add the repository and install the desktop. When I tried to update I was told that several packages had an unsatisfied dependency: kdebase4-runtime, that was the only kde4.1 package without a 4.0.98 version available (all the rest were). It was late and I got back to work with KDE3. Today I updated all of the packages (like I do every 2 days, it was like a 300MB download) from KDE4. Then I wanted to enter KDE4 so I entered my user folder to delete the .kde4 folder for the system to create a new profile and be able to use KDE4. When looking for such folder I realized that there was no folder. Turned off the computer cause I had a test and the next time I had a working KDE 4.1 desktop from scratch, that initiates normally without renaming or deleting the .kde4 folder. It’s now working.

The only bug it has it’s that Plasma crashes a lot. But remember it’s a Release Candidate!!

PD: When plasma crashes it might be difficult to rearrange the icons cause the panel dissapears. So i create a new panel (wich is always on the top of the screen and I can’t move it. Then I start to add the widgets to create a new bar with all the stuff. I don’t mind cause it just looks so cool.

Right click on panel select panel settings then right click on the bar that appears and a cross appears move the panel where you want it cool. btw kde 4.1 is gonna be sweet and looking forward to opensuse 11.1 alpha fun to begin:D