installed suse 12.2 - no audo after system wake up or hibernate

Hello
I installed suse12.2 on my old DEL 4550 desktop with creative audio card .
output of hwinfo …
4: PCI 201.0: 0401 Multimedia audio controller
[Created at pci.319]
Unique ID: GA8e.OTb4tcqddO0
Parent ID: 6NW+.5o60iem1mwE
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:01.0
SysFS BusID: 0000:02:01.0
Hardware Class: sound
Model: “Creative [SB Live! Value] EMU10k1X”
Vendor: pci 0x1102 “Creative Labs”
Device: pci 0x0006 “[SB Live! Value] EMU10k1X”
SubVendor: pci 0x1102 “Creative Labs”
SubDevice: pci 0x1003
Driver: “snd_emu10k1x”
Driver Modules: “snd_emu10k1x”
I/O Ports: 0xece0-0xecff (rw)
IRQ: 22 (1062 events)
Module Alias: “pci:v00001102d00000006sv00001102sd00001003bc04sc01i00”
Driver Info #0:
Driver Status: snd_emu10k1x is active
Driver Activation Cmd: “modprobe snd_emu10k1x”
Config Status: cfg=yes, avail=yes, need=no, active=unknown
Attached to: #18 (PCI bridge)

I am not able to get audo after the system wakes up or boots back from hibernation.
The only way to solve is reboot.
Any help is appreciated.

You could open up a terminal session after this happens and try these command:

sudo killall pulseaudio ; sleep 3 
sudo killall -9 pulseaudio
sudo modprobe -r snd_emu10k1x
sudo modprobe snd_emu10k1x

If it works, we could put it in a bash script and run it from an autostarted one.

Thank You,

Same problem here on a completely different hardware using snd_hda_intel module. Will file a bug report on this with details. Not using pulseaudio only alsa. It shouldn’t be necessary to restart the driver every time the machine comes up from sleep or hibernation.

service alsasound restart

works for me to restore audio after sleep/hibernation.

Here is how to automate the sound restore after wake up.

Create a file /etc/pm/sleep.d/09alsa with the following content and chmod a+x the file to make it executable.

case "$1" in
         hibernate|suspend)
                # Stopping is not required
                 ;;
         thaw|resume)
                 sleep 1
                /usr/sbin/alsactl restore
                  ;;
         *) exit $NA
                 ;;
esac

hello ,
Thanks for the information.,
I tried to use the 09als file in sleep.d directory , no luck.
The one way is to run the alsasound script in the /etc/rc.d
sudo /etc/rc.d/alsasound reload - this gets the sound back.
but i am not able to figure out how to get this run auto when it comes out of sleep or hibernate.
Also i noticed , If i am running amarok and the system wakes up from sleep , and i reload the alssound the amarok goes to defunct state
there will be a defunct amarok process after i run the alsasound reload.

any one . how to run this automatically when the system comes out of sleep ?

Have you tried putting /etc/rc.d/alsasound reload that works for you manually into the script above instead of alsactl as suggested? You can also try service alsasound restart which should do the same as above.