Installed SATA card, no network?

HI Guys,
Trying to add a sata card so I can add a drive to my system
I bought a sataIII pcie card -->IOcrest brand, using marvell 9215 (4s) chip

and installed it. System booted fine (actually booted faster than normal), but no network (internet) or widget on toolbar.

I rebooted, still no network.

Took out card, system boots fine, including network (internet)

put card into another PC (running linux mint), it works fine there including network.

This is a new one for me, I don’t know where to start.

Any suggestions? Thanks in advance
JOhn Kilbert

card is recognised:

02:00.0 SATA controller: Marvell Technology Group Ltd. Device 9215 (rev 11)

network config:

RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (Not connected)
MAC : 00:50:99:99:2f:23
BusID : 0000:06:00.0
Device Name: enp6s0

The device is not configured. Press Edit to configure

without card:

RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
MAC : 00:50:99:99:2f:23
BusID : 0000:05:00.0

Device Name: enp5s0
Started automatically at boot
IP address assigned using DHCP

I never had to configure the network, it automatically worked , not sure why its different with the card?

Because the NIC gets a different PCI ID, hence a different Device Name.

How do I get it to reconfigure?

You have a choice:

  1. You can reconfigure via YaST > Network Settings…
  2. Use the following to get the current network device name
ip a

and rename the /etc/sysconfig/network/ifcfg-*** name to match the name of the interface. Then restart wicked.

sudo systemctl restart wicked

Awesome, thank you

My pleasure :slight_smile: