Installed opensuse leap 42.2 - kde, windows 7 not in grub menu

Hello all. I had windows 7 installed and opensuse leap 42.1

I deleted all my linux partitions. The grub menu doesn’t show a windows 7 boot entry.

How do I add it into the grub menu?

Hi
Via YaST Bootloader, is the box check to probe for other operating systems?

Does it see it manually with the command (as root user);


os-prober

Note all OS must use the same boot method, either MBR or EFI, If you mix you can not chain between them.

Just quoting for emphasis. This is the most likely explanation of the problem.

I found that online and found that no effect. Here’s the order it happened.

Windows 10 and opensuse 42.1 dual boot.
Installed windows 7. Boots to win7.
opensuse 42.2 update install. Boots to win7.
gparted –> deleted ‘system reserved’
boot to opensuse with no entry for win7.

This doesn’t run EFI boot. It’s too old. I setup it up to boot from the MBR not the root directory.

Update:

Win7 install DVD–> fix mbr
opensuse leap 42.2 update install

Win7 now appears. :slight_smile:

On this BIOS 2010 setup, should I boot to the root partition?

Depends. Where is /boot. The boot flag should be on the partition that /boot in it. normally this should be the root partition but it could be different.

If the root partition is in an extended then the flag should be on the extended and grub should be also installed there. Assuming generic boot in the MBR unless you install grub code in the MBR then the boot flag does not matter.