Installed opensuse 13.2 but no wifi

Hi all,
I have finished installing my opensuse 13.2 and it really looks great.
Unfortunately my wifi was not visible once the pc booted (it is an external usb wifi module).

My hack was to do the following in console:

  1. go root mode
  2. launch /usr/sbin/NetworkManager
  3. from the launched applet in the kde I picked my wifi card and picked my access point and connected
  4. I noticed that my internet was not working so
  5. In the network managers gui in the dns menu I added my routers ip
  6. who for example did not work
  7. Then I did one more hack I added in my etc/resolv.conf the line nameserver # my routers ip address
  8. then my who was working
  9. then I found though that internet was not still perfect. I did not have an entry in route -n
  10. through the network applet gui I added the route
  11. currently internet works and I can write you this message
  12. although I have to repeat this process every time my pc boots.

What should I do in a “clean” way to make this working always?

I would like to thank you for your reply

Change the networking from wicked to Networkmanager in Yast - Networksettings, remove /etc/resolv.conf

Thanks. I went to yast and I found it disabled it. Yast asked me to install packages and I did. Still the service was not running but I enabled it through the Yast Services.
I also removed the line I had in the etc resolv.conf

Now each time I go to yast network it gives me the message that the network manager is running the show. Although still no internet connection…

what I am doing wrong?


I didn’t say “remove the line from …”, but “remove /etc/resolv.conf”
The hard thing now is that I cannot see what you tried manually.

Which desktop is being used?